PRIME After Effects
User Guide
Version 5.1

March 2025

C

SINCE
ONE.



Chyron PRIME After Effects User Guide + 5.1 « March 2025 « This document is distributed by
Chyron in online (electronic) form only, and is not available for purchase in printed form.

This document is protected under copyright law. An authorized licensee of Chyron PRIME After
Effects may reproduce this publication for the licensee’s own use in learning how to use the
software. This document may not be reproduced or distributed, in whole or in part, for
commercial purposes, such as selling copies of this document or providing support or
educational services to others.

Product specifications are subject to change without notice and this document does not
represent a commitment or guarantee on the part of Chyron and associated parties. This
product is subject to the terms and conditions of Chyron's software license agreement. The
product may only be used in accordance with the license agreement.

Any third-party software mentioned, described or referenced in this guide is the property of its
respective owner. Instructions and descriptions of third-party software is for informational
purposes only, as related to Chyron products and does not imply ownership, authority or
guarantee of any kind by Chyron and associated parties.

This document is supplied as a guide for Chyron PRIME After Effects. Reasonable care has
been taken in preparing the information it contains. However, this document may contain
omissions, technical inaccuracies, or typographical errors. Chyron and associated companies
do not accept responsibility of any kind for customers’ losses due to the use of this document.
Product specifications are subject to change without notice.

Copyright © 2025 Chyron, ChyronHego Corp. and its licensors. All rights reserved.

2 | PRIME 5.1 After Effects User Guide Chyron®



Table of Contents

INErOAUCHION... .. 4
How to create the AE Script file.......... e 4
Using the converter script in AE............co i 5
RUN the SCIIPL fil. ..ttt e e 5
INstall the SCriptfile... ..o e e e e e e e e e e e e e e e e eeeeeees 6
Exporting from After Effects........cccccoiiiiiiicii s 8
b q e o @ o 4o 1= P 8
L T=T T = | PSR 8
0= Y S 9
LI =T o T L= SRR 11
IMmporting to PRIME...........oo et 12
[a] oToT 3 o] o)1 4] o 1= PP 12
K571 o o] o = o 13
=T ] A o] Ve 1 o = 14

3 | PRIME 5.1 After Effects User Guide
Chyron



Introduction

Compositions created in Adobe After Effects can be exported from AE and then imported into
PRIME. Minimum requirements are PRIME 4.0 and Adobe After Effects 2020.

This is a two step process.

1. An After Effects script file exports the AE composition information to a JSON file.
2. From PRIME users can then import the JSON file to create the scene

Any unsupported After Effects elements or effects are rendered as movie files which can be
imported into the PRIME scene. See supported section for more details.

How to create the AE Script file
The After Effects converter script file can be generated within Prime Designer.

1. Select, File > Import AE. The Import AE JSON dialog will open.
2. Click on “Save AE Converter Script” to generate and save the script file “AE Comp
Converter.jsxbin”.

3 Import AE JSON — O

Save AE Converter Script Script Version v0.94
Choose File...
Create Group

Type | Mame | Import Object | Import Rendered Movie

Cancel

Once the AE script file is saved you can now proceed to use the script file within After Effects.
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Using the converter script in AE
There are two ways to execute the script from AE

1. Run the script file
2. Install the Script file (this will install it as part of AE user interface for access anytime)

Run the Script file
File > Scripts > Run Script file

BB Adobe After Effects 2020 - Untitled Project.aep
File Edit Composition Layer Effect Animation View Window Help
New >
Open Project... Ctri+0
Open Team Project...
Open Recent >
Browse in Bridge... Ctrl+Alt+Shift+ O

Close Ctrl+W
Close Project

Save Crl+5
Save As >
Increment and Save Ctrl+ Alt+Shift+5
Revert

Impert >
Import Recent Footage

Export >
Add Fonts from Adobe...

Adobe Dynamic Link

Find Ctri+F
Add Footage to Comp Ctrl+/
New Comp from Selection... Alt+)

Dependencics
Watch Folder...

Seripts > Run Script File...

Create Proxy Install Script File.

Set Proxy Install ScriptUl Panel...

Interpret Footage Open Script Editor

Replace Footage Recent Script Files N

Navigate to the script file “AE Comp Exporter.jsxbin”

mOpen X
™ » ThisPC » ChyronHego 2 () » After Effects w (] Search After Effects
Organize ¥ Mew folder =y O @
~
J’! Music ~ Mame Date modified
=] Pictures Adobe After Effects Auto-Save /202111:54 PM

Mo preview

P W

B videos Finals 2 04 AM | available.
i 0S(C) | | AE Comp Exporter.jsxbin 2 )21 10:48 PM
S#d CD Drive (D:) RTL_UL v € >

File name: |AE Comp Exporterjsxbin v| All Acceptable Files (*jsx;* jsxb

1. Click Open
2. PRIME Comp Export Dialog opens (see Exporting from After Effects below)
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Install the Script file
File > Scripts > Install ScriptUl Panel

E Adobe After Effects 2020 - I\After Effects\Sample Lower Third\Sample Lower Third\Sample Lower Third.aep ™

File Edit Composition Layer Effect Animation View Window Help

New

Open Project...
Open Team Project...
Open Recent

Browse in Eridge...

Close

Close Project
Save

Save As

Increment and Save

Ctrl+0

Ctrl+Alt+Shift+0

Ctrl+W

Ctrl+S
>
Chrl+Alt+Shift+5

Revert

Import >
Import Recent Footage
Export >

Add Fonts from Adobe...

Adobe Dynamic Link

Find Ctrl+F
Add Footage to Comp Cirl+f
Mew Comp from Selection... Alt+,
Dependencies >

Watch Folder...

Scripts > Run Script File...

Create Proxy s Install Script File...

Set Proxy Install ScriptUl Panel... l}

Interpret Footage Open Script Editor

Restart the Adobe After Effects application

From the Window menu, select “AE Comp Exporter.jsxbin”
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Window Help
Workspace
Assign Shortcut to "Default” Workspace

Find Extensions on Exchange...
Extensions

~  Align

~  Audio
Brushes

~  Character

~  Content-Aware Fill
Effects & Presets
Essential Graphics

~  Info
Learn
Libraries
Lumetri Scopes
Mask Interpolation
Media Browser
Metadata
Meotion Sketch
Paint

~  Paragraph

~  Preview
Progress
Smoother

~  Tools

~  Tracker

Wiggler

~  Composition: (none)
Effect Controls: (none)
Flowchart: (none)
Footage: (none)
Layer: (none)

~  Project

+  Render Cueue

Timeline: (none)

Create Mulls From Paths.jsx
VR Comp Editor.jsx
AE Comp Exporter.jsxbin

Ctrl+4

Ctrl+9

Ctrl+6

Ctrl+35

Ctrl+2

Ctrl+8
Ctrl+7
Ctrl+3

Ctrl+1

Ctrl+0
Ctrl+Alt+0

The Exporter dialog, is now a dockable window within After Effects (see below for Exporting

from After Effects options)
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Exporting from After Effects
Export Options

AE Comp Exporter dialog has various options

General

AE Comp Exporter =

General

Destination: the location of the JSON file and rendered layers
Export Composition Mixdown: This will mix all Audio tracks into a single mixed .aif file

Render Masks: Check this box to render all masks that are assigned to render the layers
section. When unchecked no masks will be rendered, even if they are set to render in the
Layers section.

After applying all General, Layer and Transcode preferences, hit PROCEED to generate the
JSON file.
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Layers

AE Comp Exporter =

Layers
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Composition Layers

The Layers menu displays each layer within the selected composition and what it contains with
regards to the export, for instance, the Media type and whether it contains Animation, Effects
and/or Masks.

This list also determines what will be exported to the JSON file and what layers will be rendered
out as separate files (the format preferences for rendered content is set in the Transcode
section).

By default, layers that contain unsupported Effects, a Mask and/or a Track Matte are
automatically set to render the content of that layer. Users can override the default settings by
using the + or - for both Export (E) and Render Content (RC) settings. Overridden settings are
indicated with (!).

Overrides can be cleared or reset back to the default setting anytime using the ‘Clear all
overrides” button for the entire composition or select the desired layer/s and hit “Clear layer
overrides”

Each composition referenced by the composition being rendered will render as a separate
movie file. To import them with their own objects and animations each composition should be
exported separately.

Only layers marked as E (Export to the JSON) will have the render option available. The file
location for rendered content is set in the General tab. Any file format that is already supported
by PRIME does not require rendering as the original file path will be written to the JSON file
when that layer is set to be exported.

Masks

Masks are automatically rendered out as a separate additional file by default, either as a still file
or animated as required. However, basic rectangular shaped masks (including the animation)
can be imported natively into PRIME. Override this default setting when exporting if desired.
PRIME creates the mask using 4 clipping planes.
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Transcode

AE Comp Exporter =

Best Settings

Photoshop

AIFF 48kHz

Apply the preferred render formats for all file types
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Importing to PRIME
Import options

File > Import AE
{1 Import AE JSON — ] X

Save AE Converter Script
Choose File...

¥ Create Group  FsBulletslmage

Typ Mame rnport t| Import Rendered File | Crea

comp Header 4
comp  Bullet Points L

shape i sk v

shape Shape Layer 1

shape Shape Layer 2
image Image_Headshot
comp Cyan Solid 1 Comp 1
shape Video_Mask

comp  Video_1

shape Backplate

comp  Background

Cancel

Select a JSON file. If Create Group is unchecked, then all layers will be imported into PRIME'’s Scene
Group. Alternatively, if Create Group is checked, then all layers will be imported into a newly created
group within Prime’'s Scene Group. Imported elements appear at the currently selected Scene tree
object.

All objects appear in the list for the associated selected JSON file. A user may select elements they
wish to import as either an object or rendered movie. If a layer was rendered to a movie by the AE
converter script, the Import Rendered Movie checkbox will be available for that layer. Unchecked
layers are not imported.

Compositions are imported into PRIME'’s Default Action

Create Replaceable - Starting in Prime 5.0, users can now immediately create Prime replaceables for
Text, Images, and Clips upon Import of the AE json project file.
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Supported

Images o File (All PRIME supported file formats)
Videos e Size
Audio
Animations e Linear
e Ease
*Bezier with simple Influence is converted to Eases
Text e Font
e FontSize
e FillColor - Color
e boxText - WordWrap
e boxTextSize (Size if boxText is enabled)
e boxTextPos (Pivot/Position if boxText is enabled)
e Leading
Camera e Not currently supported
Lights e Not currently supported
Masks e Rectangle Mask
e Track Matte
o Set Matte Effect
*Rectangle and Matte Effects are converted to 4 clip planes in PRIME
maintaining animation
*Feathered and unsupported masks are converted to Images or Video
files
Shapes e Rectangle
e Fill
Groups e Child Objects
AE Layer Attributes e Enabled
e Transform
e Scale
e Anchor Point
e Opacity
AE Solid e Size
e Color
Timelines e A single timeline composition

13 | PRIME 5.1 After Effects User Guide
Chyron



Best practices
Ensure the output resolution and frame rates are the same in both PRIME and AE.
Convert text imported from a PSD file into editable text in After Effects. Select the PSD
text on the AE timeline, right click, and select Create > Convert to Editable Text. This

ensures the text imports as editable text in PRIME.
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ABOUT US

Chyron is ushering in the next generation of storytelling in the digital age. Founded in 1966, the
company pioneered broadcast titling and graphics systems. With a strong foundation built on
over 50 years of innovation and efficiency, the name Chyron is synonymous with broadcast
graphics. Chyron continues that legacy as a global leader focused on customer-centric
broadcast solutions. Today, the company offers production professionals the industry’s most
comprehensive software portfolio for designing, sharing, and playing live graphics to air with
ease. Chyron products are increasingly deployed to empower OTA & OTT workflows and deliver
richer, more immersive experiences for audiences and sports fans in the arena, at home, or on
the go.

CONTACT SALES

EMEA - North America * Latin America * Asia/Pacific
+1.631.845.2000 - sales@chyron.com

Chyron.
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