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Minimum Requirements 
●​ PRIME 5.2.0+ with appropriate licensing 
●​ Adobe After Effects 2025 Version 25.3.2 (Build 2) and higher 

○​ AE versions before 25.3.2 (Build2) are incompatible with Prime AE Exporter v2.0 
 

Prime AE Exporter v2.0 is only compatible with PRIME 5.2.0+​
Prime AE Exporter v1.0 is only compatible with PRIME 4.0.0 - 5.1.2​
​

​
​
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Introduction 

Supported After Effect compositions can be imported into PRIME by utilizing the Prime AE​
Exporter v2.0. Please see the documentation below for supported AE objects.​
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Obtaining Required Install Files 

The After Effects exporter script and AE Output Module Template files can be obtained from 
within Prime Designer. ​
 
Launch PRIME 5.2.0+ 

●​ Open PRIME Scene Designer 
●​ Select File > Import AE 
●​ The Import AE JSON dialog will open 
●​ Click on “Save AE Exporter Script” to save the script file “Prime AE Exporter 

v2.0.jsxbin” 
●​ Click on “Save AE Output Module Templates” to save the template file​

“AE Output Module Templates v2.0.aom”. 
○​ Once both files have been saved to your desired hard drive location, you can 

proceed to the next section of this document which covers installing the files 
within After Effects. 
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Install Prerequisite | AE Application Scripting Option​
Prior to installing the PRIME AE Exporter Script, users must enable the AE Application 
Scripting option. If it is not enabled, users will be prompted with the following message 
when attempting to install the script.​
​

   

●​ Launch After Effects 

●​ On the top title bar, click Edit  ->  Preferences  ->  Scripting & Expressions 

●​ Enable (check) “Allow Scripts to Write Files and Access Network” 

●​ Click OK​
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Installing vs. Running the Converter Script in AE  
There are two ways to execute the script from AE  

1.​ Install the Script file via ScriptUI (this will install it as part of AE user interface for access 
anytime) *This is the recommended method as it provides best results​
 

2.​ Run the script file 

​
Install Method 1 | Installing the Script file *Recommended Method 
File > Scripts > Install ScriptUI Panel 

​
 

***You must restart the Adobe After Effects application after installing the Script in order 
for it to run properly.*** 
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After restarting After Effects, navigate to the Window menu and select​
Prime AE Exporter v2.0.jsxbin at the bottom of the menu. 
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Install Method 2 | Running the Script file 
File > Scripts > Run Script file 

 

Navigate to the script file “Prime AE Exporter v2.0.jsxbin” 

 
1.​ Click Open 
2.​ PRIME Comp Export Dialog opens (see Exporting from After Effects below) 
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Installing the Prime AE Output Module Templates 
Within After Effects, navigate to Edit > Templates > Output Module​
​
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Selecting Output Module will bring up the following Output Module Templates Window 

​
​
Next, select Load in the bottom left and open the Prime AE Exporter v2.0 Output Module 
Templates.aom file in the location you saved it.​
​

​
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The Prime AE Exporter v2.0 Output Module Templates.aom file contains 3 templates which 
have been custom created for video clips and audio files to work as intended within PRIME 
5.2.0+ 

●​ High Quality with Alpha No Audio 
○​ QuickTime Apple ProRes 4444 
○​ RGB+Alpha 
○​ Millions of Colors+ 
○​ Premultipled 
○​ Output Audio = Off​

 
●​ High Quality without Alpha No Audio 

○​ QuickTime Apple ProRes 422 HQ 
○​ RGB (Fill Only) 
○​ Millions of Colors+ 
○​ Premultipled 
○​ Output Audio = Off​

 
●​ WAV 

○​ Wav files for audio mixdown use 
​
Users are more than welcome to create and set their own custom made templates using After 
Effect’s Output Module Template Dialogue to use within the Transcode section of the exporter. 
These Output Module Templates have been provided to give users a quick and easy setup.​
​
Please see the Transcode Tab Section below for information on how to set Transcode settings prior 
to exporting from AE.​
​
*Please Note - The WAV Output Template is Required in order for the Audio mixdown to work 
properly. This template must be named WAV in order to work and function properly with the exporter. 
 

Saving AE Prime Exporter Settings 

Saving your AE Project will also save the Exporter settings and any overrides a user has set per 
project. If a user fails to save the AE project, those selections will be lost.  
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PRIME Supported AE Objects 
Images 
Videos 

●​ File Format (All PRIME supported file formats) 
●​ Size 

Audio ●​ .WAV files 
○​ PRIME only supports .wav audio files 
○​ Designers will need to manually import .wav files into 

PRIME using the Audio Resource or Effect 
○​ *Please see the audio section for further details 

Timelines ●​ Main and Secondary (Precomp) Compositions Only 

Precomps ●​ Supported (Only the first child precomp is supported) 
○​ *Please see the Precomps section for further details 

Animations ●​ Linear 
●​ Ease  

 
*Bezier with simple Influence are converted to Eases 

Text ●​ Font 
●​ FontSize 
●​ FillColor - Color 
●​ boxText - WordWrap 
●​ boxTextSize (Size if boxText is enabled) 
●​ boxTextPos (Pivot/Position if boxText is enabled) 
●​ Leading 

Camera ●​ Not supported 

Lights ●​ Not supported 

Expressions ●​ Not supported 

Masks *Support Varies 
●​ Rectangle Mask 
●​ Track Matte 
●​ Set Matte Effect 

*Rectangle and Matte Effects are converted to 4 clip planes in PRIME 
maintaining animation  
*Feathered and unsupported masks must be converted to Images or 
Video files 

Shapes ●​ Rectangle 
○​ Fill 
○​ *Please see the Shapes section for further details 

Groups ●​ Child Objects 
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Parent & Link ●​ Support will vary - Linked layers import with Prime’s Transform 
Effect with baked keyframes 

AE Layer Attributes ●​ Enabled​ ​  
●​ Transform 
●​ Scale  
●​ Anchor Point  
●​ Opacity 

AE Solid ●​ Size 
●​ Color 

 
 
Recommended Building Practices 

●​ Ensure the output resolution and frame rates are the same in both PRIME and AE.​
 

●​ Convert text imported from a PSD file into editable text in After Effects. Select the PSD 
text on the AE timeline, right click, and select Create > Convert to Editable Text. This 
ensures the text imports as editable text in PRIME.​
 

●​ Video Clips in PRIME​
Please keep in mind that Chyron PRIME is a Real-time Platform unlike Adobe After 
Effects. Due to this, too many video clips will have a major impact on PRIME’s Real-time 
performance capabilities. This also includes any PRIME Base Scenes with video clips 
that are being referenced in the primary PRIME Scene (.pbx). Heavy clip usage may 
require tweaking Advanced Clip Settings within PRIME. Results will vary depending on 
your computer’s capabilities. 

○​ Please take note - Existing PRIME scenes with clips should be closed in PRIME 
before another AE export is executed to the same folder. If PRIME is reading 
from the same clips you are trying to re-export, the render will fail since the 
computer is accessing those files in PRIME, Prime Engine, or another 
application. 
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Docking the Exporter within After Effects 
The Exporter can be a docked window within After Effects but only if a user installs it using the 
ScriptUI (Method 1). Running the Script (Method 2) does not support docking and will always 
present as a floating window. 
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Operating the Prime AE Exporter v2.0 Script 
The Prime AE Exporter has four primary tabs and various options to choose from within each.​
The details below cover each to allow for best results and easiest user experience. 

General Tab 

 

Destination directory: Save location for JSON and rendered files from Render Queue​
​
Create a subfolder named after the exported composition: Automatically creates and stores 
all exported files into a subfolder within the selected destination folder. Subfolders will inherit the 
primary exported composition’s name.​
​
User starts rendering: Enables manual user interaction of executing the Render Queue export 
and creating the .JSON export file. *Recommended export method and is enabled by default​
​
Export Composition Mixdown: Mixes all Audio tracks into a single .wav file​
​
Render masks and mattes by default: Always renders all mask layers as a clip. When 
unchecked, masks will only be rendered if they are set to RM or +RM under the Mask Column 
per layer.​
​
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Layers Tab 

The Layers tab displays many options as well as your selected composition’s layers within the 
composition layers section. 

Layer properties determine what will be exported to the JSON file and what layers will be 
rendered out as separate files (the format preferences for rendered content is set in the 
Transcode tab section).  

 

 

18 | PRIME 5.2 After Effects User Guide​ ​ ​ ​ ​ ​ ​

​ ​ ​ ​ ​ ​      



 

​
​
Users can override the default settings by using the + or - buttons at the top of the Layers 
Top. Overridden settings are indicated (!) 

Unsupported After Effects layers, objects, elements, effects, etc. can be rendered as movie 
files which can then be imported into PRIME. Please see the Supported Objects section for 
more details.​
​
Export layer to JSON 

(+E) Exports the layer and includes it within the JSON file to be imported into PRIME 

(-E) Excludes the layer and will not be imported into PRIME​
​
​
Render layer Content 

(+RC) Renders the layer as a video clip or image (only an image if the layer is not animated). 
Anytime +RC or RC is labelled under the Export Content column, that layer will be rendered as a 
video clip using AE’s Render Queue and will use the Transcode settings. Please see the 
Transcode Tab for further details. 

(-RC) Prevents or reverses the layer from being rendered as a clip.​
Needed in circumstances where a video clip, precomp, or other layers are automatically set to 
RC (!). Invoking the (-) or (-!) states under the Exporter Content column will result in the same 
behavior as -RC.​
​
​
Render Masks and Mattes 

(+RM) Renders the Mask or Track Matte as a video clip 

(-RM) Prevents the Mask or Track Matte from being rendered as a video clip 

 

Precomp 

(+P) Sets the Precomp layer to Import into PRIME as a Base Scene 

(-P) Sets the Precomp layer to (+RC) thus Rendering the Precomp as a video clip  
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Exported composition​

 
Displays the Primary (Master) Composition the user intends to Export out of AE and Import into 
Chyron PRIME. If a composition is not present, please select the desired composition from the AE 
Project Bin, and click << Load Active Comp to load the composition into the Export Script. 

​
Overrides 
Overrides can be cleared or reset back to the default setting anytime using the ‘Clear all overrides” 
button for the entire composition or select the desired layer/s and hit “Clear layer overrides” 

​
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Precomps 

Precomps (P), can be exported out of AE and imported into Prime 5.2+ as a Base Scene or 
Rendered Content. Media and Export Content must be labeled P in order for the Base Scene to 
be generated in PRIME upon import. If a Precomp (P) Media Type has its Export Content set to 
(+RC), the Precomp will be rendered and imported as a video clip into Prime. Please make sure 
your transcode settings are set properly before rendering content.​
​
Only the first level nested precomps are supported as PRIME Base Scenes. Second level 
nested Precomps will automatically be set to Rendered Content (RC) for Precomps inside 
Precomps and rendered as video clips to be imported into PRIME.​
Users can not see beyond the 2nd level of Precomps and only the 1st level of Precomp will 
display all layers like the primary export composition within the Prime AE Exporter Script. 
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Navigating Precomps 

There are two ways to navigate through Precomps within Prime AE Exporter v2.0​
​
Method 1​
Double click a layer labeled P under Media that also shows a dropdown arrow next to the layer 
number..​

​
​
Doing so will drop down the layer contents within that Precomp.

​
​
​
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Method 2​
Select the Precomp within the Layers you wish to open and click the Open Precomp button 
located towards the bottom of the Exporter.​

 

Selecting Open Precomp  will isolate the Precomp which allows users easier navigation and 
focuses on just that Precomp and its contents. Users can set all the same options like in the 
primary Export Composition. Precomp settings will be saved when users go back and forth 
between precomps and the main export composition. Please make sure to save your AE project 
to retain Exporter layer selections. 

​
​
To return to the primary parent export composition, please select one of the following buttons, 
Back or Back to Parent.​
​

        or        
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Masks 

Masks can be automatically rendered out as a separate additional file by default, either as a still 
file or animated as required. Please see the General Tab Section for more information about the 
Render masks and mattes by default option.​
​
Basic rectangular shaped masks (including the animation) can be imported natively into PRIME. 
Override this default setting when exporting if desired. PRIME re-creates the mask using the 
different methods below.​
​
The following Masks are supported: 

●​ Rectangle Mask (Clip Plane Effect in PRIME) 
●​ Track Matte (Mask Effect in PRIME) 
●​ Set Matte Effect (Clip Plane Effect in PRIME) 

​
*Rectangle and Set Matte Effect are converted to 4 clip planes in PRIME maintaining animation  
*Feathered and unsupported masks must be converted to Images or Video files. The Mask 
Effect will be used in Prime. Please make sure these layers are set to +RM. 
 
Set Matte Effect requires the use of a solid layer with a mask applied on the solid layer like in 
the photo here.​

 
 
*Please Note - AE to Prime mask compatibility / import results can and will heavily vary 
depending on AE composition complexity and setup.  
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Mask Column 
●​ (M) Mask 

○​ Clip Plane Effect in Prime will be applied to the object if the object is also fully 
supported. Otherwise, users are encouraged to mark this layer as +RM to render 
the mask as a clip.​
 

●​ (T) Track Matte  
○​ Mask Effect in Prime will be applied to the object if the object is also fully 

supported. Otherwise, users are encouraged to mark this layer as +RM to render 
the mask as a clip.​
 

●​ (T/M) Track Matte + Mask on the same layer 
○​ Supported objects will attempt to use the M and/or T Prime supported mask 

features above. If you are having difficulties with T/M, we recommend only using 
one supported mask type at a time per mask layer setup. Another option is to 
render T/M masks out as a mask clip (+RM) in order to import your masks into 
PRIME.​
 

*Please Note - Compositions and Precomps can have a mix of Masks and Track Mattes. Too 
many masks or mask clips in Prime can and will cause real-time performance issues.​
 
 
 

​
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Transcode Tab 

 

Please select the preferred templates for all file types 

●​ Please see the Prime AE Output Module Templates Section of this guide to install and/or 
create your own output templates. 

*Please Note - Confirming the proper Transcode preset and settings are set is required prior to 
exporting your AE Composition. Transcode presets and settings can vary greatly and we recommend 
always checking these settings before exporting. 
​
Render Settings 

●​ Best Settings is the default and preferred Render Settings for the Exporter 

​
Files with and without alpha channels (Video Clips) 

●​ Several preset options available 
○​ High Quality with Alpha No Audio and High Quality without Alpha No Audio 

Output Templates work well with PRIME. 
■​ QuickTime ProRes Clips in PRIME especially if the video requires an 

Alpha Channel. 
○​ H.264 (.mp4) files are also very performant but do not allow for alpha. 
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*Please Note (audio with rendered clips) - if you select a Template which allows the audio to 
be rendered with your video clips, any and all enabled audio in the composition’s tree will be 
included within each and every video clip rendered. The provided Output Templates are 
specifically configured to not export the audio. 

 

Images and static layers 

●​ PNG 
○​ Makes all images and static layers individual .png files (Recommended) 

●​ TIFF Sequence with Alpha 
○​ Makes all images and static layers individual .tiff files 

●​ Photoshop 
○​ Makes all images and static layers individual .psd files 

Audio Mixdown 

●​ WAV 
○​ Currently, PRIME only supports .wav files 

■​ The Audio Mixdown template must be named WAV in order to work 
and function properly. Please use the provided WAV Output Template 

​
If you are experiencing Prime performance issues - please reduce the number of clips being 
used at once or use different PRIME supported codecs within your Prime Scene and Base 
Scenes.  
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Help Tab 
Provides users with the Legend and a Quick Help Guide if needed while using the Exporter 
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Exporting your Composition​
Once you are finished with creating and optimizing your AE to PRIME project and you have 
confirmed and applied all General, Layer and Transcode selections / preferences, please 
navigate to the Layers tab and select EXPORT COMPOSITION. The composition name loaded 
into the Exported Composition within the script will display itself so users know which primary 
composition they are exporting. This is the composition that will be imported as a .pbx into 
PRIME.​
​

​
​
Clicking the EXPORT COMPOSITION button will immediately queue up any videos that need to 
be rendered into the After Effects render queue. If the AE render queue already has files 
pending to be rendered, a prompt will appear to confirm the queue can be cleared. Once all 
videos have completed rendering, the exporter will generate the JSON file. Please see the two 
different export methods below for step-by-step instructions. 

​
​
​

Export Methods 
There are two different Export workflows a user can utilize with the Prime AE Exporter v2.0 
Script. Under the General Tab you will find an option named, User starts rendering.​
This is enabled by default and at this time we recommend keeping this enabled for the best 
experience. Saving your project will save any and all user defined settings to the Prime AE 
Exporter. The “Automatic Mode” sub-section below outlines why we do not recommend users 
use this as their workflow experience at this time.  
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User starts rendering (Checked by Default) 

*Highly Recommended Method 

User starts rendering will enable a manual export process requiring users to interact with the AE 
UI/UX during the export process. Users will be required to start the Render Queue and export the 
.JSON file manually. 

 

1.​ Confirm User starts rendering is checked under the General Tab​

​
 

2.​ Select Export Composition​
​

​
 

3.​ The After Effects Render Queue will be focused and any rendered content (video clips, 
images, and audio) will automatically be added to the render queue based on your layer 
selections. Each queued render will use the appropriate Transcode Tab settings users 
set up at the beginning of this document. The following message will pop up informing 
you to click Render in the Render Queue.​
 

a.​ Click OK​
​

​
 

b.​ Select Render in the AE Render Queue.​
This will begin rendering your video and audio files to the destination folder set 
under the General Tab.​

​
​
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​
​
 

4.​ Once Rendering is complete, Select Finalize Export to generate the .JSON file​

​
 

5.​ If Successful, the JSON file will have been written to the specified destination folder 
under the General Tab and the following prompts will appear.​
Hit OK.​
 

6.​ Please see the Importing to PRIME section below to continue next steps.​
​

 

 

​
Reset Execution​

​
​
If you encounter an issue prior to Finalizing the Export, please select Reset Execution to start 
the Export process over. 
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User starts rendering 
(Unchecked \ Automatic Mode) 

When User starts rendering is Unchecked in the General Tab, this enables the automatic 
exporter workflow which was the default experience previously in the original 1.0 version of 
the AE Comp Exporter.​
​
Automatic Mode will automatically queue up and render the video\audio files setup within 
your Layers Tab and then export the .json file once rendering has completed.​
​
The Exporter will display a Rendering… status during export​

​
​
However, There are two known issues with this workflow which Chyron is working with 
Adobe to fix at a later time. This is why we highly recommend using the Manual (checked 
mode) at this time. 

●​ Issue 1 - The Render Queue will not display the real-time render status or % while 
rendering​

​
 

●​ Issue 2 - AE might appear washed out with (Not Responding) in the Title Bar and 
appear like it is crashing. AE should not actually crash and is actually rendering the 
videos in the background. 

​
 

When using Automatic Mode, please be aware of these two issues. Even though AE looks 
unresponsive, your system should render the content and export the .JSON file.​
Please give the system time to do its job depending on how many files you are rendering.
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Importing into PRIME  
Import options 
​
File > Import AE 

​
​
All objects appearing in the list for the associated selected JSON file. A user may select 
elements they wish to import as either an object or rendered file. If a layer was rendered to a 
clip by the AE exporter script, the Import Rendered File checkbox will be available for that layer. 
Unchecked layers are not imported. 

Animations are imported into PRIME’s Default Action for Prime and Base Scenes 

Create Replaceable - Starting in Prime 5.0, users can now immediately create Prime 
replaceables for Text, Images, and Clips upon Import of an AE json project file. 
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Precomps will be labeled under Type as comp and will be imported either as a Rendered Video 
Clip or a Base Scene, depending on the options selected during the AE export process. 
​
Three Base Scene options are available: 

●​ Create New 
○​ Creates a brand new Base Scene that does not exist within the Project Folder 

●​ Use Existing 
○​ Uses the existing Base Scene that is named the same and already exists within 

the Project Folder 
●​ Overwrite Existing  

○​ Overwrite a Base Scene that already exists within the Project Folder  
​
Unless Use Existing is selected, after importing - Base Scenes will automatically be saved to disk 
and then opened in Prime Scene Tabs. Please make sure to Save your Prime Scene after importing.​
 
Turning a Base Scene with Existing or Overwrite Options into a New Base Scene upon Import​
When importing your JSON file, if a Base Scene already exists with the same name which you are 
attempting to import, the Options dropdown will only display Use Existing or Overwrite Existing.​
​
File Name Column file names are editable during import - double clicking the File Name itself per 
layer, designers can modify the name of the Base Scene and the importer will create a new Base 
Scene instead.​
​

 

​
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Sorting Layers 
Users can click on the Column Headers to sort by ascending or descending order. This will not affect 
the PRIME Scene Tree layer order during import into PRIME. 
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Troubleshooting 
●​ If any rendered content is not found in its destination folder, a pop up will appear 

informing you that it has not been rendered. This could also happen if Finalize Export 
was clicked before the render queue had time to complete.

 

 

●​ If a rendered file already exists in the Destination directory, the following message will 
appear alerting the user. 

 

●​ If your AE Composition is having difficulty importing into PRIME, please see the PRIME 
Supported AE Objects section of this document. We recommend users simplify and 
optimize needed compositions made in After Effects in order to import into PRIME as 
well as to maintain best performance due to PRIME’s Realtime Engine capabilities. 
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