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Chapter 1: Welcome 

About the PRIME Live Platform 
PRIME Switcher is an important module of the PRIME Live Platform, a common 
foundation for a complete ecosystem of production modules that you can use to 
assemble your ideal workflow. With software-defined architecture and floating I/O 
resources, you can layer your production modules of choice over any PRIME 

engine on the fly - each providing intuitive control interfaces, consistent design tools, and 
integrated, file-based efficiency. 

●​ Flexible, customizable, and scalable: Chyron’s pioneering PRIME Live Platform 
bridges your legacy workflows with the future of live content creation and distribution. 
PRIME’s dynamically flexible, customizable, and scalable live production engine 
provides the functionality and resources to meet your production requirements. 

 

●​ Unified Platform: Since all PRIME production tools exist on the common foundation of 
the PRIME Live Platform, they seamlessly integrate into a customizable unified 
production interface. 

●​ Open Ecosystem Flexibility: Interoperable with devices from most industry vendors, 
PRIME can adapt to your requirements and existing infrastructure for automated or 

​
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manual workflows. Supported protocols include Chyron Intelligent Interface®, AMP, 
EAS, PBus, VDCP, Ross Talk, XML, and Oxtel. 

●​ Wide Range of Standards and Formats: Combine the SDI, IP, NDI, H.264-stream and 
H.265-stream signals you need to capture and deliver content across all channels; and 
take it to air in the SD, HD, UHD-4K, SDR/HDR, IP, GPU, and H.264/H.265 formats of 
your choice. See Function and Specification Overview for details. 

●​ Environment-Agnostic: With PRIME's cloud-enabled software architecture, you can 
deploy and distribute resources as you see fit. Introduce PRIME to your 
hardware-based control rooms via COTS hardware, custom IT equipment, or virtualized 
machine, or realize the value of live production in the cloud - on your public (AWS) or 
private cloud infrastructure. The PRIME Live Platform is adaptable to the content 
creation, storage, and distribution strategy that best suits your organization. 

Please visit chyron.com to learn more about the PRIME Live Platform, and our wide range of 
advanced solutions and services. 

About PRIME Switcher 
If you are already familiar with the fundamentals of switcher operations, 
PRIME Switcher is easy and intuitive. However, even if you have never 
operated a switcher, this guide can help you become proficient.  

PRIME Switcher is a software-based 2ME production switcher built on 
Chyron’s industry-leading PRIME Live Platform, providing an integrated 
solution that leverages PRIME’s unique capabilities. PRIME Switcher 
delivers a complete live production suite, with control of our legendary 
real-time graphics, versatile clip player, chroma key, DVE, multichannel 

audio mixer, and auxiliary audio buses - all within a single engine. 

TIP: Does some of this lingo sound unfamiliar? Chapter 2: PRIME Switcher Basics and the 
Glossary can bring you up to speed! 

 

 

 

​
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PRIME Switcher provides a software-based user interface similar to control panels that 
technical directors typically use. Rather than press buttons on a hard panel, simply click and/or 
use keyboard shortcuts to switch sources, add graphics, trigger dynamic transitions, and build 
the complex ME output you need for a compelling show. In addition to the switcher panel, the 
interface features an audio mixer, CG (graphics)/clip controls and the PRIME playlist from this 
single interface. Active CG and clip channels provide a multiviewer window with simple 
playback and file cue controls – and your project file folder with all your clips, images, and 
graphics scenes is directly browsable from the interface. 

 

Flexible Usability 
PRIME Switcher offers greater flexibility than traditional hardware-based switchers, is 
especially suited for remote workflows, and provides the ability to: 

●​ Spin up additional control rooms, remote or disaster recovery control rooms, or 
low-cost OTT control rooms. Input and output your sources in a combination of SDI, 
NDI, and H264 streams. 

●​ Run switching operations in the cloud. 

●​ Perform routing operations in the software configuration. 

●​ Apply transitions via effects created within PRIME, leveraging PRIME’s advanced 
graphics creation capabilities. 

​
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●​ Control PRIME Switcher operation via automation. 

●​ Span the PRIME Switcher user interface across multiple monitors for easier visibility 
specific components. 

●​ Run PRIME CG, PRIME Clips and PRIME Branding on the same chassis as PRIME 
Switcher. 

●​ You can use PRIME Master Control Panels for specialized workflows, for example, 
loading and triggering graphics and clips. Contact Chyron Creative Services for 
additional information. 

Function and Specification Overview 
PRIME Switcher Inputs: 

●​ SDI/UHD-4K/HDR 
●​ NDI 
●​ Network Stream: H.264/H.265 over (RTMP) SMPTE 2110/SMPTE 2022-6 
●​ Embedded audio 

PRIME Switcher Outputs: 

●​ SDI/UHD-4K/HDR 
●​ NDI 
●​ Network Stream: H.264/H.265 over (RTMP) SMPTE 2110/SMPTE 2022-6 
●​ GPU 
●​ Desktop Window 
●​ Application Window 
●​ PRIME Sub Channels, including: 

○​ Preview Sub Channel 
○​ Two Sub Channels Clips 
○​ Two Sub Channels Graphics 
○​ One Sub Channel Mix Effects 

●​ Embedded/System Audio 

The number and types of inputs and outputs are dependent upon the video resolution. 

​
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About Playout and Switcher Control 
The Mix Effects Banks control the switcher output mix, including: 

●​ Background video from a camera, clip server, or other source. 

●​ One or more keys, layered over the background, to display graphics or clips. 

See Work with Main and Mix Effect (ME) Banks and Transitions. 

PRIME Switcher Banks, Video and Audio Buses, Sources, Keys, and Transitions can be 
controlled remotely as follows: 

●​ PRIME Audio Director. See the PRIME Audio Director User Guide and the Websocket 
Automation Interface Reference Guide. 

●​ WebSocket using a JSON protocol. See the Websocket Automation Interface 
Reference Guide. 

●​ PRIME Master Control Panels, which can control Banks, Keys, Sources, and 
Transitions. See the PRIME User Guide for additional information. 

PRIME Switcher can employ multiple methods to control graphics and clips from internal or 
external sources. 

●​ The PRIME Switcher Graphics Players and Clip Players. See Work with Graphics and 
Work with Clips. 

●​ A PRIME Playlist. See PRIME Playlist Graphics and Clip Playback within PRIME 
Switcher. 

●​ PRIME Master Control Panels. See the PRIME User Guide. 

●​ Chyron Intelligent Interface®, XML, UDP, Generic, VDCP, PBus, Oxtel, EAS, and 
AMP protocols. Automated playout is configured in the Switcher Automation Panel. 
See the PRIME Automation Guide. 

●​ WebSocket using a JSON protocol. Automated playout is configured in the Switcher 
Automation Panel. See the PRIME Automation Guide and the WebSocket Automation 
Interface Reference Guide. 

​
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External Monitor Display 

A major benefit of PRIME Switcher is that physical monitors are not required to view Program, 
Preview, Mix Effects, video inputs, clips, and graphics. The PRIME Switcher interface displays 
all video, clips, and graphics. 

PRIME Switcher can display input sources and output mixes on physical monitors using the 
following methods: 

●​ Windows Mosaic. See the PRIME Display Matrix Configuration document. 
●​ Configure Matrox for SDI outputs and Mosaic for GPU outputs. Note that doing so 

reduces the available number of available video inputs. See the PRIME Playout 
Configuration Guide. 

​
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Device Control 
PRIME Switcher interfaces with the following devices: 

●​ Input Devices: 

○​ PC Keyboard/Touchpad/Mouse: Works out of the box. 

○​ Chyron Advanced Keyboard: Configure via Config > Devices. See the Chyron 
Advanced Keyboard User Guide for details. 

○​ X-keys: Configure via Config > Devices. See the PRIME User Guide for 
information on X-keys configuration. 

○​ GPI In: Configure via Config > Devices. See the PRIME User Guide for 
information on GPI configuration. 

●​ Output Devices: 

○​ GPI Out: Access configuration via Config > Devices. See Enable GPI Tallies, 
Configure Tally Pins for details on enabling and configuring GPI Tallies. See the 
PRIME User Guide for information on GPI configuration. 

Best Practices 

Avoid Last-Minute Configuration Changes 
PRIME Switcher provides the ability to quickly and precisely configure the inputs, outputs, and 
the interface layout. We strongly advise, however, that you do not modify configuration directly 
before a production is about to go live, as you may introduce unexpected behavior. 

Do Not Perform Updates without Testing 
Do not perform updates to Windows, other applications, drivers, firmware, etc., without testing 
PRIME Switcher operation prior to going on air. If you are unsure as to whether or not to 
perform an update, then contact Chyron Support. 

Save Layouts and Configurations for Future Use 
If PRIME Switcher is configured exactly as you wish, then save the layout and the switcher 
configuration files for future use. Saving also enables you to revert to a known working 
configuration if something goes wrong. 

See Save a UI Layout and Save PRIME Switcher Configuration for details. 

​
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Ensure that Scenes, Images, and Clips are Correctly Formatted 
Ensure that scenes and clips have the same resolution and frame rate as PRIME Switcher 
configuration; otherwise, they may not play correctly. 

Ensure that images have the same resolution as PRIME Switcher; otherwise, they may not 
display correctly. 

Ensure that All Necessary Assets Are Available 
Ensure that all assets necessary for the show are available in their expected locations. 

Ensure that There are No Keyboard Shortcuts Conflicts 
If you have created keyboard shortcuts, then prior to going on air, test operation to ensure that 
there are no inadvertent keystroke conflicts! Also note that numeric keypad numbers may be 
interpreted differently from the numbers in the top row of your keyboard. 

Rehearse! 
Test PRIME Switcher before going live, to ensure that it performs as expected. If playing clips 
and graphics from PRIME Switcher, then ensure that all assets are available.  

​
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PRIME Documents 

PRIME Document Location 
PRIME documents, including this User Guide, are located in the PRIME Documents folder on 
the PRIME Platform user desktop. 

About this Document 
This document comprises the instructional chapters, plus the following supplementary 
sections: 

●​ Troubleshooting 
●​ Glossary 
●​ PRIME Switcher File Formats 

NOTE: Our products are in continuous development. Some screen images or 
illustrations in this document may differ from your actual user interface, however, you 
should generally find the instructions valid and useful. 

Conventions 
Working with the PRIME Switcher UI is similar to working with other computer applications. 
You can navigate and access many of the functions via the keyboard or mouse/touchpad. 

Mouse/touchpad instructions assume that the left button selects an item, and the right button 
displays the context-sensitive menu. If your mouse/touchpad is set with the buttons reversed, 
then adjust the instructions to correspond to your configuration. 

●​ >​
In a multi-step process, this means “and then click or select.” For example, “Go to View 
> Layout > Save Layout“ instructs you to click or select the View menu, then select 
Layout, and then select Save Layout. 

●​ Active/Grayed Out (Inactive/Unavailable) 
Specifies the availability of an icon, menu item, etc. 

○​ When active, the element is displayed in full color. 
○​ When grayed out and therefore inactive/unavailable, the element appears gray or 

dark. 

​
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●​ Click​
Left-click using a mouse/touchpad to select an item. 

●​ Click and drag 
Click a control or an item, and while holding down the mouse/touchpad button, drag 
the control or item to a new position or location. 

●​ Click and hold 
Click a control or an item, and hold down the left mouse/touchpad button. The 
instructions may also specify that you perform another operation while you click and 
hold the mouse/touchpad button. 

●​ Cursor to​
Use the cursor keys to navigate to an item. 

●​ Double-click​
Left-click two times quickly in succession. Typically opens an application or a file. 

●​ Enable (Activate)/Disable (Deactivate) 
This control applies to a checkbox or an icon/button. 

○​ Checkbox: 

■​ To enable the control, click the checkbox so that a check mark displays 
in the checkbox . 

■​ To disable the control, click the checkbox so that the check mark does 
not display in the checkbox . 

○​ Icon/Button: 
■​ To enable/activate an icon or button, click the button, so that it displays 

in its activated state. Example: Clip Player Loop and Playlist Play icons 
active: 

 

■​ To disable/deactivate an icon or button, click the button, so that it 
displays in its deactivated state. Example: Clip Player Loop and Playlist 
Play icons inactive: 

 
●​ Enter​

Type a value or string into the field. 

​
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●​ Highlight​
Using the mouse/touchpad or the keyboard, place the cursor on the interface element. 
When highlighted, it changes appearance to indicate that the element is currently 
selected. 

●​ Hover​
Move the mouse/touchpad cursor over a specified item, to either highlight it or to cause 
something, for example, a horizontal cursor , to appear. 

●​ Press​
Refers to an action performed on a keyboard. 

Keyboard actions that contain a “+” indicate that you should press and hold the first key 
while pressing the second key. For example, Ctrl+C specifies that you press and hold 
the Ctrl key while you then press the C key. 

You can select items on the menu bar using the mouse/touchpad or the keyboard. 
Pressing, then releasing Alt changes the cursor focus to the menu bar. You can use the 
left/right cursor keys to scroll through the menu items, and then press Enter to open the 
selected menu.  

●​ Right-click​
Right-click using a mouse/touchpad. Typically displays a context menu. 

●​ Select​
Left-click or use the cursor keys to select/highlight an item. 

 

​
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Chapter 2: PRIME Switcher Basics 

Switcher Operation 
A switcher is the center of all live broadcast operations, and controls the video content that is 
broadcast to viewers. The person who operates the switcher is typically known as either a 
switcher operator, vision mixer or technical director (TD).  

Traditionally, the director of the broadcast instructs all control room (aka gallery) personnel, 
including the TD, as to when and how various elements triggered, switched, mixed, etc. PRIME 
Switcher may be used in this type of workflow.  

However, with the power of the PRIME Live Platform many tasks previously performed by 
dedicated operators on multiple devices from a single, fixed control room may now be 
performed by a single operator, or by multiple operators in various locations. 

Basic Functions of a Switcher 
A switcher accepts video input (with or without audio) from a variety of sources, including:  

●​ Live cameras 

●​ Clip servers 

●​ Internal/external feeds 

●​ CG/graphics systems 

●​ Webcams 

●​ Live streams 

As a switcher operator, you can display any of the sources on air, and create complex layering 
and effects to enhance your broadcast. 

 

​
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The switcher allows you to specify which video is the Background (BKGD), and the video or 
graphics that are layered over the background. Layering video over a video background is 
referred to as keying. These layers, or keys, commonly have areas of transparency where the 
background is visible. PRIME Switcher provides Linear Key and Chroma Key, as well as the 
ability to apply a DVE to each key. 

●​ You can specify which layers to include in the next transition and preview how the 
transition affects the output in a Preview monitor.  

●​ A Mix Effect is a composite of one or more sources. You can apply a Transition to play 
a Mix Effect to an output channel and view it in the Program monitor.  

●​ Transition Types include Cut, Wipe, Dissolve and Custom. 

You can independently control each source, easily select and trigger transitions, and save Mix 
Effects for future use. 

PRIME Switcher provides an Audio Mixer, with which you can mix audio, set audio to follow 
video, and create AUX Audio Buses for Mix Minus outputs. 

See the Glossary for definitions of PRIME Switcher terms. 

 

​
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Chapter 3: The PRIME Switcher User Interface 

Start PRIME Switcher 
The PRIME Switcher UI provides most of the same components as a traditional hardware 
switcher, and operates in a similar manner. 

The UI also provides: 

●​ Video Input, Preview, Program, Graphics, Clips and Mix Effect video displays, 
without the need for physical monitors. 

●​ One or more Assets Browsers that provide access to the PRIME assets such as 
Scenes (graphics) and Clips. 

●​ An Audio mixer. 
●​ A keypad. 
●​ Display of additional components, including Playlist(s), Workflow Logger, Automation 

Logger, and Parameters. 

To start PRIME Switcher: 

1.​ On the desktop, double-click the Chyron PRIME shortcut icon. 

 

The Startup Configuration panel appears. 

 

​
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2.​ The name of the last selected application has a thin blue outline around it. 

 

Click the desired Switcher item. Depending upon your facility, there may be more than 
one Switcher item. The PRIME Switcher splash screen appears. 

 

The PRIME Switcher interface appears. If Video Sources are connected, then they 
display in the monitors. If graphics are already loaded, then they display, as well. 

 

​
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CAUTION: If the PRIME Engine window appears on top of the PRIME Switcher interface 
when it opens, then do not close the window. To hide the PRIME Engine window while 
operating PRIME Switcher, do one of the following: 

●​ Click the PRIME Switcher interface outside of the PRIME Engine window; or, 

●​ Click the PRIME icon  in the taskbar at the bottom of the screen. 

 

If you closed the PRIME Engine window, and the Video Input, Clips and Graphics 
displays have frozen: 

●​ Close and reopen PRIME Switcher, making sure not to close the PRIME Engine 
window. 

One reason that the PRIME Engine window might display is that the Clean Feed may 
have been configured to output to a Desktop Window for testing. You can reconfigure 
the Clean Feed to a different output (typically SDI), or if the production is not using the 
Clean Feed, you can disable or delete the Clean Feed. 
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If video sources are connected and configured, then they appear in the PRIME interface. The 
following figure shows a typical PRIME Switcher UI that is configured for: 

●​ 8 Video Inputs 
●​ 2 Graphics Player Channels 
●​ 2 Clip Player Channels 
●​ 1 Mix Effects Channel 
●​ Audio Mixer 

An Assets Browser displays Scenes and Clips, and can display other assets, as well, and a 
keypad provides the same functionality as a hardware keypad. 

 

​
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The following figure shows the main areas of the PRIME Switcher UI. For clarity, the monitors 
are blank. Normally, the Video Input monitors display video. 

 

The PRIME Switcher UI is composed of the following main components: 

●​ Menu Bar: Provides access to PRIME Switcher display parameters, configuration, and 
other functions. 

●​ Project Operation and Selection: Provides the ability to select a project and perform 
project operations. 

●​ Graphics, Clip and ME1(Mix Effects) Recall Box: Provides the ability to enter 
graphics, clips or mix effects in sequence. 

●​ Layout Recall Dropdown: Provides the ability to recall layouts. 
●​ Scene Editor Display Selection: Displays the PRIME Scene Designer. 
●​ Preview/Program Monitors: Displays PRIME Switcher Preview and Program output. 
●​ Mix Effect (ME1) Monitor: Displays ME1 Bank Program output. 
●​ Video Input Monitor(s): Displays Video Input(s). If audio is present, enabled, and 

added as a Switcher Audio Source, then the Video Monitor displays the audio 
level(s). 

●​ Graphics Player(s): Displays currently loaded graphic(s). The Graphics Player can 
preview and play graphics. One or more graphics can be queued for playout. 

​
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●​ Clip Player(s): Displays currently loaded clip. The Clip Player can preview, play, pause, 
return to frame 0, loop, and stop a clip. A clip can be queued for playout. If audio is 
present, enabled, and added as a Switcher Audio Source, then the Clip Player 
displays the audio level(s). 

●​ Assets Browsers: Displays the Clips and Scene assets. You can create additional 
browsers to access other asset types. 

●​ Switcher Banks: Main and Mix Effect Banks, each composed of a Preset, Program 
and Key Bus, a Transition Area, and a Downstream Keyer. 

○​ Preset, Program, Key Buses control: 
■​ The video that is in Program. 
■​ The video that is about to transition to Program. 
■​ The Key source active in the Key Bus. 

○​ Transition Area: Each Bank has its own independently controllable Transition 
Area. The Transition Area has the following functions: 

■​ Controls that specify which sources transition. 
■​ Controls the transition type (e.g., Wipe, Dissolve, Custom) to be applied 

to the transition. 
■​ Performs transitions involving video and/or one or more keys, and 

indicates which keys are in Program. 
■​ In the ME1 Bank, can save and load Mix Effect Presets. 

○​ Downstream Keyer: Key video channel source selection and control. Each 
Bank has its own independently controllable Downstream Keyer. 

●​ Audio Buses: Audio Mixer controls. May also display Auxiliary Buses. 
●​ Keypad: Provides keypad functions, including clip, graphic, and Mix Effects Preset ID 

entry, plus Load, Play, Save, Delete and Clear. 
●​ SDI Input and Bypass Status Indicators: Indicates active/inactive status for each SDI 

Input and the Bypass. 

The UI can also display the following components: 

●​ Playlist: Provides the ability to play graphics and clips from a PRIME playlist to the 
PRIME Switcher Graphics Player and Clip Player. 

●​ Workflow Logger: Logs specific events in the PRIME application. See the PRIME User 
Guide for additional information. 

●​ Automation Monitor: Displays the automation connections. See the PRIME 
Automation User Guide and the PRIME User Guide for additional information. 

●​ Parameters: Displays the list of the PRIME scene parameters. See the PRIME User 
Guide for additional information. 

​
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Each component (Monitor, Bus, Audio Mixer, Assets Browser) on the PRIME Switcher UI 
displays in its own tab. The following figure shows the Main Bank tab. 

 

To save space, the switcher can display multiple components in the same physical space as a 
single component, by combining multiple tabs in Tab Groups, or by displaying smaller 
side-by-side or stacked components. The following figure shows a Tab Group. 

 

See Resize and Reposition Components and Tab Groups for details. 

​
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Close and Restart PRIME 

Close PRIME 
To apply any change in PRIME configuration or PRIME Switcher configuration, you must close 
and restart PRIME. 

Certain hardware firmware changes may require a system restart. PRIME will display a prompt 
if a restart is required. See the PRIME Playout Configuration Guide. 

To close PRIME: 

1.​ Go to File > Exit, or click the Close icon (x) at the upper right of the PRIME Switcher 
interface. The following message appears. 

 

2.​ Click OK. 

PRIME Settings - General 
Overview and Access PRIME Settings - General 
The PRIME General settings specify the behavior pertaining to PRIME startup, status, closing 
and layout. 

NOTE: Certain setting modifications require you to close and restart PRIME Switcher. 
PRIME Switcher displays a message when close and restart are required.   

​
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To access the settings: 

●​ Go to Config Menu > Settings, and then click General. The PRIME Settings dialog 
appears: 

 

Theme: Specifies the appearance of the interface. The theme is set to Dark, and is the only 
theme available at this time. 

​
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General Settings 
Prompt Before Closing 

●​ If enabled, then when you close PRIME Switcher, PRIME displays the Close PRIME 
prompt: 

 

●​ If disabled, then when you close PRIME Switcher, PRIME Switcher closes without 
displaying the prompt. 

Prompt Administrator Warning on Startup 
●​ If enabled, displays an Administrator Warning upon startup. 

●​ If disabled, does not display an Administrator Warning upon startup. 

 

You can also disable display of this warning directly from warning: 

○​ Uncheck Show this warning on startup. 

​
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Prompt for Playout Configuration 
●​ If enabled, then when you open PRIME, the list of available playout configurations 

displays: 

 

●​ If disabled, then PRIME opens the most recently opened playout configuration. 

You can also disable display of this warning directly from the Startup Configuration 
panel: 

○​ Uncheck Prompt On Startup. 

​
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Export Settings 
PRIME settings and configurations are stored in individual files. You can export one or more 
PRIME settings and configuration files for future use in PRIME Switcher or for import into other 
PRIME switchers. 

To export PRIME Settings: 

1.​ Click Export Settings. The Zip Files dialog appears, and lists settings or configuration 
files from which you can choose full categories of settings/configurations to export, or 
one or more individual items within the categories to export. The following figure shows 
the Group by dropdown expanded. 

​
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2.​ If desired, then click the Group by dropdown arrow to display the list by one of the 
following: 

1.​ File Type: Lists the files by type. 
2.​ Folder: Lists the files by folder. 
3.​ None: Lists the files in alphabetical order by filepath. 

3.​ Select the files that you would like to export. You can select one or more individual 
items, or use the following selection shortcuts to quickly select/deselect groups of files: 

1.​ Enable/disable the All Items checkbox to select all/no items in the list. 
2.​ Enable/disable the checkbox at the top of a category to select all/no items in 

that category. 

4.​ When you have completed selection, click Export Selection, and then save to a *.zip 
file at the desired location. The saved settings and configuration files can then be 
imported in the future on the same PRIME Switcher, or into a different PRIME Switcher. 

Import Settings 
To import PRIME settings: 

1.​ Click the Import Settings button. 
2.​ Browse to the desired *.zip file, and then click Open. The Unzip Asset dialog appears. 

It is similar in appearance and operation to the Zip Files dialog. 
3.​ Select the files that you would like to import, and then click Import Selected. The files 

replace their corresponding current settings and configuration files. 
4.​ Close and restart PRIME. 

Status Settings 
Status Overview 
The Status Indicators display at the bottom of the PRIME Switcher interface, and govern if the 
PRIME Switcher starts up in In Circuit or Bypass Mode, and specifies which indicators 
display. 

 
See SDI Input, Bypass Indicators for additional information about these indicators. 
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In Circuit on Startup 
●​ If enabled, then PRIME Switcher starts in In Circuit Mode. 
●​ If disabled, then PRIME Switcher starts in Bypass Mode. 

Show Bypass Indicator 

●​ If enabled, then the Bypass Indicator displays on the PRIME Switcher interface. 
●​ If disabled, then the Bypass Indicator does not display on the PRIME Switcher 

interface. 
Show SDI Input Indicators 

●​ If enabled, then the SDI Input indicators, including Genlock, display on the PRIME 
Switcher interface. 

●​ If disabled, then the SDI Input indicators, including Genlock, do not display on the 
PRIME Switcher interface. 

Layout Setting 
Auto Save Layout 

●​ If enabled, then the state of the layout upon closing PRIME Switcher is preserved. 
When you reopen PRIME Switcher, then the layout is the same as when you last closed 
it. 

●​ If disabled, then the state of the layout upon closing PRIME Switcher is not preserved. 
When you reopen PRIME Switcher, then the default layout displays. 

​
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Close and Restart PRIME without Change to Configuration 
If you close and then restart PRIME without changing configuration, then the configuration 
upon closing is retained upon opening. The state of the PRIME Switcher upon restart is as 
follows: 

●​ Video Inputs remain as is. 
●​ Main and ME1 Switcher Bank settings revert to their default states. 
●​ Main and ME1 Transition Area settings revert to their default states. 
●​ Main and ME1 Downstream Keyer sources revert to their default states. 
●​ Graphics Player(s) is cleared, unless you configured one or more Startup Scenes. 
●​ Clip Player(s) is cleared. 
●​ Playlist Player(s) is cleared. 
●​ Master Audio Mixer Fader: Resets to 0.0 dB. 
●​ Audio Bus Faders: For each Audio Fader: 

○​ Main Audio Bus Fader not set to Follow Video reverts to -∞ dB. 
○​ Auxiliary Bus Fader reverts to -∞ dB. 
○​ Mute status reverts to inactive. 
○​ Delay setting is retained. 
○​ Follow Video - Main Audio Bus Only: 

■​ Follow Video active/inactive status is retained. 
■​ Follow Sources selection(s) is retained. 

Close and Restart PRIME with Change to Configuration 
If you close and then restart PRIME after changing the configuration, then the new 
configuration is applied. For example, if two Clip Players had been displayed, and one had 
been removed during reconfiguration, then a second Clip Player does not display when PRIME 
Switcher restarts. 

The new configuration now becomes the default state of the PRIME Switcher. 

See UI Layout, Switcher Components Overview, Assets Browser and Configure PRIME 
Switcher for details on customizing the PRIME Switcher UI. 
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Configure Startup Scenes 
Startup Scenes Overview 
When PRIME Switcher launches, the UI displays, by default, blank Graphics Players. You can 
configure one or both Graphics Players to play and/or load scenes upon startup. 

To access Startup Scene configuration: 

●​ Go to Config > Settings. The PRIME Settings panel displays. If not already selected, 
then select Startup Scenes. 

 

You can select the following:: 

○​ Project: The project in which the graphic resides. 

○​ Scene: The scene file 

○​ Command: The action that the selected Graphics Player will perform when 
PRIME Switcher opens. 

○​ Channel: The Graphics Player that on which the graphic will be loaded/played. 
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Add Startup Scenes 
For this exercise, you will set: 

●​ Graphics Player 1 to play a live bug scene and load a series of OTS messages. 

●​ Graphics Player 2 to load series of lower third messages. 

To set: 

1.​ Click the Add icon  at the top of the Startup Scenes panel. The Startup Scene 
panel displays a new item. By default, Graphics 1 is selected and set to  Play Scene. 

 

2.​ Click the item. The drop-down fields display. 

 

​
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3.​ For the first item: 

○​ Select the project and scene. All graphics in the project’s Scene and Message 
folders are listed, including their sub-folders. 

○​ Select the action that the Graphics Player performs when PRIME Switcher 
opens: 

■​ Load: Loads the selected graphic into the Graphics Player Preview 
channel of the selected Graphics Player. 

■​ Play: Plays the selected graphic in the selected Graphics Player. 

 

4.​ For the next item, click the Add icon and set a graphic to load in Graphics Player 1. 
Repeat this step for each graphic to load. 

 

​
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5.​ Repeat step 4 as needed to add the graphic to load in Graphics Player 2. 

 

6.​ Click Apply to save the settings and continue PRIME Settings configuration, or click OK 
to exit PRIME Settings configuration and save the settings. 

7.​ Close and restart PRIME Switcher. The specified graphic in Graphics Player 1 plays, 
and the specified graphics in Graphics Player 1 and 2 are loaded. 

8.​ To review the list of loaded graphics, click Preview to the right of the Graphics Player 
Play icon. The list displays. The following shows the list of graphics loaded in Graphics 
Player 1. 

 

Remove Startup Scenes 
To remove a graphic from the Startup Scenes configuration: 

​
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●​ In the Startup Scenes list, click the item, and then click the Remove icon . 

UI Layout 

Overview 
PRIME Switcher’s flexible layout enables you to configure the UI to suit a specific operator or 
production. 

●​ Move, resize, and group switcher components. See Switcher Components Overview 
and Tab Groups. 

●​ Set switcher components to visible or not visible. See Enable/Disable Component 
Display. 

●​ Save, recall, recall recent, and reset switcher layouts. 

Component Display 

The remainder of this chapter assumes that the video/audio inputs/outputs, clip players, 
graphics players, playlists, audio channels and audio buses have been configured for use in 
PRIME Switcher. If they have not been configured, then perform the configurations outlined in: 

●​ Configure PRIME Video and Audio 
●​ Configure PRIME Switcher 
●​ Configure Sources 
●​ Configure Atlas 
●​ Configure Clip Players 
●​ Configure Transitions 
●​ Configure Playlist Players 
●​ Configure Audio Channels 
●​ Configure Audio Buses – Mix Minus 

Also ensure that you have enabled the components for visibility via the View menu. 

​
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About the Default Layout 
The PRIME interface default layout displays all components specified for display in the View 
menu. The components are arranged in an evenly distributed manner. The following figure 
shows a typical default layout: 

 

​
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Display Recent Layout 
You can display recently used layouts. To display a recently used layout: 

●​ Go to View > Layouts > Recent Layouts, and then choose the desired saved layout. 

 

 

​
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Reset Layout to Default 
The default layout displays all source monitors and other components, evenly distributed on 
the UI. To reset the layout to default: 

●​ Go to View > Layouts > Reset Layout. 

Edit the Layout 
You can customize the layout for a specific show or purpose. See Switcher Components 
Overview for details on customizing the PRIME Switcher UI. 

If you make a change to the PRIME Switcher UI, e.g., move a component from one location to 
another, or resize a row, then a temporary layout, which is the name of the current layout, plus 
an asterisk, is added to the Layout Recall dropdown. 

 

The edited UI persists, even if you close and restart PRIME Switcher. 

This item remains in the list until the layout is either saved to the current or a different name, or 
a different layout is selected. 

TIP: There is no “Undo” or “Esc” (Escape) once you start to move or resize a component. As 
such, it is good practice to save interim versions of a layout as you create it. You can delete 
unneeded layouts later. 

Revert from Edited Layout to Saved Layout 
To revert to the saved layout, i.e., the layout that was loaded, with no edits: 

●​ Select the layout name that does not contain an asterisk. 

If you perform this operation, then edits are lost, and the layout with the asterisk no longer 
appears in the list. 
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Save a Layout 
A saved layout preserves the positions and sizes of the: 

●​ Main and ME1 Banks 
●​ Preview, Program, Mix Effects and Video Inputs monitors 
●​ Assets Browsers 
●​ Graphics Players 
●​ Clip Players 
●​ Audio Mixer 
●​ Keypad 
●​ Other Components, including Playlist(s), Workflow Logger, Automation Logger, 

and Parameters  

To save a UI layout: 

1.​ Go to View > Layouts > Save Layout. 
2.​ Enter File name. 

Save a Layout under a Different Name 
To save a layout under a different name: 

1.​ Go to View > Layouts > Save Layout As. 
2.​ Enter File name. 

Load a Layout 
To load a saved UI layout: 

1.​ Go to View > Layouts > Load Layout. 
2.​ From the Open dialog, choose the desired layout, and then click Open. 

or 

●​ From the Layout Recall dropdown at the top right of the PRIME Switcher UI, click the 
dropdown, and then choose the desired layout. 
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Delete a Layout 
You cannot delete a layout from the PRIME Switcher interface. You must perform a deletion 
from the file structure. Prior to doing so, ensure that the layout is not being used by others. 

To delete a layout: 

1.​ Go to the location at which the file is located, typically, ...\PRIME\Settings\Layouts. 

2.​ Delete the file. 

Note that if you delete the file of a layout that is currently loaded in PRIME Switcher, then the 
layout name displays with an asterisk. 

​
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Switcher Components Overview 

What is a PRIME Switcher Component? 
A component is any element of the switcher that is contained within its own tab, e.g., the Main 
Bank, the ME1 Bank, the Program Monitor, the Preview Monitor, Video Input, the Audio 
Mixer, a Graphics Player, a Clip Player, an Assets Browser, etc. 

Examples of Graphics 1, Audio Buses, and Program/Preview/Mix Effects 1/Video Input 
1/Video Input 2 Monitor tabs: 

 

 

​
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You can customize the UI to meet the needs of your production: 

●​ Enable/disable visibility of switcher components. 
●​ Resize, move, and group individual components. 
●​ Resize entire rows. 

To save space, multiple components can display in space of one component in a Tab Group. 
The following figure shows Video Input 5 and Video Input 6 in a Tab Group. 

 

​
 

58 | PRIME 5.3 Switcher User Guide​
​
 



Video input monitors can display in individual windows, or in a continuous strip. To configure, 
see Set Video Input Display. 

Video Sources Displayed in Single Grid Window 

 

Since the sources are not individually labeled, then it may be advantageous to display on the 
source monitors. 

Video Sources Displayed in Single Grid Window with Labels 

 

To configure label display, see Configure Label Display - Show Label. 

Video Sources Displayed in Individual Windows 

 

Almost all component labels of the PRIME Switcher UI can be customized for purpose or 
language. The exceptions are as follows: 

●​ Bank names: Main and ME1. 
●​ Bus names: Preset, Program, KeyX, where X specifies the active Key. 
●​ Transition Area BKGD button. 
●​ Transition Area KEY buttons: KEY1, KEY2, KEY3, KEY4. 
●​ Transition Area CUT, AUTO, PRESET BLACK buttons. 
●​ Recall Box at the top left of the UI, from which Graphics 1, Graphics 2, Clip Player 1, 

Clip Player 2, and ME 1 can be recalled. 

​
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The PRIME Switcher can display Main and ME1 Bank video source and transition names on 
only the Source name row, or on each of the individual buttons. See Set Video Source Name 
Location. 

Source Names on Bus Buttons 

 

Source Names Only on  Source Name Row 

 

​
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Enable/Disable Component Display 
You can enable or disable the display of configured components in the switcher UI. For 
example, a specific production may use fewer video inputs that are configured. As such, there 
is no need to display the unused video inputs. See NOTE at the end of this section for 
information on configured components. 

To enable/disable the display of a component: 

1.​ Go to View. The View menu appears and displays a list of configured components. 

○​ Components that have a checkmark to the left of the component name are 
enabled for display. 

○​ Components that do not have a checkmark to the left of the component name 
are disabled for display. 

​
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NOTE: If the View menu is missing components that you expect to see, then 
ensure that the components are properly configured for use in PRIME Switcher: 

●​ Configure PRIME Video and Audio 
●​ Configure PRIME Switcher 
●​ Configure Sources 
●​ Configure Atlas 
●​ Configure Clip Players 
●​ Configure Transitions 
●​ Configure Playlist Players 
●​ Configure Audio Channels 

​
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2.​ Enable or disable as follows: 

○​ To enable the display of a component, select the unchecked component name. 
The View menu closes, and the component displays. 

○​ To disable the display of a component, select the checked component name. 
The View menu closes, and the component no longer displays. 

Note that visibility of only one component at a time can be enabled/disabled. 

3.​ Repeat steps 1 and 2 to set the visibility for each additional component. 

Depending upon the current layout, when you enable visibility of a component, it may be 
added to an existing component as an additional tab, instead of as a separate component. 

 

If this occurs, then you can drag a tab to the desired location. See Resize and Reposition 
Components, Tab Groups, and Remove a Tab from Tab Group for additional information. 

NOTE: The Video Input Display setting affects how the Video Inputs are listed in the 
View menu: 

●​ If set to Individual Windows, then each Video Input is listed separately in the 
View menu. You can set the visibility of each independently. 

●​ If set to Single Grid Window, then the Video Inputs are all included in the Video 
Inputs item in the View menu. You can set the all or none to display. 
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Close a Component 
To close a component tab: 

●​ Right-click the tab of the component, and then select Close from the context menu. 

○​ If you close an Assets Browser tab, then it is removed from the View menu, 
and therefore, from the PRIME Switcher UI. To restore, add the Assets Browser 
to the UI, via the View menu. See Add an Assets Browser. 

○​ If you close any other tab, then it is not removed from the View menu. Visibility 
of the tab is simply disabled. To restore, enable view of the tab, via the View 
menu. See Enable/Disable Component Display. 

Resize and Reposition Components 

Overview 
You can resize and reposition components to create the UI that works best for your production. 

Component Aspect Ratio 
When you reposition, resize, or insert components, aspect ratio may or may not be preserved, 
depending upon type of component: 

●​ A monitor does not change aspect ratio upon resizing or repositioning. The tabs in 
which it resides may stretch to accommodate row width. 

●​ All other components, i.e., banks and the Audio Mixer, may change aspect ratio upon 
repositioning, resizing or insertion. 
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Resize Monitor Row or Switcher Bank Height 
You can resize the height of a row or switcher bank by repositioning its top and/or bottom 
boundaries. 

To resize the height of a row of monitors or a switcher bank: 

1.​ Hover over the boundary of the row that you would like to resize, until a vertical double 
arrow appears. 

 

​
 

65 | PRIME 5.3 Switcher User Guide​
​
 



2.​ Press and hold the mouse/touchpad select button. A dark bar that marks the Row 
Boundary appears. 

 

3.​ While holding the select button, drag the Row Boundary up or down to the desired 
position, and then release the select button. The monitors in the row display with the 
new dimensions, maintaining the aspect ratio of the monitors. The height of the other 
row that shares the same boundary adjusts to accommodate the new height of the row 
that was originally adjusted. 
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Resize Component Height 
You can resize the width of a component by adjusting its top/bottom Component Boundary. 
There are two restrictions: 

●​ If the component occupies the entire height of the row, then it cannot be independently 
resized. If you move the top or bottom border, then the entire row resizes. 

●​ You can resize the height of a component that shares the row height; however, only the 
inner top and bottom borders can be moved, not the borders that are concurrent with 
the row border. Doing so changes the height of the row. 

To resize the height of a height of a component: 

1.​ Hover over the boundary that you would like to move to resize the component, until a 
vertical double arrow cursor appears. 

 

2.​ Press and hold the left mouse/touchpad select button. A dark bar that marks the 
Component Boundary appears. 

 

​
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3.​ While holding the select button, drag the Component Boundary up or down to the 
desired position, and then release the select button. The component resizes. The height 
of the other component that shares the same Component Boundary adjusts to 
accommodate the new height of the component that was originally adjusted. 

Resize Component Width 
You can resize the width of a component by repositioning its left and/or right Component 
Boundaries. 

To move the left or right boundary of a component: 

1.​ Hover over the boundary of the component that you would like to resize, until a 
horizontal double arrow appears. 

 

2.​ Press and hold the mouse/touchpad select button. A dark bar that marks the 
Component Boundary appears. 

 

3.​ While holding the mouse/touchpad select button, drag the Component Boundary left 
or right to the desired position, and then release the mouse/touchpad select button. The 
adjacent tab boundary moves to accommodate the fixed width of the monitor row. 
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Reposition an Individual Component 
You can move an individual component to a different location in the interface. There are 
different types of repositioning operations: 

●​ Insert a component between: 

○​ Two components. 
○​ A component and the end of a row. 

See Insert a Component to the Left, Right, Above or Below Another Component. 

●​ Add a component to a Tab Group. See Tab Groups. 
●​ Float a component on top of the other components. See Float a Component. 

Note that only individual components can be moved in a move operation. Tab Groups cannot 
be moved as a unit. 

Float a Component 
A component can float, i.e., display, on top of other components, not anchored to other 
interface elements. 

To float a component: 

●​ Right-click the tab of the component that you would like to float, then select Float from 
the dropdown. The component appears at the top left of the UI. 

or 

1.​ Click and hold the mouse/touchpad select button on the tab of the component that you 
would like to float. 

2.​ Drag the component by its tab or top bar, from its current position. The Guide Diamond 
appears. 

3.​ Drag the component to the desired location. Make sure to not select a drop zone on the 
Guide Diamond. 

4.​ Release the cursor. The component floats on top of the UI. 

A floating component displays the familiar Maximize (◻) and Close (x) icons. 

You can maximize the component for closer inspection. When maximized, the floating 
component displays the familiar Restore (❐) and Close (x) icons. 
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Resize a Floated Component 
To change the width of a floated component: 

1.​ Hover over the left or right border of the component, until the horizontal arrow appears. 

 

2.​ Press and hold the mouse/touchpad select button. While holding the mouse/touchpad 
select button, drag the boundary left or right to the desired position, and then release 
the select button. 

To change the height of a floated component: 

1.​ Hover over the top or bottom border of the component, until the vertical arrow appears. 

 

2.​ Press and hold the mouse/touchpad select button. While holding the select button, drag 
the boundary up or down to the desired position, and then release the select button. 

To simultaneously change the width and height of a component: 

1.​ Hover over a corner of the component, until the diagonal arrow appears. 

  

2.​ Press and hold the mouse/touchpad select select button. While holding the select 
button, drag the corner to the desired position, and then release the select button. 
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Insert a Component to the Left, Right, Above or Below Another 
Component 
To insert a component to the left, right, above or below another component: 

1.​ Depending on the initial position of the component: 

○​ If the component is not in a Tab Group, then press and hold the mouse select 
button on the tab of the component that you would like to insert to the left, right, 
above or below another component. 

○​ If the component is in a Tab Group, then press and hold the mouse select 
button on the tab of the component that you would like to insert to the left, right, 
above or below another component. 

2.​ Drag the component that is to be inserted, to the approximate location of the point of 
insertion, until the Guide Diamond appears. In this example, the ME1Monitor is to be 
inserted between Program Monitor and the Audio Buses. 

 

You may see a smaller arrow tracking along with the larger arrow. The smaller arrow 
disappears once the larger arrow is over the Guide Diamond. 

 

​
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3.​ Continue to drag the component until the arrow cursor is over the drop zone within the 
Guide Diamond that specifies the direction in which you would like to insert the 
component: 

 

A white box appears at the point of insertion, and shows the area to be occupied by the 
inserted component. The following figure shows that the Mix Effects 1 tab is about to 
be inserted to the right of the Program Monitor tab. Note the position of the arrow over 
the Insert Right drop zone on the Guide Diamond. 

 

​
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○​ Release the mouse/touchpad select button. The component inserts at the 
position outlined by the white box. 

 

4.​ If desired, then resize the components. 

​
 

73 | PRIME 5.3 Switcher User Guide​
​
 



Experiment with inserting a tab to the left, right, above and below a tab. The following example 
shows Video Input 3 being moved to the left, right, above and below Video Input 4. 

When trying each exercise, reset the UI so that you start from the same point each time. 

Initial Tab Positions 

 

Insert to the Left 

 

Result 

 

Insert to the Right 

 

Result 

 

​
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Insert Above 

 

Result 

 

Insert Below 

 

Result 

 

Insert a Component at the Edge of the PRIME Switcher UI 
You can insert a component at the edge of the UI. To do so, use a similar method as when 
working with the central element of the Guide Diamond, except use an outer element/drop 
zone of the Guide Diamond to insert the component. The outer elements/drop zones are 
located at the edges of the PRIME Switcher UI. 

●​  Insert Left of UI Border 

●​  Insert Right of UI Border 

●​  Insert above Top Row 

●​  Insert below Bottom Row 
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When you insert a component in this manner, the repositioned component resizes to the same 
width as the UI (if inserted above or below the UI), or the same height as the UI (if inserted to 
the left or right of the UI). You may need to further adjust the UI to create an optimal layout. If 
you would like to reuse the layout, then make sure to save it. 

Tab Groups 

Tab Group Overview 
You can create Tab Groups to logically group components and/or to save space on the PRIME 
Switcher UI. Each component is in its own tab, with only the contents of the selected tab 
displayed, but other tabs are visible and selectable. 

 

A Tab Group can contain two or more tabs. 

If the component is not wide enough to display the names of all of the tabs, then only one tab 
appears. You can resize the component to display the tab names. See Resize Component 
Width. 
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Display Multiple Components in a Tab Group 
To display multiple components in a Tab Group: 

1.​ Select the tab of the component that you would like to merge into the space of a 
second component. 

 

2.​ Drag the selected tab on top of the second component, until the white Insert Tab 
appears. 

 

​
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3.​ Drag the white tab to the desired position, and then release the mouse/touchpad select 
button. The Tab Group appears. 

 

4.​ If desired, then do one of the following to resize the component: 

○​ Drag the left and/or right boundaries to remove the excess space to the left and 
right of the tab group. 

○​ If only one tab is visible, then drag the left and/or right boundaries to widen the 
tab group until all tabs display. 

If the tab that receives the merging tab is not wide enough to display multiple tabs, then the 
added tab is automatically positioned on top of the tab(s) to which it is added. 
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Create Tab Group Using the Guide Diamond 
To create a Tab Group using the Guide Diamond: 

1.​ Select the tab that you would like to merge into the space of a second component. 
2.​ Drag the selected tab on top of the second component, until the white Insert Box 

appears. 

 

3.​ Release the mouse/touchpad select button. The Tab Group appears. Note that the tab 
that was dragged to merge with the second tab is positioned at the left of the Tab 
Group. 
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4.​ If desired, then do one of the following to resize the component: 

○​ Drag the left and/or right boundaries to remove the excess space to the left and 
right of the Tab Group. 

○​ If only one tab is visible, then drag the left and/or right boundaries to widen the 
Tab Group until all tabs display. 

If the tab that receives the merging tab is not wide enough to display multiple tabs, then the 
added tab is automatically positioned on top of the tab(s) to which it is added. 

To add additional tabs: 

●​ Repeat the above procedure. 

Display a Specific Component of a Tab Group 
To display a specific component of a Tab Group: 

●​ Select the component’s tab. 

Reposition a Tab within a Tab Group 
To reposition a tab within a Tab Group: 

●​ Drag the tab to the desired position. 

Remove a Tab from a Tab Group 
To remove a tab from a Tab Group, do one of the following: 

●​ Right-click the tab, then select Float from the dropdown menu. 
●​ Drag the tab out of the Tab Group to the desired location. 
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Other Tab Operations 

How Do I Locate a Hidden Tab? 
When grouping tabs, one or more tab(s) may be completely covered by another tab, or may 
completely cover another tab(s). When this occurs, the Tab Group looks like a single tab, or in 
a Tab Group with more than two tabs, not all tab names in the Tab Group may be visible. 

If you do not see a specific component on the UI, first check the View menu to make sure that 
the display of the component is enabled. See Enable/Disable Component Display. If the 
component is enabled for display, then perform one of the following three procedures: 

I.​ Drag Border 
●​ Drag the left or right border  of the tab that may be hiding the lost tab, in order to 

widen the component. If the tab is in the same Tab Group, then it should appear. 

II.​ Right-Click Tab 
1.​ Right-click the tab that may be hiding the missing tab. 
2.​ Float the tab, or drag the tab to a different location to reveal the missing tab. 

III.​ The Active Tool Windows/Active Files Panel 
1.​ Select (click) any component tab on the UI. 
2.​ Press and hold the Ctrl key and while holding the Ctrl key, press the Tab key. The 

Active Tool Windows/Active Files panel appears. 

​
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The selected tab name appears as the title of the panel and the name is highlighted in 
the Active Files list. 

The order of the components in the list may be different than shown in the figure, 
depending upon the switcher configuration, the presence of one or more Tab Groups, 
and/or if you have previously selected an item from the list. 
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3.​ While holding the Ctrl key, perform one of the following operations: 

○​ Press the Tab key to advance through the list until you reach the component 
that you would like to view on the UI. When you reach the end of the list, 
pressing the Tab key cycles to the beginning of the list. As you tab through the 
list, the tab name at the top of the panel reflects the name that is highlighted. 
While holding the Ctrl key, you can use the mouse to drag the scroll bar to view 
hidden items. 

○​ Do one of the following: 

■​ Release the Tab key. The panel closes and the selected tab appears on 
the UI. 

■​ Click the name of the component that you would like to view on the UI. 
You can use the scroll bar to view hidden items. The panel closes and 
the selected tab appears on the UI. 

​ Note that displaying the tab may hide one or more other tabs. 

How Do I Reset the Tabs on the PRIME Switcher Interface? 
See Reset Layout to Default. 
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Project Operations 

Project Overview 
A project is the main PRIME “container” that holds all of the assets associated with a specific 
show, production, look, etc. Assets include scenes, images, clips, playlists, scripts, and more. 
A project is defined by a project folder, and the name of the project folder is the name of the 
project. The following shows that the PRIME Projects folder contains three projects: News - 
Evening, News - Morning, and News - Noon.  

 

The Common folder can contain assets that are common to multiple projects, so as to save 
the duplication of assets among projects, ensure consistency and save space. Note, however, 
that when you copy/publish a project to a location that does not have access to the Common 
folder assets, the project will be missing assets. Therefore, ensure that the assets necessary for 
the project are included in the copy/publish. 

See Assets Browser for additional information on managing projects and assets. 
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Open a Project 
You can select the project to load into the PRIME Switcher. 

To select a project, do one of the following: 

●​ Click the Project Recall dropdown arrow, then select the project that you would like to 
open. The white outline indicates the currently loaded project. The blue outline indicates 
the project about to be loaded. 

 

●​ From the Project Folder icon: 

1.​ Click the Project Folder icon , and then select Open. 

 

2.​ Browse to and select the project that you would like to open, and then click OK. 

​
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●​ From the File menu: 

1.​ Go to File > Open Project. 

 

2.​ Browse to and select the project that you would like to open, and then click OK. 

Opening a project loads the project’s assets (Scenes, Clips, etc.). 

Create a New Project 
To create a new project, do one of the following: 

●​ Click the Project Folder icon, select New, browse to the location where you would like 
to create the new project, click the New Project Folder button, enter the name of the 
project as the folder name, and then click OK.  

●​ Go to File > New Project, browse to the location where you would like to create the 
new project, click the New Project Folder button, enter the name of the project as the 
folder name, and then click OK. 

Delete a Project 
To delete the currently open project and all files associated with it: 

1.​ Go to File > Delete Project. The Delete Project? Prompt appears. 

 

2.​ Click Yes. 

The project and its files are deleted. 
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Remove a Project 
To remove the currently open project from the PRIME Switcher interface, i.e., remove the 
display of the project from the Project Recall dropdown: 

1.​ Go to File > Remove. The Remove Project? prompt displays. 

 

2.​ Click Yes. The project no longer appears in the Project Recall dropdown. 

Removing a project does not delete the project or its assets. To display a project that you have 
removed: 

●​ Open the project. 
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Remove All Projects 
To remove all open projects, except the currently selected project from the PRIME Switcher 
interface, i.e., remove the display of the projects from the Project Recall dropdown: 

1.​ Go to File > Remove All. The Remove All Projects? prompt appears. 

 

2.​ Click Yes. The project no longer appears in the Project Recall dropdown. 

Removing the projects does not delete the projects or their assets. 

Display a Project that Has Been Removed 
To display a project that you have removed: 

●​ Open the project. 

Publish, Unpublish a Project 
See the PRIME User Guide and the Content Distribution User Guide for information on 
publishing and unpublishing projects. 
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Zip a Project 
You can zip a project’s assets for future use on the same or other systems. To zip a project’s 
assets: 

1.​ Click the Project Folder icon, and then select Zip. 

2.​ From the sub-menu, select one of the following: 

●​ Project: Zips only the project files. 

●​ Project and Common Folder: Zips the project and Common folder files. 

3.​ The Zip Files dialog appears. Add the files that you would like to zip. Note that the Zip 
Files dialog that displays if you selected Zip Project is different from the Zip Files 
dialog that displays if you selected Project and Common Folder. 

Zip Project 

 

Zip Project and Common Folder 

 

​
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4.​ Click Export Selected. 

5.​ Browse to the desired location, and then click Save. 

Recall Elements 

Recall Element Overview 
PRIME Recall elements provide the ability to open/create/save projects, enter Clip, Graphic 
(Scene), Mix Effect Preset, UI Layout names and ID numbers. 

Actions that you perform in the Recall Area, on the Keypad, on your system keyboard, or an 
external keypad or keyboard, are reflected in the Recall Area and the Keypad. For example: 

●​ If you select Graphics 1 in the Recall Area on the Keypad, the Graphics 1 button 
becomes active in the Recall Area. 

●​ If you then enter 1234 from an external keypad, then it displays in the Recall Box. 

NOTE: If, when entering an ID, the ID does not appear in the Recall Box, then you must 
change the cursor focus to the Recall Box. To do so: 

●​ Click the Recall Box. You can also set a Keyboard Shortcut to change focus to 
the Recall Box. 

You can select a Clip Player, Graphics Player, or ME1 using any of the following methods: 

●​ Click the Clip Player or Graphics Player in the UI. Does not apply to ME1. 
●​ Click the Clip Player or Graphics Player button on the Keypad. 
●​ Click the Clip Player or Graphics Player button in the Recall Area. 

NOTE: You can set Keyboard Shortcuts to perform any of the functions provided by the 
Recall Area and the Keypad. 

Recall Area/Recall Box 
Recall Area/Recall Box Overview 
From the Recall Box, located in the Recall Area at the top left of the UI, you can recall Clip, 
Graphic (Scene), Mix Effect Preset names and ID numbers. 

Recall Area component selection is reflected in the Keypad. 

See Clip Player, Graphics Player and Mix Effect Presets for information on Recall Area/Recall 
Box operations specific to each. 
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Select a Graphics Player, Clip Player, or ME1 (Mix Effects) Bank 
Using the Recall Area/Recall Box, you can perform Load, and Play operations on any of the 
following components: Graphics Player 1, Graphics Player 2, Clip Player 1, Clip Player 2, 
and the ME1 Bank. Each component has its own button. When a button is selected 
(highlighted), then you can enter an ID, and perform the operations. 

Note that only components configured in PRIME Switcher display in the Recall Area. For 
example, if only Graphics 1, Clip Player 1, and ME1 Bank are configured, then the Recall 
Area displays only the Graphics 1, Clip Player 1, and ME1 Bank buttons. 

To select the active component, i.e., Graphics 1, Graphics 2, Clip Player 1, Clip Player 2, 
ME1: 

●​ Click the component name. 

The following figure shows Graphics 1, Graphics 2, Clip Player 1, Clip Player 2 and ME1. 
Clip Player 2 is highlighted, which enables you to perform operations with Clip Player 2. 

 

Set Visibility of Recall Area Components 
You can set the visibility/operability of individual Clip, Graphics and ME1 components in the 
Recall Area. See Set Visibility/Operability of Recall Area and Keypad Components. 

Enter Clip, Graphic, or Mix Effect Preset ID Number Directly in the Recall Box 
To enter a clip, graphic, or Mix Effects ID number directly in the Recall Box: 

1.​ Click the Clip Player, Graphics Player or ME1 Bank for which you would like to enter 
the ID number. 

2.​ If the focus is not already in the Recall Box, then click the Recall Box. 

3.​ Enter (type) the ID in the Recall Box. 

The ID number displays in the Recall Box. 
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Keypad 

Keypads and Keyboards 
Keypad/Keyboard Type Overview 
You can perform Clip, Graphic, and ME1 ID entry, layout and other operations using the 
PRIME Switcher numeric keypad, a physical numeric keypad, an alphanumeric keyboard, the 
Chyron Advanced Keyboard, or an X-Keys keyboard. You can use them in any combination. 

PRIME Switcher Numeric Keypad 
The PRIME Switcher Numeric Keypad is a component of the PRIME interface. To enter ID 
numbers, click the number keys. In this User Guide, it is referred to as a “Keypad” or “PRIME 
Switcher Keypad.” 

 

Physical Numeric Keypad 
The physical numeric keypad is a physical set of keys, with a layout similar to the PRIME 
Switcher Keypad that may be located on a PC keyboard, the Chyron Advanced Keyboard, or 
may be a separate physical component. The number keys may also function as cursor keys, 
depending whether or not NumLock is enabled. To enter an ID number, press the number 
keys. In this User Guide, it is referred to as a “physical keypad” or “external keypad.” From 
the PRIME interface, you can set the use of the physical keypad to allow or not allow numeric 
entry. 
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Alphanumeric Keyboard 
The alphanumeric keyboard is the PC or Chyron keyboard that includes letters, symbols and 
numbers. The numbers that you enter are located in a row near or at the top of the keyboard. 
You can enter numeric and alphanumeric IDs using the alphanumeric keyboard. 

Keypad Overview 
The Keypad is typically located at the bottom right of the PRIME Switcher interface, but you 
can reposition it. You can perform operations pertaining to Clips, Graphics (Scenes and 
Messages) and Mix Effect Presets. 

 

​
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You can perform the following functions from the Keypad: 

●​ Select Clip Player 1 or 2, Graphics Player 1 or 2, or ME1 component. 
●​ Enter ID numbers. 
●​ SAVE Mix Effect Preset. Not available to clips, graphics. 
●​ CLEAR graphic, clip. Not available to ME1. 
●​ PLAY graphic, clip, Mix Effect Preset. 
●​ Display ID of PREVious available graphic, clip, Mix Effect Preset. 
●​ Display ID of  NEXT graphic, clip, Mix Effect Preset. 
●​ LOAD graphic, clip, Mix Effect Preset. 
●​ DELete ID from the Recall Box. 

Keypad component selection, ID entry, PLAY, PREV, NEXT, LOAD and DEL operations are 
reflected in the Recall Area/Recall Box. 

The Macros (labeled M1 - M8) buttons have not yet been implemented, and will be operational 
in a future release. 

See Clip Player, Graphics Player and Mix Effect Presets for information on Keypad operations 
specific to each. 

Set Operability of Keypad Components 
You can set the operability of individual Clip, Graphics and ME1 components in the Keypad. 
See Set Visibility/Operability of Recall Area and Keypad Components. 

Select a Graphics Player, Clip Player, or ME1 (Mix Effect) Bank 
Using the PRIME Switcher keypad, you can perform operations such as LOAD and PLAY on 
any of the following components: Graphics Player 1, Graphics Player 2, Clip Player 1, Clip 
Player 2, and the ME1 Bank. Each component has its own button. When a button is selected 
(highlighted), then you can enter an ID, and perform the operations provided by the keypad. 

Note that only components configured in PRIME Switcher are available to the keypad. For 
example, if only Graphics 1, Clip Player 1, and ME1 Bank are configured, then only those 
buttons on the Keypad are active. The Graphics 2 and Clips 2 buttons would be grayed out. 

To select the active component (i.e., Graphics 1, Graphics 2, Clip Player 1, Clip Player 2, or 
ME1 Bank): 

●​ Click the component’s button. The following shows Graphics 2 selected. 

​
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Enter Clip, Graphic, or Mix Effect Preset ID Number 
To enter an ID number: 

1.​ Click the Clip Player, Graphics Player or ME1 Bank for which you would like to enter 
the ID number. 

2.​ If the focus is not already in the Recall Box, then click the Recall Box. 

3.​ Click the numbers in the keypad. 

The ID number displays in the Recall Box. 

Enter a Clip, Graphic, or Mix Effect Preset ID Number by Navigating the Browser 
To enter a clip, graphic, or Mix Effects ID number by navigating the Browser: 

1.​ Click the Clip Player, Graphics Player or ME1 Bank for which you would like to enter 
the ID number. 

2.​ If the focus is not already in the Recall Box, then click the Recall Box. 

3.​ Click PREV or NEXT to navigate through the browser until the desired ID displays in the 
Recall Box. 

​
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Clear the Recall Box in the Recall Area 
To clear the Recall Box in the Recall Area: 

●​ Click DEL. 

Playout Settings 
Playout Settings Overview 
Playout settings include enabling/disabling the automatic focus for the physical keypad, 
tracking recall per channel, and enabling/disabling Recall Box/PRIME Switcher keypad entry 
for clips, graphics and ME1. To access Playout settings: 

●​ Go to Config > Playout Configuration > Settings. 

 

Set Physical Keypad Automatic Focus Enable/Disable 
You can set whether or not using a physical keypad automatically enters an ID into the Recall 
Box, or if you must first click the Recall Box or use a Keyboard Shortcut to change the focus 
to the Recall Box. 

Regardless of the setting, the PRIME Switcher keypad displayed in the PRIME Switcher UI 
always focuses on the Recall Box, as are the number keys located in the top row of a 
computer keyboard. 

To enable the use of a physical keypad: 

●​ Check the Enabled checkbox. 
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To disable the use of a physical keypad: 

●​ Uncheck the Enabled checkbox. 

Set Keypad Entry Track Recall per Channel 
The Recall Area and the PRIME Switcher keypad can keep track IDs for each channel, or not 
keep track per channel. 

To keep track per channel: 

●​ Check (enable) the Track Recall per Channel checkbox. When enabled, the keypad 
independently tracks the IDs for each channel, i.e., Clip1, Clip 2, Graphics 1, Graphics 
2, and ME1, so that the Recall Box contains the most recent ID/Name for the selected 
channel. 

To not track each channel: 

●​ Uncheck (disable) the Track Recall per Channel checkbox. 

​
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Set Visibility/Operability of Recall Area and Keypad Components 
You can enable/disable the visibility of the Recall Box Components and operability of the 
Keypad components. Components are as follows: Graphics 1/2, Clips 1/2, and ME1. 

●​ When a component is enabled, you can perform Recall Area and Keypad operations 
involving the component, e.g., select a Clip Player, enter an ID number, load a clip, and 
play the clip. 

●​ When a component is disabled: 

○​ You cannot access the component from the Recall Area or from the Keypad. 

○​ If Clip Player is disabled, then none of the Clip Player buttons display in the 
Recall Area, and the Graphics Player buttons in the keypad are grayed out and 
are non-functional. You can still drag and drop clips from the Clips Browser into 
a Clip Player’s Playing or Cued channels. 

○​ If Graphics is disabled, then none of the Graphics Player buttons display in the 
Recall Area, and the Graphics Player buttons in the keypad are grayed out and 
are non-functional. You can still drag and drop graphics from the Scenes 
Browser into a Graphics Player’s Preview or Program channels. 

○​ If Mix Effects is disabled, then the Mix Effects Bank is still operational. 

You can disable a maximum of two out of the three items; i.e., Graphics and Clip Player, Clip 
Player and Mix Effects, or Mix Effects and Graphics. 

To set: 

1.​ Go to Config Menu > Settings > Playout. The PRIME Settings Playout dialog 
appears. 

2.​ In the Toolbar Buttons checkboxes, check the desired component(s) to enable visibility 
of the Recall elements and operability: 

○​ Graphics 
○​ Clip Player 
○​ Mix Effects 

3.​ Click either: 

○​ Apply, if you are continuing to modify other settings; or, 
○​ OK to close the dialog. The Playout settings are applied. There is no need to 

restart PRIME Switcher. 
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The following example shows the Recall Area and the Keypad with Clip Player disabled. The 
Clip Player buttons do not appear in the Recall Area, and they are grayed out in the Keypad. 

 

 

Mix Effects Load/Save Recall Field 
The Mix Effects Recall provides the ability save and recall (load) Mix Effects Presets. See Mix 
Effect Presets. 

Layout Recall Dropdown 
The Layout Recall Dropdown provides the ability to recall saved PRIME Switcher UI Layouts. 
See Load a UI Layout. 
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Assets Browser 
The Assets Browser provides access to assets, such as graphics and clips, that PRIME 
Switcher may use. By default, PRIME Switcher displays the Scenes Browser and Clips 
Browse. Also by default, multiple Assets Browsers display within the same Tab Group. You 
can change the Assets Browser display and save to a custom layout. 

The following figure shows a Scenes Browser tab, and a Clips Browser tab, which displays 
thumbnails of the available clips. You can isolate, resize, and reposition a tab. See Tab Groups 
for details on tab operations. 

 

You can add, remove, and change the display mode of an Assets Browser, navigate to other 
folders from within the browser, and perform operations such as Cut, Paste, and Delete. 

See Assets Browser for details on Assets Browser operations. 
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Banks and Buses 

Switcher Bank 
A switcher bank is comprised of three main areas: 

●​ Buses and Key Settings 
●​ Transition Area 
●​ Downstream Keyer 

The following figure shows two switcher banks, Main and Mix Effects (ME1): 

 

Bus Overview 
A bus is a row of buttons, with each button capable of activating a video, graphics, clip, or Mix 
Effects source. Switchers usually provide three buses per bank, and the PRIME Switcher does, 
as well: 

●​ Program: The selected source is set to display in Program. 

●​ Preset: The selected source is set to transition to Program. 

●​ Key: The Key Bus can specify: 

○​ A Key source that is set to display in Program or Preview (when lit red); or, 

○​ A Key source that is set to transition from Preview to Program (when lit white). 

The Key Bus can reflect a Key that has been set in the Transitions Area or the 
Downstream Keyer. 

Each button on each bus is associated with a source, either input or internal. When you press a 
button, the source is sent to the output of that bus. The Program and Preset buses indicate 
their respective sources. 
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In addition: 

●​ The middle row in the Bus area displays the names of the sources. 

●​ The middle row in the Transition Area displays the names of the transitions. 

●​ The top row of the Bus Area displays provides the ability to: 

○​ Select a Key Bus to view and set. 

○​ Select the type of Key to apply: Linear or Key. 

○​ Set a DVE. 

●​ The top row of the Transition Area indicates the Keys that are  On Air, i.e., in Program. 

In the following figure, Main Bank switcher buses are configured for eight Video Inputs, two 
Clip Players, two Graphics Payers, and ME1 (output of the ME1 Bank feeding the Main 
Bank). 

●​ A red-lit button indicates that the selected source is sent to Program output. 

●​ A white-lit button indicates that the selected Preset source is set for transition to 
Program. 

Note that there are situations specific to the Next Transition Selection buttons, where the 
behavior may be different. See Next Transition Selection. 

 

You can edit video source names in PRIME Switcher Source Configuration. See Rename a 
Video Source. 
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Set Source Names on Buttons 
PRIME Switcher can display the video source and transition names either on only the Source 
Name row, or on the individual buttons as well. The following shows the Bus and Transition 
buttons labeled and unlabeled, and close-ups of the Bus and Transition buttons. 

Source and Transition Names on Bus Buttons 

 

 

 

​
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Source and Transition Names on Source Name Only 

 

 

 

Throughout this User Guide, UI examples are shown with and without source names on the 
individual Bus and Transition buttons. 

​
 

104 | PRIME 5.3 Switcher User Guide​
​
 



To set Source Names on Buttons: 

1.​ Go to Config Menu > Settings > Switcher. The PRIME Settings View dialog displays. 

 

2.​ Do one of the following: 

○​ To display the source and transition names on the individual buttons, check 
(enable) Show Source Names on Buttons. 

○​ To display the source and transition names only on the Source Name row, 
uncheck (disable) Show Source Names on Buttons. 

3.​ Click either: 

○​ Apply, if you are continuing to modify other settings; or, 

○​ OK to close the dialog. The Switcher settings are applied. There is no need to 
restart PRIME Switcher. 
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Set Video Input Display 
Set Single Grid Window or Individual Windows 
The video input monitors can display in a single grid window or individual windows. 

Video Inputs Displayed in Single Grid Window 

 

Video Inputs Displayed in Individual Windows 

 

NOTE: If displaying video input monitors in a single grid window, as opposed to each in 
its own individual window, then it is advisable to show labels, in order to quickly 
identify the inputs. 
 
Video Inputs Displayed in Single Grid Window with Labels 

 

See Configure Label Display - Show Label. 
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To set the PRIME Switcher Video Input Display: 

1.​ Go to Config Menu > Settings > Switcher. The PRIME Settings View dialog displays. 

 

2.​ From the Video Input Display dropdown, select either Individual Windows or Single 
Grid Window. 

3.​ Click either: 

○​ Apply, if you are continuing to modify other settings; or, 

○​ OK to close the dialog. 

4.​ Close and restart PRIME Switcher. 
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NOTE: The Video Input setting affects how the Video Inputs are listed in the View menu: 

●​ If set to Individual Windows, then each Video Input is listed separately in the 
View menu. You can set the visibility of each independently. 

●​ If set to Single Grid Window, then the Video Inputs are all included in the Video 
Inputs item in the View menu. You can set the all or none to display. 

Adjust Spacing between Monitors in Single Grid WIndow 
You can adjust the spacing between the monitors in a Single Grid Window. The following 
shows monitors with no spacing between them. 

 

​
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To adjust spacing between the monitors: 

1.​ Hover the mouse over the Single Grid Window. A slider appears: 

 

 

2.​ Drag the slider to the desired position. As you drag, the spaces between the monitors 
change widths. 

●​ Drag the spacer to the right to increase spacing between the monitors. 

●​ Drag the spacer to the left to decrease spacing between the monitors. 

3.​ When finished adjusting, move the cursor off of the Single Grid Window. The monitors 
display with the adjusted spacing. 
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Preset Bus 
The Preset bus indicates the video source that is available to transition to Program. 

●​ If the Main Bank BKGD is turned ON, then the Preview Monitor displays the video 
input that is selected in the Preset Bus. When a transition is performed, the video in 
Preview transitions to Program. 

●​ If the Main Bank BKGD is turned OFF, then the Preview Monitor displays the video 
input that is in Program. When a transition is performed, the video in Program does not 
change. 

See Next Transition Selection for additional information. 

Program Bus 
The Program Bus indicates the video source that is in Program. A red button specifies the 
Video Source. 

Key Bus 
The Key Bus both reflects the state of a key and provides the ability to change a key. 

●​ A red button indicates that a Key source is in Program.  

●​ A white button indicates that a Key source is in Preview. 

●​ The Key Bus label indicates the Key state (in Program or Preview) for that Key Bus. 

See Work with Main and Mix Effect (ME) Banks and Transitions for information on how to set 
and perform key operations. 
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Transition Area 
The Transition Area settings determine which sources change state when transitioning from 
Preview to Program when a transition is performed, and which transition is applied. The video 
source, and each of individual keys can each be specified to transition, or to maintain their 
current state. Both the light above each KEY button and the small light on each KEY button 
indicate whether or not the key is in Program. 

 

In the ME1 Bank Transition Area, you can create, save, load, and modify a Mix Effect Preset. 
See Set Transition Area and Mix Effect Presets for additional details. 

Downstream Keyer 
The Downstream Keyer provides the ability to set the type (Linear or Chroma) and source for 
each Key, and to perform either a Cut or the transition selected in the Transition Area to 
transition a Key to Program. 

 

See Downstream Keyer for additional information. 
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Clip Player 

PRIME provides a Clip Player in which you can cue, load, preview, scrub, play, pause, stop, 
rewind, and loop, as well as apply a transition between clips. 

 

See Work with Clips for details on operation. 

Graphics Players 
PRIME provides two Graphics Players, in which a scene (graphic) can be cued, previewed, 
and played. 

 

​
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See Work with Graphics for details on operation. 

Audio/Audio Mixing 
All inputs that have embedded audio are supported. As in a hardware audio mixer, faders 
control the audio level, and audio channels can be muted. You can set audio for a channel to 
follow one or more video sources. You can also configure Auxiliary Audio Buses to output Mix 
Minus and/or for Pre Fade Listen. 

 

See Work with Audio for details. 

Workflow Logger 
The Workflow Logger logs specific events in the PRIME application. See the PRIME User 
Guide for additional information. 

 

When you enable display of the Workflow Logger, it becomes part of a Tab Group that 
includes the Preview Monitor. 
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Automation Monitor 
The Automation Monitor displays the automation connections. See the PRIME Automation 
User Guide and the PRIME User Guide for additional information. 

 

When you enable display of the Automation Monitor, it becomes part of a Tab Group that 
includes the Preview Monitor. 

Parameters 
Parameters displays the list of the PRIME scene parameters. See the PRIME User Guide for 
additional information. 

 

When you enable display of the Parameters, it becomes part of a Tab Group that includes the 
Preview Monitor. 

Playlist Player 
A Playlist Player can play playlists created in PRIME. You can configure one or more Playlist 
Players. See Play Back Graphics/Messages/Images/Clips from the PRIME Playlist. 
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SDI Input, Genlock, Bypass Status Indicators 

The SDI Input, Genlock, and Bypass Status Indicators, located along the bottom of the 
PRIME Switcher interface, show the status of the inputs, including Genlock and Video 
Bypass. 

●​ A green indicator specifies an active input. 
●​ A red indicator specifies an active, but disabled input. Its corresponding monitor 

displays a black screen. The input is configured in Config Menu > Playout 
Configuration > Video Channels, but the Channel checkbox at the top of its settings 
is disabled. 

●​ A gray indicator indicates an inactive input. 

The following figure shows the 8 Video Inputs and Genlock active, and Bypass inactive: 

 

The following shows 6 Video Inputs active, 2 Video Inputs inactive, and Genlock Active: 

 

To view the format of a video input: 

●​ Hover the mouse over the indicator for that input, until its tooltip displays. The following 
figure shows the Video Input 1 format. 

 

To confirm that Genlock is present: 

●​ Hover the mouse over the Genlock indicator. 
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The In Bypass Indicator provides the ability to Go to Bypass or Go In Circuit. To select: 

●​ Click the In Bypass Indicator, and then select either Go to Bypass or Go In Circuit. 

 

 

​
 

116 | PRIME 5.3 Switcher User Guide​
​
 



Chapter 4: Configure PRIME Video and​
Audio Channels 

Overview 
You must configure PRIME video and audio inputs and outputs prior to using PRIME Switcher. 
To access video and audio configuration: 

1.​ Go to Config Menu > Playout Configuration. 

2.​ The Playout Configuration Video Channels Panel displays. 

 

​
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Video inputs and outputs are configurable as follows: 

PRIME Switcher Inputs: 

●​ SDI/UHD-4K/HDR 
●​ NDI 
●​ Network Stream: H.264/H.265 over (RTMP) SMPTE 2110/SMPTE 2022-6 
●​ Embedded Audio 

PRIME Switcher Outputs: 

●​ SDI/UHD-4K/HDR 
●​ NDI 
●​ Network Stream: H.264/H.265 over (RTMP) SMPTE 2110/SMPTE 2022-6 
●​ GPU 
●​ Desktop Window 
●​ Application Window 
●​ PRIME Sub Channels, including: 

○​ Preview Sub Channel 
○​ Two Sub Channels Clips 
○​ Two Sub Channels Graphics 
○​ One Sub Channel Mix Effects 

●​ Embedded/System Audio 
●​ Auxiliary Audio Channels, e.g., Mix Minus 

To configure the PRIME Switcher video and audio inputs and outputs: 

●​ Follow the input/output setup procedures in the PRIME Playout Configuration Guide, 
located in the PRIME Documents folder on the PRIME user desktop. 

For additional information about Matrox IP configuration: 

●​ Click the Help icon  at the upper right of the Video Channels dialog. The PRIME 
Matrox IP Playout Configuration Guide opens. 

NOTE: Ensure that the inputs and outputs that you intend to display in PRIME Switcher 
are enabled, i.e., the Channel checkbox at the top of the channels’ settings are 
checked; otherwise, they will not be available to PRIME Switcher. 
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Switcher Component Display 
When input/output configuration is complete, and the channels are enabled, then the 
channels are available to PRIME Switcher. To use in PRIME Switcher, however, you must 
perform the following configurations: 

●​ Make Clip Player(s) Available to PRIME Switcher: Go to Config Menu > Playout 
Configuration, and then click Clip Players in the left navigation. Add and enable one or 
more Clip Players. See Configure Clip Players for details. 

●​ Make Playlist Player(s) Available to PRIME Switcher: Go to Config Menu > Playout 
Configuration, and then click Playlists in the left navigation. Add and enable one or 
more Playlist Players. See Configure Playlist Players for details. 

●​ Add Video Input, Clips, Graphics, Mix Effect as Sources: Go to Config Menu > 
Playout Configuration, click Switcher in the left navigation, and then click the 
Sources tab. Add each source. See Configure Sources for details. 

●​ Add Switcher Component to Atlas: This provides the ability to display the Program, 
Preview, Mix Effects and Video Input monitors, in the PRIME Switcher UI. Go to 
Config Menu > Playout Configuration, then click Atlas in the left navigation. Add each 
component to Atlas. See Configure Atlas for details. 

●​ Enable Visibility in the View Menu: Once the components become available to the 
switcher, then you can enable/disable visibility of each component. Go to the View 
Menu and click to add a checkmark next to each component that you would like to 
display. The View menu also controls the visibility of the Audio Buses, Playlist 
Player(s), (if configured), Workflow Logger, Automation Monitor, Parameters. See 
Enable/Disable Component Display for details. 

To display Audio Channels in the PRIME Switcher Audio Mixer: 

​
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●​ Add Audio Channels: Go to Config Menu > Playout Configuration, click Switcher in 
the left navigation, and then click the Audio Channels tab. Add each source. See 
Configure Audio Channels for details. 

To display Auxiliary Audio Buses in the PRIME Switcher Audio Mixer: 

●​ Add Audio Buses: Go to Config Menu > Playout Configuration, click Switcher in the 
left navigation, and then click the Audio Buses tab. Add each source. See Configure 
Audio Buses - Mix Minus for details. 

Configuration also determines the labels and identifiers on the PRIME Switcher interface. The 
following diagram shows how the labels and identifiers originate. For brevity, Config refers to 
the Config Menu, and Playout Config refers to the Playout Configuration menu item. 

Configure System Audio as an Output 
Prime Switcher can output System Audio. 

To configure: 

1.​ Go to Config Menu > Playout Configuration, and then select Video Channels. 

 

​
 

120 | PRIME 5.3 Switcher User Guide​
​
 



2.​ Set Audio Mode to System Audio, and Audio Device to Primary Sound Driver. 

 

3.​ Restart the PRIME system to apply configuration. 
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Troubleshoot Configuration 
If the interface does not display properly, ensure that you have performed the following 
configurations: 

●​ Config Menu > Playout Configuration > Video Channels: Ensure that you have added 
and enabled channels. 

●​ Clips: Config Menu > Playout Configuration > Clip Players: Ensure that you have 
added and enabled the clip player(s). 

●​ Config Menu > Playout Configuration > Atlas: Ensure that you have enabled Atlas, 
and added channels. 

●​ Config Menu > Playout Configuration > Switcher > Sources: Ensure that you have 
added channels as Switcher Sources. 

●​ Playlists: Clips: Config Menu > Playout Configuration > Playlists: Ensure that you 
have added and enabled Playlist Players. 

●​ View Menu: Ensure that you have enabled channels and other components for display. 
●​ Audio Channels: Ensure that you have added Audio Channels. 
●​ Audio Buses: Ensure that you have added Audio Buses. 

The following may occur if PRIME Switcher is not correctly configured: 

●​ Channel is green in the Status Indicator, but the monitor does not appear in the 
interface. 
Add the channel in Config Menu > Playout Configuration > Atlas and to Config Menu 
> Playout Configuration > Switcher > Sources. Ensure that the Atlas Grid and/or 
Size settings accommodate the display of the monitor. 

●​ Channel is red in the Status Indicator. Monitors for the channels display black 
screens. 

Enable the channel in Config Menu > Playout > Configuration > Video Channels. 

●​ Channel is completely missing. 

Add the channel in Config Menu > Playout > Configuration > Video Channels. 

●​ All monitors are missing. 

Enable Atlas in Config Menu > Playout Configuration > Atlas. 

​
 

122 | PRIME 5.3 Switcher User Guide​
​
 



●​ Some of the monitors are missing. 

Ensure that the Atlas Grid dimensions accommodate all monitors. For example, PRIME 
Switcher requires a minimum 4x4 Grid to display the Program, Preview, ME1, 8 Video 
Input, 2 Clip Player, and 2 Graphics Player monitors. 

●​ Clip Player and/or Graphics Player displays in the interface, but there is no 
monitor. 

Add the Clip Player and/or Graphic Player to Atlas in Config Menu > Playout 
Configuration > Atlas. Ensure that the Atlas Grid and/or Size settings accommodate 
the display of the Clip/Graphics Player. 

●​ ME1 Bank is missing. 

Potential reasons that the ME1 Bank does not display: 

○​ It is not enabled for display in the View Menu. 
○​ It has not been added as a Switcher Source in Config Menu > Playout 

Configuration > Switcher > Sources. 
○​ It has not been added as a Mix Effects Channel in Config Menu > Playout 

Configuration > Video Channels. 

●​ Auxiliary Audio Bus does not display in Audio Mixer. 

Potential reasons that an Auxiliary Audio Bus does not display: 

○​ It has not been added as a Switcher Audio Bus in Config Menu > Playout 
Configuration > Switcher > Audio Buses. 

○​ It has not been added as an Output Channel in Config Menu > Playout 
Configuration > Video Channels. 

●​ When adding a Clip Player in Config Menu > Playout Configuration > Switcher > 
Sources, the Source dropdown is blank or is missing a Clip Player. 
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Ensure that you have configured the Clip Player in Config Menu > Playout 
Configuration > Clip Players. 

 

 

​
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Chapter 5: Configure PRIME Switcher 

Overview 
For PRIME Switcher to work, you must configure the video, clip and graphics sources and 
transitions. If outputting audio, then you must configure audio sources, as well. 

BEST PRACTICE: Save Layouts and Configurations for Future Use 
If PRIME Switcher is configured exactly as you wish, then save the layout and the switcher 
configuration files for future use. Saving also enables you to revert to a known working 
configuration if something goes wrong. 

See Save a UI Layout and Save PRIME Switcher Configuration for details. 

Access PRIME Switcher Configuration 
To access PRIME Switcher configuration: 

1.​ If the Playout Configuration panel is not open, then from the PRIME interface, go to 
Config Menu > Playout Configuration. The following message may display: 

 

Click OK. 

This message displays the first time that you access PRIME configuration during a 
PRIME Switcher session. For the sake of brevity, this step is omitted from subsequent 
sets of instructions. 
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2.​ The Playout Configuration Video Channels Panel displays. In the left navigation, click 
Switcher. The Switcher Sources Configuration panel appears. 

 

​
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Configure Switcher Opening Project, Layout and Shortcuts 
PRIME Switcher can load a specific project, layout, and keyboard shortcuts upon opening. To 
access settings: 

Go to Config Menu > Playout Configuration > Settings. The Override Application Settings 
dialog appears: 

 

Enable/disable the following settings, and if desired, select the source for each: 

●​ Project: Select the project file that is loaded upon opening PRIME Switcher. 
●​ Layout: Select the layout file that is loaded upon opening PRIME Switcher.  
●​ Shortcuts: Select the keyboard shortcuts file that is loaded upon opening PRIME 

Switcher. 

You can create a new, save, or recall a PRIME Switcher configuration. The processes are the 
same as found in the Switcher Configuration panel. See Create New Configuration, Save 
Configuration, and Recall Configuration. As in the Switcher Configuration Panel, the License 
displays the name of the PRIME application currently in use. 
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Apply and Activate Configurations in PRIME Switcher 
You can configure and edit the Source, Transition, and Audio settings, and then save the 
configurations as follows: 

●​ To save the configuration settings and leave the Playout Configuration panel open, 
click Apply. 

●​ To save the configuration settings and close the Playout Configuration panel, click OK. 

Please note that configuration changes DO NOT take effect within the same PRIME 
Switcher session. 

To apply any updates to PRIME Switcher configuration, you must close and restart the 
PRIME Switcher application. 

Some changes, such as any change in frame rate, may require a system shutdown and 
restart. 

1.​ After completing edits in the Sources panel, click OK. A PRIME restart message 
appears: 

 

If the restart message does not appear, then PRIME may be configured not to display 
the message.  

2.​ Click OK. This action does not restart PRIME Switcher. 
3.​ Close, and then restart PRIME Switcher. The configuration updates are now active. See 

Close and Restart PRIME for additional information. 
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Switcher Output Configuration 

The Program Channel, Preview Channel, and Atlas Channel output should be set to 
Program, Preview and Atlas, respectively. 

To select an output for a channel: 

●​ Select from the channel’s dropdown. 

Once you close and restart PRIME Switcher, then the settings are applied. 

Save PRIME Switcher Configuration 
After configuring PRIME Switcher, you can save and recall the configuration. 

To access the Save Configuration dialog: 

●​ Click Save As. The Save Configuration dialog displays. If you are editing an existing 
configuration, then the Name field displays the configuration name. Otherwise, the 
Name field is blank.  

 

To save updates to an existing configuration: 

●​ Click OK. The update overwrites the existing configuration. 

To save the configuration to a new name: 

●​ Enter the new name, and then click OK. When you next start PRIME, the switcher name 
appears in the Startup Configuration panel. 
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Recall Configuration 
To recall an existing configuration: 

1.​ Click the File dropdown. The list of available configurations displays. 

 

2.​ Click the configuration that you would like to load. The selected configuration loads. 

Once you close and restart PRIME Switcher, then the selected configuration is applied. 
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Create New Configuration 
You can create configurations that you can customize for specific purposes, e.g., PRIME 
Switcher, PRIME CG, PRIME Mantis, etc. 

To create a new configuration. 

1.​ Click New. The New Configuration dropdown displays. 

 

○​ Items displayed in bold text specify PRIME applications that are licensed to run 
on the system, and for which you can create new configurations. 

○​ Items displayed in regular (not bolded) text specify PRIME applications that are 
not licensed to run on the system, and for which you cannot create new 
configurations. 
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2.​ Select Switcher. The default switcher configuration, which includes available Video 
Inputs and Black displays. 

 

3.​ Configure as desired. 

Once you close and restart PRIME Switcher, then the configuration is applied. 

License 
The License field displays the name of the PRIME application currently in use. 
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Auto Config 
PRIME Switcher can be auto-configured, based on the inputs and outputs configured in 
PRIME. You can modify auto-configured settings. 

To view and edit the Auto Configure settings: 

1.​ Click Auto Config. The Switcher Auto Configure panel appears: 

 

2.​ The Auto Config panel displays default settings for PRIME. It is therefore possible to 
select a higher number of Clip Players and Graphics than is allowed for use by PRIME 
Switcher. Maximum settings for PRIME Switcher are as follows: 

●​ Clip Players: 2 
●​ Graphics: 2 
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You can edit the following settings: 

●​ Outputs: 

○​ Program: Can be set to any valid PRIME Switcher output.  
○​ Preview: Output is typically set as SDI in PRIME. Typically set as Sub 

Channel in PRIME Switcher. 
○​ Atlas: Output is set to Application Window, as Atlas provides the 

PRIME Switcher UI. 
○​ Clean Feed: Outputs only the video that is in Main Bank Program, with 

no key video. A typical Clean Feed setting in a studio outputting SDI 
would be Matrox SDI. Note that a Clean Feed displays only on the 
Device specified Config > Playout Config > Video Channels, e.g., SDI, 
NDI, etc. It does not display in the PRIME Switcher interface. 

○​ Resolution: Set to output resolution. 

●​ Inputs: 

○​ Video Input: 
■​ Quantity: Set number of Video Inputs. 
■​ Source: Set source of Video Inputs. 
■​ Enable GPI Tallies: Enable/disable the assignment of GPI Tallies. 

○​ Clip Players: 
■​ Quantity: Set number of Clip Players. Maximum 2 in PRIME 

Switcher. 
■​ Source: Typically set as Sub Channel in PRIME Switcher. 

○​ Graphics: 
■​ Quantity: Set number of Graphics Channels. Maximum 2 in 

PRIME Switcher. 
■​ Source: Typically set as Sub Channel in PRIME Switcher. 

○​ Mix Effects: 
■​ Quantity: Set to 1. Maximum 1 in PRIME Switcher. 
■​ Source: Mix Effect Input is typically set as GPU in PRIME. 

Typically set as Sub Channel in PRIME Switcher. 

​
 

135 | PRIME 5.3 Switcher User Guide​
​
 



●​ Audio: 

○​ Main Channels: 
■​ Enable/Disable: Enable or disable Main Audio Channels. 
■​ Quantity: Set number of Main Audio Channels. 

○​ Aux Send Audio 
■​ Enable/Disable: Enable or disable Aux Send Audio. 
■​ Aux Send Audio Mode: Select Aux Send Audio Mode. 

3.​ Edit settings as desired, and then click OK. The following message appears: 

 

4.​ Click OK. 

Once you close and restart PRIME Switcher, then the settings are applied. 

NOTE: When performing an Auto Config, make sure that you apply the intended 
settings. For example, if PRIME Switcher Program and Preview are set to Matrox SDI 
(1), and in Auto Config, and they are set to Matrox SDI (0), then the switcher interface 
might display blank screens, and the switcher might display an error message 
requesting firmware update. 
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Chapter 6: Configure Clip Players 

Overview 
After you have configured one or more Clip Players in Config Menu > Playout Configuration 
> Video Channels, then you must add them to PRIME Switcher. To access Clip Player 
configuration: 

1.​ Go to Config Menu > Playout Configuration, and then in the left navigation, click Clip 
Players. The Clip Controllers Panel displays. 
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Add Clip Player 
To add a Clip Player to the PRIME Switcher: 

●​ Click the Add Clip Player icon . A new Clip Player displays. 

 

You can add a second Clip Player, and configure it independently of Clip Player 1. 
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NOTE: If the Clip Player(s) is not visible in the PRIME Switcher interface, ensure that: 
●​ You have enabled the Clip Player checkbox. 
●​ You have added the Clip Player(s) as a Channel(s) to Atlas.  
●​ You have added the Clip Player(s) as a Video Source(s) in Config Menu > Playout 

Configuration > Switcher > Sources. 
●​ In the View menu, you have enabled the Clip Player(s) for display. 

Enable/Disable component display. 
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Configure Clip Player 
Settings are as follows: 

●​ Clip Player Enable/Disable: Enable to make available to PRIME Switcher. 
●​ Name: If desired, enter a new name of the Clip Player. 
●​ Parent Channel: A Clip Output as set in Config Menu > Playout Configuration > 

Video Channels. Select either Clip 1 or Clip 2 (if there are two Clip Outputs). 
●​ Layer: The priority layer, i.e., how the clip is layered in relation to other graphic layers. It 

is typically set to 0, so as to display as a background behind graphics. 
●​ Transition: If desired, select from available transitions to automatically apply a transition 

whenever a clip is played. 
●​ Transition Priority: Check choices. 
●​ Show Current Frame: Enable/disable display of a frame counter to the left of the Clip 

Scrub Control that displays the current frame of the clip as it plays. 
●​ Show Frames Remaining: Enable/disable displays of a frame counter to the right of 

the Clip Scrub Control that displays the frames remaining in the clip as it plays. 

Current Frame and Frames Remaining displayed. 
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Current Frame and Frames Remaining display disabled. 

 

●​ Use Preview Channel: If a Preview Channel has been added for the Clip Player in 
Config Menu > Playout Configuration > Video Channels, then this setting is active. It 
is otherwise grayed out. 

Remove Clip Player 
To remove a Clip Player: 

●​ Click the Remove icon at the upper right corner of the Clip Player’s settings. 

NOTE: Deleting a Clip Player does not remove it from PRIME Channel configuration (Config 
Menu > Playout Configuration > Video Channels). It removes the Clip Player from use as 
a PRIME Switcher Source. 
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Chapter 7: Configure Sources 
Overview 
The Sources panel provides the ability to configure, add, edit, and delete PRIME Switcher 
video sources, and enable/disable GPI Tallies, set Tally Pins, and Pass VANC from 
Background. The number and types of available video sources depends upon PRIME 
configuration. You can configure each of the video inputs, which are displayed on the PRIME 
Switcher Program, Preset and Key Buses from left to right, in the order in which they are 
listed in the Sources Configuration Panel. See Configure Switcher Program, Preset, Key Bus 
Display Order for information on how to set the Video Source order. 

Access the Sources Configuration Panel 
To access the Sources Configuration Panel: 

1.​ In the PRIME Switcher menu bar, go to Config Menu > Playout Configuration. The 
Video Channels panel appears. 

2.​ In the left navigation, click Switcher. The Switcher Sources panel appears. 
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The Sources panel comprises the following columns: 

●​ List Position Up/Down Icon : The column header for the List Reposition icons . 
●​ Type: The type of Source. This field is not editable. The source types are as follows: 

○​ Black 
○​ Video Input 
○​ Clip Player 
○​ Graphics 
○​ Mix Effects 

●​ Name: The name of the Source, which can be set by the user. 
●​ Source: The video Source, selected by the user. Note that Source selection cannot be 

set for the Black Source Type, as Black uses a dedicated source on the PRIME 
system. 

●​ Tally Pins: The GPI Board and Pin specified for a Video Input Source. This column 
appears only if GPI Tallies is enabled. 

NOTE: Once you have completed Source and any other configurations, remember to 
close, and then restart PRIME Switcher to apply the configuration settings. 

Enable GPI Tallies, Configure Tally Pins 

Enable GPI Tallies 
PRIME Switcher can output a GPI pulse to trigger a camera tally, alerting the camera operator 
and the talent that the camera is in Program. To enable or disable GPI Tallies: 

●​ Click Enable GPI Tallies to enable/disable. 

○​ If enabled, then a Tally Pins column appears in the Source list, and you can set 
a Tally Pin for any of the Video Inputs. 

○​ If disabled, then a Tally Pins column does not appear in the Source list. 

See the PRIME User Guide for information on GPI configuration. 
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Configure Tally Pins 
You can assign a Tally Pin to each Video Input Source. Note that you cannot assign a Tally 
Pin to other types of Sources (i.e., Black, Clips, Graphics, Mix Effects). To assign a Tally Pin 
to a Source: 

1.​ From the Tally Pin dropdown for the Source, select a Tally Pin. 
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2.​ If desired, then continue assigning Tally Pins. A typical configuration is as follows: 

 

A GPI Tally Pin can trigger an anchor’s camera tally light and, for example, an On Air light at a 
studio entrance. See your GPI documentation and the PRIME User Guide for additional 
information. 
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GPI Tally for NDI Source 
If a GPI tally is set for an NDI source, then in addition triggering the tally on the NDI camera, 
you can view the on-air status via the NewTek NDI application. Note that this application is 
completely separate from the PRIME Switcher UI, and would typically be viewed on one or 
more separate monitors. 

●​ If the NDI source is on air, then a red stripe displays across the top of the NDI input 
monitor. 

 

●​ If the NDI source is in a preview state, then a green stripe displays across the top of the 
NDI input monitor. 

 

Once you close and restart PRIME Switcher, then the GPI Tally settings become active. 
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Pass VANC from Background 
PRIME Switcher can pass through Vertical Ancillary Data (VANC) from the Background. To 
set: 

●​ Click Pass VANC from Background to enable/disable. 

Once you close and restart PRIME Switcher, then the new VANC setting is applied. 

Add a Video Source 
You can add one or more new sources to the PRIME Switcher as follows: 

●​ Black 
●​ Video Input 
●​ Clip Player 
●​ Graphics 
●​ Mix Effects (ME1) Bank (See Add the ME1 Bank for details specific to the ME1 Bank.) 

The Add Source icons, a Remove Selected Source icon, and an option to enable/disable 
Pass Vertical Ancillary (VANC) Data from Background display at the top of the Sources 
panel. 

 

NOTE: Source limits are as follows: 

●​ Video Inputs: Depends upon resolution and other factors. 
●​ Clip Player: 2 
●​ Graphics: 2 
●​ Mix Effects (ME) Bank: 1. This is in addition to the Main Bank. 

PRIME Switcher configuration does not prohibit the addition of a component that 
exceeds the specified limit; however, any component that exceeds the specified limit, 
e.g., a third Clip Player, is not supported. 
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In the following example, the switcher lists only one Clip Source. 

 

​
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To add a second Clip source: 

1.​ In the Sources panel, click the Add Clip Player icon. A new Clip Source appears at 
the bottom of the Sources list. 
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2.​ The Source automatically populates with the next available source (video channel) for 
that Source type. To select a different Source, then from the Source dropdown for the 
new Clip source, select a Source. In this example, it is left at Clip Player 2. 
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NOTE: When adding a Clip Player in Config Menu > Playout Configuration > 
Switcher > Sources, if the Source dropdown is blank or is missing a Clip Player, as 
shown below, then ensure that you have configured the Clip Player in Config Menu 
> Playout Configuration > Clip Players. 

 

 

NOTE: Do not assign the same Video Channel to more than one Source, as it 
may result in unexpected PRIME Switcher appearance and/or behavior. 

Example: Do not assign Video Input 2 to CAM2 and to CAM3. 
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3.​ If desired, then enter a new name in the Name field of the source. The name should be 
short enough to fit within the width of a bus button on the PRIME Switcher. The PRIME 
interface truncates excess characters. 

4.​ If desired, reposition the bus in the list so that it is adjacent to the CLP1 bus. 

 

Once you close and restart PRIME Switcher, then the Sources configuration is applied. 

Rename a Video Source 
To change the name of a source as it appears on the PRIME interface. 

1.​ Click the row of the source to be renamed. 
2.​ Enter a new name. The name should be short enough to fit within the width of a bus 

button on the PRIME Switcher. The PRIME interface truncates excess characters. 

Once you close and restart PRIME Switcher, then the new name appears in the switcher bus 
label(s)s. 
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Reconfigure an Existing PRIME Switcher Video Source 
To reconfigure an existing PRIME Switcher source. 

1.​ Click the row of the source to be reconfigured. 
2.​ From the Source dropdown, select a new source. 

Once you close and restart PRIME Switcher, then the reconfigured Video Source is applied. 

Delete a Video Source 
To delete a Video Source: 

1.​ Click the row of the source to be deleted. 
2.​ Do one of the following: 

○​ Press Delete. 

○​ Click the Remove icon . 

Once you close and restart PRIME Switcher, then the deleted Video Source no longer appears 
on the PRIME Switcher interface. 

Configure Switcher Program, Preset, Key Bus Display Order 
It may be desirable to reposition one or more sources in the Source List. The new position is 
reflected in the left-to-right order of the switcher buttons in the buses. To reposition a source: 

1.​ Click the row of the source to be moved. 

2.​ Click the Reposition icon  at the left of the Source Type. 
3.​ Drag the Source to the desired location. 

Once you close and restart PRIME Switcher, then the Sources display in their new positions on 
the PRIME interface. 
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Add the ME1 Bank 
If the PRIME Switcher displays only the Main Bank, then you can add the ME1 Bank: 

1.​ From the PRIME Switcher menu, go to Config Menu > Playout Configuration. The 
Playout Configuration Sources tab appears. 

2.​ Click the Add Mix Effects icon. Mix Effect (ME1) appears at the bottom of the Source 
List. 
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3.​ The default Mix Effects source is Mix Effects 1. 

 

Once you close and restart PRIME Switcher, then the ME1 Bank appears on the PRIME 
Switcher interface. 

NOTE: Once you have completed Source and any other configurations, remember to 
close, and then restart PRIME Switcher to apply the configurations. 
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Chapter 8: Configure Atlas 

Overview 
The Atlas stream provides the ability to display proxy monitors and other PRIME Switcher 
interface components, such as the Program, Preview and Mix Effects monitors, and the Clips 
and Graphics Player monitors.  

If a channel has been configured in Playout Configuration, and a component has been 
enabled (e.g., a Clip Player), then it can be displayed in the PRIME Switcher interface. 

It may also be desirable to display only specific components e.g., CAM1, CAM2, CAM3, CAM4 
in the interface, even though eight CAMS may be configured. You can disable display of CAMs 
5-8 in the View menu. To remove them from the View menu, so that they cannot be displayed, 
you can remove them from Atlas configuration. 

NOTE: Even if sources are not configured in Atlas, the switcher buttons for those 
sources are still active, and they can be switched to Preview or Program. To disable 
operation of the channel, while still retaining its configuration: 

●​ Go to Config Menu > Playout Configuration > Video Channels, and click 
(uncheck) the enable/disable checkbox at the top of the channel’s configuration 
settings. The channels still appear on the Status Indicator, but display red. The 
following shows Video Inputs 7 and 8 disabled. 

 

​
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To access Atlas configuration: 

●​ Go to Config Menu > Playout Configuration, and then in the left navigation, click 
Atlas. The Atlas Panel displays. For easier and more detailed viewing in this document, 
the following shows the panel narrowed and lengthened to see all components, and the 
Auxiliary Audio Labels relabeled. 

 

​
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Settings are as follows: 

Enable/Disable: Enables/disables the display of the monitors in the PRIME Switcher 
interface. 

●​ If enabled, then the monitors of the Channels listed in the Atlas Panel display in the 
PRIME Switcher interface. They also appear in the View menu. 

●​ If disabled, then none of the monitors of the Channels listed in the Atlas Panel display 
in the PRIME Switcher interface. They also do not appear in the View menu. 

NOTE: If Atlas is enabled, and monitors do not display in the PRIME Switcher interface, 
then ensure that: 

●​ You have added the Channels as Video Sources in Config Menu > Playout 
Configuration > Switcher > Sources. 

●​ In the View menu, you have enabled the Channels for display. Enable/Disable 
component display. 

●​ The Grid dimensions and/or component Size accommodate the display of the 
components. 

Grid: The grid displayed at the right of the Atlas Panel displays the names of all items that 
display in the interface. To configure the Grid, see Configure Grid. 

Labels: Show/Do Not Show. Each monitor can display a label for easier identification. The 
label does not appear on output. The label obscures the underlying video, so configure ahead 
of time for optimal viewing. The following shows a monitor with no label, with a label with fully 
stretched background, and a label with a background only behind the text. 

   

To enable/disable and configure label appearance, see Configure Label Display - Show Label. 

​
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The Atlas panel comprises the following columns: 

●​ List Position Up/Down Icon : The column header for the List Reposition icons . 
●​ Channel: The source of Channel that is to display in the PRIME Switcher interface. You 

can select from the dropdown, but not edit the items. There are five source types: 

○​ Black 
○​ Video Input 
○​ Clip Player 
○​ Graphics 
○​ Mix Effects 

●​ Size: The size of the monitor with respect to the other monitors. 

○​ Small 
○​ Medium 
○​ Large 
○​ Hidden 

We advise setting Size to Small for all Channels. Setting a component to a larger size 
can set the Grid in a manner that may not accommodate the display of all components. 

Auxiliary Audio channels are always set to Hidden. 

●​ Label: The text to display that identifies the monitor, e.g., Program, CAM1, CLP1, 
GFX2. Depending upon configuration, the Label text appears on a component tab, 
and/or on the monitor itself. See Configure Label Display - Show Label. 

●​ Include Audio: Include audio in the Atlas stream. If the Audio Channel Audio Mode is 
set to Disabled in Config Menu > Playout Configuration > Video Channels, then: 

■​ The Include Audio field for that Atlas channel specifies Disabled and is grayed 
out; and, 

■​ Audio Channels automatically specifies N/A. 

●​ Audio Channels: Assigns one channel (if Mono) or two channels (if Stereo) to the Atlas 
stream audio. 
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Configure Grid 

The Grid displays the names of the components that, with the exception of the Clean Feed, 
display in the PRIME Switcher interface. 

 

The Grid dimensions determine the maximum number of monitors (Preview, Program, ME1, 
Video Inputs, Clip Players, Graphics Players) that the PRIME Switcher displays. The order in 
which the monitors display in the Grid does not determine the order of display in the PRIME 
Switcher interface. 

Also note the following: 

●​ The Clean Feed displays only on the Device specified Config > Playout Config > 
Video Channels, e.g., Matrox SDI, NDI, etc. Even if added to the Atlas stream, it does 
not display in the PRIME Switcher interface. 

●​ While you can add Auxiliary Audio Channels to the Atlas stream, they do not appear 
in the Grid, and it is not necessary to add them to the Atlas stream for them to display 
as Audio Buses. The visual representation of the Audio Buses in the PRIME Switcher 
interface, is set in Config > Playout Config > Switcher > Audio Buses. 

You can set the grid display as follows: 

●​ Auto Enabled: If enabled, then automatically and evenly distributes the monitors in the 
PRIME Switcher interface. We advise that you enable Auto. 

●​ Auto Disabled: If disabled, then allows selection of Grid dimension from 2 x 2 to 8 x 8. 
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If you set a Grid dimension that does not accommodate all of the components, then the Atlas 
list displays a red outline around the components that it cannot accommodate. As such, the 
outlined components: 

●​ Do not display in the PRIME Switcher interface; and, 

●​ Do not display in the View menu. 

Caution: 

●​ The outlined components remain in Config > Playout Config > Sources. As such, 
these sources are still live in PRIME Switcher, and can be taken to Preview or 
Program, even if the monitors are not displayed. 

●​ If Clip Players or Graphics Players are among the outlined components, then the 
players display, but not the content of the players. They still operate. 
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Configure Label Display - Show Label 
You can enable or disable the display of a label on each monitor, and configure the appearance 
of the label. 

To display labels: 

●​ Enable (check) the Show checkbox. 

NOTE: If displaying monitors in a single grid window, as opposed to each in its own 
individual window, then it is advisable to show labels, in order to quickly identify the 
inputs. 
 

​
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Video Sources Displayed in Individual Windows 

 

Video Sources in Single Grid Window with No Labels 

 

Video Sources Displayed in Single Grid Window with Labels 

 

See Set Video Input Display for details. 

​
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To display the label settings: 

●​ Click the dropdown directly to the right of the Show checkbox. The label parameters 
display. 

 

●​ Location: Select the location of the label on the monitor. 

○​ Top Left 
○​ Top Center 
○​ Top Right 
○​ Bottom Left 
○​ Bottom Center 
○​ Bottom Right 

●​ Font: Select the font for the label. 

●​ Foreground: Use the Color Picker to select the foreground, i.e., the font color. Click 
the Advanced tab to set a custom color and transparency. 

●​ Background: Use the Color Picker to select the background color. Click the 
Advanced tab to set a custom color and transparency. Transparency is advised, so that 
the underlying video is visible. 

●​ Height: % of the total monitor height to which the label is set. Use the spin box to set. 
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●​ Stretch Background: Enable/disable. 

○​ When enabled, the label background extends across the entire monitor. 

 

○​ When disabled, the label background extends across the length of the label text, 
plus the padding. 

 

●​ Padding: The size of the padding, in pixels, surrounding the label text. Use the spin box 
to set. 
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Add Channel Display 
To add the display of a component to the PRIME Switcher interface: 

1.​ Click the Add icon . A new item appears at the bottom of the Channel list. In 
this example a Clean Feed has automatically been added. The type of Channel added 
is based on available channels based on the system configuration. 

 

NOTE: If, upon adding a Channel, the Channel field is blank, then ensure that you have 
added the Channel in Config Menu > Playout Configuration > Video Channels. 
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2.​ For this example, you will change Clean Feed to Video Input 8. From the Channel 
dropdown, select Video Input 8. 

 

 

​
 

169 | PRIME 5.3 Switcher User Guide​
​
 



Relabel a Channel 
If the Label Show checkbox is enabled, then the label, as specified in Channel’s Label field, 
displays on the monitor in the PRIME Switcher interface. 

To relabel a Channel: 

●​ Click the Channel’s Label field, and then enter a new Label name. 

Delete a Channel Display 
To delete the display of a Channel, so that it no longer displays in the PRIME Switcher 
Interface, and it no longer appears in the View menu: 

Select the Channel that you would like to delete, then do one of the following: 

●​ Press Delete. 

●​ Click the Remove icon . 

The Channel no longer appears in the Channel list. 
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Reorder Channel Display 
The order of the Channels in the list is reflected in the PRIME Switcher interface. It may be 
desirable to reposition one or more Channels in the Atlas list. To reposition a Channel: 

1.​ Click the row of the Channel to be moved. 

2.​ Click the Reposition icon  at the left of the Channel name. 
3.​ Drag the Channel to the desired location. 

In this example, Video Input 8 is moved directly following Video Input 7. 

 

Once you close and restart PRIME Switcher, then the components display in their new 
positions on the PRIME interface. 

 

​
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Chapter 9: Configure Transitions 

Overview 
A Transition Effect controls how video and graphics transition to or from Program. A 
Transition Effect can be a simple Cut, Wipe, or Dissolve, or a more complex, custom-built 
effect created in PRIME. Transition Effects are configured based on Transition Types within 
the Transitions Configuration Panel, and can be added, configured, deleted, and edited. You 
can create multiple Transition Effects based on the same Transition Type. 

You can configure up to five Transition Effects, which are displayed as buttons on the PRIME 
Switcher Transitions Area from left to right, in the order in which they are listed in the 
Transitions Configuration Panel. See Configure Transition Effect Button Display Order for 
information on how to set the Transition Effect button order. 

See Work with Main and Mix Effect (ME) Banks and Transitions for information on how to set 
and perform transitions in the switcher. 

Access the Transitions Configuration Panel 
To access the Transitions Configuration Panel: 

1.​ In the PRIME Switcher menu bar, go to Config Menu > Playout Configuration. The 
Video Channels panel appears. 

2.​ In the left navigation, click Switcher. The Switcher Sources panel appears. 

​
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3.​ Click the Transitions tab. The Transitions panel appears. 

 

The Transitions Panel comprises the following columns: 

●​ List Position Up/Down Icon : The column header for the List Reposition icons . 
●​ Type: the type of transition. This field is not editable. Three transition types are 

available: 
○​ Dissolve 
○​ Wipe 
○​ Custom 

●​ Name: The name of the transition, which can be set by the user. 
●​ Properties: Transition-specific properties, which can be set by the user. 

You can add, configure, and delete transitions from this panel. 

Switcher Transition files are in *.pst format. PRIME Switcher can also apply a Clip Transition 
file (*.pct format) to a transition. Note that a *.pst file cannot be used as a Clip Transition. 
​
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NOTE: Once you have completed Transition and any other configurations, remember to 
close, and then restart PRIME Switcher to apply the configurations. 

Add Transition 
You can add a Dissolve, Wipe or Custom Transition Effect to the PRIME Switcher interface. 

To add a transition: 

1.​ Click the Dissolve, Wipe or Custom icon at the top of the Transitions Panel. 

 

2.​ Each type of transition has transition-specific parameters as described in Transition 
Types. Configure as desired. 

Once you close and restart PRIME Switcher, then the new Transition Effect appears on the 
PRIME Switcher interface. 

Transition Types 

Overview 
PRIME Switcher provides three built-in Transition Types: Cut, Wipe and Dissolve. Custom 
transition files can be created within PRIME and imported and applied as PRIME transitions. 

Cut 
A Cut switches instantaneously from one video source to another. Sources are not mixed. Cut 
is the only transition that cannot be edited. 
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Dissolve 
A Dissolve simultaneously fades the Program video out as the Preview video fades in. Both 
sources are at full screen throughout the transition. 

The following Dissolve parameters can be configured: 

●​ Name: Default Name is DISS. To edit: 

1.​ Select the transition row, and then click the Name field. 
2.​ Enter the new name, then press Enter. 

●​ Properties: The duration of the Dissolve, in frames. To set: 

1.​ Enter a value or use the spinner to set a value. 
2.​ Press Enter. 

More than one Dissolve transition can be configured. To add a Dissolve transition: 

1.​ At the top of the Transitions tab, click Dissolve. The new Dissolve transition appears 
in the Transitions list. 

2.​ Configure as described above. 

Once you close and restart PRIME Switcher, then the Transition Effect settings are applied. 

Wipe 
Preview channel video wipes over the Program channel video in the configured direction. For 
example, if a Wipe is set to Left, then the Preview video enters the Program screen from the 
right, and moves left, covering the Program video. 

The following Wipe parameters can be configured: 

●​ Name: Default Name is WIPE. To edit: 

1.​ Select the transition row, and then click the Name field. 
2.​ Enter the new name, and then press Enter. 

●​ Properties: The duration of the Wipe, in frames. Default is 25 frames. To set: 

1.​ Enter a value or use the spinner to set a value. 
2.​ Press Enter. 

●​ Direction: The direction in which the Wipe moves. Default is Left. To set: 

○​ From the dropdown, select Left, Right, Up or Down. 
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●​ Feather: Applies a soft edge to the wipe edge. Default is 0 frames (hard edge). To set: 

1.​ Enter a value or use the spinner to set a value. The higher the value, the softer 

the edge. Range: 0 - ∞ 

2.​ Press Enter. 

More than one Wipe transition can be configured. To add a Wipe transition: 

1.​ At the top of the Transitions tab, click Wipe. The new Wipe transition appears in the 
Transitions list. 

2.​ Configure as described above. 

Once you close and restart PRIME Switcher, then the Transition Effect settings are applied. 
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Custom 
You can add a Custom transition to the PRIME Switcher. Custom transitions must be created 
in PRIME, and must be of file format *.pst or *.pct. To add a Custom transition: 

1.​ At the top of the Transitions tab, click Custom. The new Custom appears in the 
Transitions List. 

 

2.​ If desired, edit the Name. 
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3.​ Click the Browse button  to the right of the File field. From the Browse dialog, 
select the desired *.pst or *.pct Transition file, and then click Open. The Browse 
dialog closes. The file name appears in the File field. 

 

Once you close and restart PRIME Switcher, then the Transition Effect settings are applied. 

Rename Transition Effect 
You can edit Transition Names. It is good practice for a Transition Name to be short enough 
to display in its entirety on a Prime Switcher Transition Effect button; otherwise, part of the 
label name does not display. To edit a Transition Name: 

●​ In the Name field, type a new name. 

Once you close and restart PRIME Switcher, then the new name appears on the Transition 
Effect button on the PRIME Switcher interface. 
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Reconfigure an Existing PRIME Switcher Transition Effect 
To reconfigure an existing Transition Effect: 

1.​ Click the row of the Transition to be reconfigured. 
2.​ Reconfigure the settings as desired. 

Once you close and restart PRIME Switcher, then the reconfigured Transition Effect is applied. 

Delete a Transition 
To delete a transition: 

1.​ Highlight the row that contains the transition. 
2.​ Press Delete, or, at the top of the Transitions tab, click Remove. 

Once you close and restart PRIME Switcher, then the deleted Transition Effect no longer 
appears on the PRIME Switcher interface. 

Sort the Transition List 
The Transition List can be sorted by Name, in either ascending or descending order. To sort 
the list: 

●​ Click the Name heading to toggle the Transition list in ascending or descending 
alphabetical order. 

Once you close and restart PRIME Switcher, then the Sort settings are applied to the PRIME 
Switcher interface. 

Configure Transition Effect Button Display Order 
It may be desirable to reposition one or more Transition Effects in the Transition List. The 
new position is reflected in the left-to-right order of the Transition Effects buttons in the 
switcher Transition Area. To reposition a Transition Effect: 

1.​ Click the List Reposition icon  at the left of the row that contains the transition that 
is to be moved. 

2.​ Drag the transition to the desired location. 

Once you close and restart PRIME Switcher, then the Transition Effect buttons display in their 
new positions on the PRIME Switcher interface. 
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NOTE: Once you have completed Transition and any other configurations, remember to 
close, and then restart PRIME Switcher to apply the configurations. 

Chapter 10: Configure Playlist Players 

Overview and Access the Playlist Configuration Panel 

You can configure PRIME Playlist Players for playlist playout in PRIME Switcher. 

To access the Playlist Configuration Panel: 

1.​ In the PRIME Switcher menu bar, go to Config Menu > Playout Configuration. The 
Video Channels panel appears. 

2.​ In the left navigation, click Playlists. The Playlists panel appears. 

 

​
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Add Playlist Player 
To add a Playlist Player: 

1.​ Click Add Playlist . 
2.​ A new Playlist Player appears. 

 

3.​ In the Name field, enter the name of the new Playlist Player. 
4.​ Do one of the following: 

○​ To set the Playlist Player not to automatically advance to the next item in a 
playlist after the current clip/graphic/scene/message has played, leave the Auto 
Advance checkbox blank. 

○​ To set the Playlist Player to automatically advance to the next item in a playlist 
after the current clip/graphic/scene/message has played, check the Auto 
Advance checkbox to enable. 

Once you close and restart PRIME Switcher, then the new Playlist Player becomes available in 
the View menu, from which visibility can be enabled. 

See Play Back Graphics/Messages/Images/Clips from the PRIME Playlist. 
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Enable a Playlist 
You can enable or disable availability of a Playlist Player without removing it. 

To enable or disable Playlist Player availability: 

●​ Check the checkbox to the left of the Playlist Player number: 
○​ To disable, leave the checkbox blank. 
○​ To enable, check the checkbox. 

Once you close and restart PRIME Switcher, then the specified playlist availability is applied. 
You can then enable/disable Playlist Player visibility from the View menu. 

Delete a Playlist 
To delete a Playlist Player: 

●​ Click the Close icon (x) to the right of the Playlist Player number. 

Once you close and restart PRIME Switcher, then the playlist no longer appears. 

 

​
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Chapter 11: Configure Audio Channels 

Overview 
The Audio panel provides the ability to configure, add, edit, and delete PRIME Switcher audio 
sources. The number and types of available audio sources depends upon PRIME configuration. 

You can configure each of the audio inputs, which are displayed in the Audio Mixer as Audio 
Faders, from left to right, in the order in which they are listed in the Audio Configuration 
Panel. See Configure Audio Fader Display Order for information on how to set Audio Fader 
order. 

Access the Audio Channels Configuration Panel 
To access the Audio Channels Configuration Panel: 

1.​ In the PRIME Switcher menu bar, go to Config Menu > Playout Configuration. The 
Video Channels panel appears. 

2.​ In the left navigation, click Switcher. The Switcher Sources panel appears. 
3.​ Click the Audio Channels tab. The Audio Channels panel appears. 

 

​
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The Audio Channels panel comprises the following columns: 

●​ List Position Up/Down Icon : The column header for the List Reposition icons . 
●​ Name: The name of the audio source, which can be set by the user. 
●​ Source: The audio source, selected by the user. 
●​ Input Count: User-set input index number. Maximum number is determined by number 

of Audio Channels set for the specified Input in: 
Config Playout Config > Video Channels 

●​ Input Channel: Audio input channels from the source. The number and choice of 
channels depends upon the number set in the Input Count. 

●​ Include in Main: Include in PRIME Switcher Main Audio Bus and Main output. 
●​ Main Count: Number of Audio Channels in the Main Count, number, the maximum 

determined by number of Audio Channels set for the specified Input in: 
Config Playout Config > Switcher > Audio Buses > Type: Main. 
This maximum applies to all Main Count settings in the Audio Channels Panel. 

●​ Main Channel: Number of audio input channels from the source. The number and 
choice of channels depends upon the number set in the Main Count. 

●​ Delay: Delay in relation to the selected source for that channel. Used for audio-video 
synchronization. Range: 0 - 192 milliseconds. 

Set Duck Frame Count 
Duck Frame Count specifies the duration, in frames, of the transition to and from duck under. 
The Duck Frame Count applies to all audio sources and is triggered via API only. Range: 0 - 
∞. 

To set Duck Frame Count, do one of the following: 

○​ Enter the Duck Frame Count value in the Duck Frame Count field. 
○​ Use the spin box to set the Duck Frame Count value. 

NOTE: Once you have completed Audio and any other configurations, remember to close, 
and then restart PRIME Switcher to apply the configurations. 
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Add an Audio Channel 
You can add a new Audio Channel to the PRIME Switcher. 

The Add Audio Channel icon , as well as a Remove Selected Audio Channel 

icon , are displayed at the top of the Audio Channels Panel. 

In the following example, an Audio Channel for the Video Input 7 is added. 

1.​ In the Audio panel, click the Add Audio Channel icon . A new audio 
Source is added to the audio sources list. By default, the Audio Channel Name is 
AUDIO<x>, where x is the next available number with the prefix AUDIO. In this 
example, the name is AUDIO1. 
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2.​ Click the Source dropdown for the new audio source, and then select a source. PRIME 
Switcher selects the most logical source, which you can change. For this example, a 
Video Input 7 is selected as the AUDIO1 source. If another source is available, 
however, then you can select a different source. 

 

​
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3.​ If desired, then enter a new name in the Name field of the audio source. The name 
should be short enough to be readable on the PRIME Switcher Audio Mixer. Excess 
characters are truncated on the PRIME Switcher interface. 

 

4.​ If desired: 

a.​ Using direct entry or the spinners, set Input Count, Main Count, and Delay. 

b.​ From the dropdowns, select Input Channel and Main Channel. 

c.​ Enable/disable Include in Main. 

■​ If Include in Main is enabled, then the Audio Channel appears in the 
Main Audio Bus and outputs to the Main Audio Bus audio output. 

■​ If Include in Main is disabled, then the Audio Channel does not appear 
in the Main Audio Bus and does not output to the Main Audio Bus 
audio output. 

All Audio Channels configured in this panel appear in the Auxiliary Buses, 
regardless of whether or not Include in Main is enabled or disabled. 
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5.​ If desired, reposition the Audio Fader in the list so that it follows the Video Input 6 
Audio Fader. 

 

Once you close and restart PRIME Switcher, then the Audio Channels configuration is applied. 

Rename an Audio Source 
You can edit Audio Source Names. It is good practice for an Audio Source Name to be short 
enough to display in its entirety on a Prime Switcher Audio Fader label; otherwise, part of the 
label name does not display. To edit an Audio Source Name: 

1.​ Click the row of the Source to be renamed. 
2.​ Enter a new name. The name should be short enough to be readable on the Audio 

Mixer. Excess characters are truncated on the Audio Mixer interface. 

Once you close and restart PRIME Switcher, then the new name appears on the Audio Fader 
label on the PRIME Switcher interface. 
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Reconfigure an Existing PRIME Switcher Audio Source 
To reconfigure an existing PRIME Switcher Audio Source. 

1.​ Click the row of the Source to be reconfigured. 
2.​ Reconfigure the settings as desired. 

Once you close and restart PRIME Switcher, then the reconfigured Audio Source is applied. 

Delete an Audio Source 
To delete an Audio Source: 

1.​ Click the row of the Source to be deleted. 
2.​ Do one of the following: 

○​ Press Delete. 

○​ Click the Remove icon . 

Once you close and restart PRIME Switcher, then the deleted Audio Fader no longer appears 
on the PRIME Switcher interface. 

Configure Audio Fader Display Order 
It may be desirable to reposition one or more sources in the Audio Source List. The reposition 
is reflected in the left-to-right order of the Audio Faders in the Audio Mixer. To reposition a 
source: 

1.​ Click the row of the source to be moved. 

2.​ Click the Reposition icon  at the left of the Source Type. 
3.​ Drag the Source to the desired location. 

Once you close and restart PRIME Switcher, then the Audio Faders display in their new 
positions on the PRIME Switcher interface. 

NOTE: Once you have completed Audio and any other configurations, remember to 
close, and then restart PRIME Switcher to apply the configurations. 
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Chapter 12: Configure Audio Buses -​
Mix Minus, Pre Fade Listen 

Overview 
An Auxiliary Audio Bus is a signal path that is auxiliary to the main audio path of the Audio 
Mixer. You can configure one or more Auxiliary Audio Buses to create a variety of Mix Minus 
outputs. Common uses of an Auxiliary Audio Bus include the following: 

●​ Provide an isolated iFB feed of an anchor to a reporter, so that the reporter does 
not hear their own voice echoed in the iFB: To do so, create an Auxiliary Audio Bus, 
and then raise the level of the channel(s) that the reporter should hear, excluding the 
reporter’s own channel. 

●​ Monitor a specific audio channel, i.e., Pre Fade Listen: To do so, create an Auxiliary 
Audio Bus, and then raise the audio level of the audio channel that you would like to 
monitor. 

The MAIN Audio Bus is always present in the Audio Mixer. Follow Video and Mute are 
available to the Audio Buses as follows: 

●​ Follow Video: MAIN Audio Bus only. 
●​ Mute: MAIN and Auxiliary Audio Buses. 
●​ MASTER Audio Fader: Controls output of the MAIN Audio Bus. 

If no Auxiliary Audio Bus(es) are configured, then the Audio Mixer displays the Main Bus and 
Master Audio Faders only. 
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If Auxiliary Audio Buses are configured, then the Audio Mixer displays Main and Auxiliary 
Audio Bus buttons, in addition to the audio faders. The following shows buttons for the Main 
and three Auxiliary Audio Buses.  

 

In the Auxiliary Audio Buses, the Follow Video button is replaced by a PRE button . The 
PRE button is not yet operational. 

Each Auxiliary Bus button provides its own set of faders that you can set independently of the 
MAIN and other Auxiliary Buses, and that enable you to create your own Mix Minus outputs. 
You can change Auxiliary Bus audio levels at any time, and can create mixes involving one or 
multiple audio sources. For example, you can set the AUX1 Audio Bus to output CAM2 and 
CAM3 audio, and AUX 5 to output only CAM5 audio. 

 

​
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Depending upon the audio hardware and setup, Auxiliary Audio Buses can output on 
unallocated PRIME Switcher Program channels, or can output on channels, from, e.g., an 
audio card. The configuration is highly customizable.    

You can allocate Auxiliary Audio Bus outputs to unused Program channels or to other 
channels. PRIME Switcher provides 16 channels of Program audio output. By default, two are 
allocated for Program output, although you can change the number of Program audio 
channels. The audio channels not allocated to Program can be allocated to Auxiliary Audio 
Buses in one of two ways: 

●​ Via the creation of Auxiliary Audio Channels, which are used as outputs for the 
Auxiliary Audio Buses. 

●​ Direct allocation of outputs in the Audio Bus configuration. 

Audio Channels not included in the Program output can also be allocated via the creation of 
Auxiliary Audio Channels or directly via Auxiliary Audio Bus configuration. 

To create an Auxiliary Channel to use as an output for an Auxiliary Audio Bus: 

1.​ Configure the Auxiliary Channels within Config Menu > Playout Configuration > 
Video Channels. This is an optional step. 

2.​ Configure the Audio Buses within Config Menu > Playout Configuration > Switcher 
> Audio Buses. 

To configure an Auxiliary Audio Bus without the creation of an Auxiliary Audio Channel: 

●​ Configure the Audio Buses within Config Menu > Playout Configuration > Switcher 
> Audio Buses. 

​
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Configure Auxiliary Audio Channels 
For this exercise, you will set the Main and Auxiliary Audio Buses to output to the Program 
Audio Channels. 

●​ Program Channels  1 and 2 to Program. 

●​ Program Channels  3 and 4 to Auxiliary Audio Channel 1. 

●​ Program Channels  5 and 6 to Auxiliary Audio Channel 2. 

●​ Program Channels  7 to 10 to Auxiliary Audio Channel 3. 

●​ Program Channels  11 to 14 to Auxiliary Audio Channel 4. 

●​ Program Channels  15 and 16 to Auxiliary Audio Channel 5. 

In PRIME Switcher, the term “channel” has multiple meanings, so it is important to understand 
how the term is used. 

●​ In Config > Playout Configuration > Video Channels, you can configure video output 
channels, video input channels, audio output channels, and audio input channels. In the 
Video Channels configuration panel, each channel is represented by a vertical column 
of settings. 

●​ Depending upon the Device that you specify, you can allocate a number of individual 
audio channels to a video or audio channel that you configure. These settings are 
represented by the Audio Channels setting for each of the channels described in the 
previous bullet. 

For example, when the Device is a Matrox SDI Video Output, its embedded audio 
provides 16 individual Audio Channels. 
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To configure the Auxiliary Audio Channels: 

1.​ Go to Config Menu > Playout Configuration, and if Video Channels is not already 
displayed, then in the left navigation, select Video Channels. 

 

2.​ At the top of the panel, in the second row of icons, click Add Output dropdown arrow, 
and then select Add Auxiliary Audio Output. 

 

​
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NOTE: Do not click the Add Output icon to add the Auxiliary Audio Output. You 
must click the dropdown arrow. If you instead click the Add Output icon, then by 
default, a video channel is added to the configuration. This may also result in the 
display of an alert stating that you must update the firmware, as the allowable number 
of video channels, per the license, has been exceeded. 

If you accidentally add a video channel, then remove it as follows: 

●​ Scroll the Video Channels Panel to the right, until you see the settings for the 
newly added channel, and then click the Close icon at the upper right of the 
settings for the channel. The channel is removed. 
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3.​ To add each additional Auxiliary Audio Output, repeat step 2. 
4.​ Scroll the Video Channels Panel to the right, until you see the settings for the newly 

added Auxiliary Audio Output. 

 

 

​
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Settings are as follows: 

●​ Channel: Disables/enables the channel. 

●​ Device: Displays Auxiliary Audio. 

●​ Connector: Parent: The Channel to which the Auxiliary Audio outputs. The 
Auxiliary Audio outputs on the specified Audio Channels of the Parent. In the 
following figure, the Auxiliary Audio outputs on Program Audio Channels 3 
and 4. For this exercise, the Parent for each Auxiliary Output is set to Program. 

 

​
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●​ Name: Default name is Auxiliary Audio <number>. Numbering starts at 1. To 
change the Name, enter a new name. 

●​ Audio Mode: The following modes are available: 

○​ Disabled. The Auxiliary Audio is not output. The Output Channels are 
not available in Config Menu > Playout Configuration > Switcher > 
Audio Buses. Audio is not output from this Auxiliary Audio Channel.  

Channels that are assigned to a disabled channel become available to 
the next Output. For example, if Output 10 Audio Mode is Disabled, 
then the Program Channels 13-14 that are assigned to Output 10, 
become available to Output 11. 

○​ Virtual: The Auxiliary Audio is output on one or more virtual channels. 
The channels are further configured in the Config Menu > Playout 
Configuration > Switcher > Audio Buses - Output Channel setting. 

○​ System: The Auxiliary Audio is output on one or more system channels. 
When System is selected, the Audio Device setting displays. The 
channels are further configured in the Config Menu > Playout 
Configuration > Switcher > Audio Buses - Output Channel setting. 

It is not necessary to select the same Audio Mode for each Auxiliary Audio 
Output. 

●​ Audio Device: Displays only when Audio Mode: System is selected. Available 
choices are or are similar to the following, but may differ depending on the 
specific hardware: 

○​ Primary Sound Driver 
○​ Digital Audio (S/PDIF) (High Definition) 
○​ U28E590 (NVIDIA High Definition) 
○​ Speakers (USB Audio Device) 
○​ Any other Audio Devices available to the system 

It is not necessary to select the same Audio Device for each Auxiliary Audio 
Output. 
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●​ Audio Channels: You can allocate the available channels, in pairs, quads, or 
sets of eight as you wish. The total number of Audio Channels available to 
Program plus the Auxiliary Channels is 16. For example, you can allocate: 

○​ 2 channels to Program, and 2 channels to each of 7 additional Auxiliary 
Audio Outputs; or, 

○​ 4 channels to Program, 4 channels to one Auxiliary Audio Output, and 
2 channels each to 4 additional Auxiliary Audio Outputs. 

As you allocate channels to an Auxiliary Audio Output, each additional 
Auxiliary Audio Output displays the remaining available channels, in sets of 2, 4 
and 8. As such, you cannot allocate the same pair of channels to more than one 
Audio Output, including MAIN. 

For the following example, five Auxiliary Audio Outputs have been added, and 
renamed Auxiliary Audio Output 1, Auxiliary Audio Output 2, Auxiliary Audio 
Output 3, Auxiliary Audio Output 4, and Auxiliary Audio Output 5, 
respectively. Audio Mode is set to Virtual for all Auxiliary Audio Outputs. 

If you allocate 2 channels (Program 1-2) to Program (also referred to as MAIN), 
then the channels available to Auxiliary Audio Output 1 are as follows: 

 
Auxiliary Audio Output 1 

You can allocate 0, 2, 4 or 8 channels to Auxiliary Audio Output 1. 

If you allocate 2 channels to Auxiliary Audio Output 1, then the channels 
available to Auxiliary Audio Output 2 are as follows: 

 
Auxiliary Audio Output 2 

You can allocate 0, 2, 4 or 8 channels to Auxiliary Audio Output 2. 
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If you allocate 2 channels to Auxiliary Audio Output 2, then the channels 
available to Auxiliary Audio Output 3 are as follows: 

 
Auxiliary Audio Output 3 

You can allocate 0, 2, 4 or 8 channels to Auxiliary Audio Output 3. 

If you allocate 4 channels to Auxiliary Audio Output 3, then the channels 
available to Auxiliary Audio Output 4 are as follows: 

 
Auxiliary Audio Output 4 

You can allocate 0, 2 or 4 channels to Auxiliary Audio Output 4. 

If you allocate 4 channels to Auxiliary Audio Output 4, then the channels 
available to Auxiliary Audio Output 5 are as follows: 

 
Auxiliary Audio Output 5 

You can allocate 0 or the remaining 2 channels to Auxiliary Audio Output 5. 
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The final configuration is as follows: 

 
This example represents only one of the many ways that you can configure the 
Auxiliary Audio Outputs. The previous figure shows the Auxiliary Audio 
channels renamed Auxiliary Audio 1, Auxiliary Audio 2, Auxiliary Audio 3, and 
Auxiliary Audio 4. 

5.​ After you complete Auxiliary Audio Output configuration, click Apply. Doing so saves 
the settings, but does not close Playout Configuration. If you would like to close 
Playout Configuration, then click OK to save the configuration. Note that settings are 
not applied until you close and restart PRIME Switcher. 

6.​ Click Apply, and then proceed to the next section. 
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Configure Audio Buses 

You can configure Auxiliary Audio Buses using Audio Channels configured in Config > 
Playout Configuration > Video Channels as the outputs, or bypass the configuration of Audio 
Channels within the Video Channel configuration. In either instance, you must configure the 
Audio Buses. 

To configure the Audio Buses: 

1.​ If Playout Configuration is already open, then in the left navigation, click Switcher. If 
Playout Configuration is not open, then go to Config Menu > Playout Configuration, 
and then click the Audio Buses tab. The Audio Buses Panel displays. 

 

​ The Audio Buses panel comprises the following columns: 

●​ List Position Up/Down Icon : The column header for the List Reposition 

icons . 

●​ Name: The name of the audio source. To change the Name, enter a new name. 

●​ Type: The type of the Audio Bus, as determined by its configuration in the 
Video Channels Panel. In the above figure, the Type is Main, corresponding to 
the Main Program Output. For an Auxiliary Bus, Type is automatically 
specified as Aux Send. 
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●​ Output: The source for the Audio Bus. In the above figure, the source is the 
Main Program Output. 

●​ Output Count: The number of outputs. The maximum value is based on the 
number of channels set for Auxiliary Audio 1 in the Video Channels Panel. The 
default value is 2. If more than 2 channels are available, then the spin box up 
arrow becomes active , i.e., not grayed out. 

○​ Output Count = 1: Mono 

○​ Output Count = 2: Stereo 

●​ Output Channel: The output channels. Maximum number of channels specified 
by the Output Count. The number of channels available reflects the number of 
channels set in the Output Count. For example, if 8 channels are set for an 
Auxiliary Audio Channel in the Video Channel Panel, then you can specify up 
to 8 channels in the Output Count. If you set Output Count to 6, then the 
following 6-channel Output Channel settings are available: 

 

​
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2.​ In this example, continue using the configuration set in the previous section. Click the 

Audio Bus icon. A new Audio Bus appears in the Audio Bus list. 
3.​ If desired, then enter a different name in the Name field. 
4.​ Click the Output dropdown and specify Auxiliary Audio 1. 

 
​
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NOTE: If the Output item is grayed out, and Disabled Audio Mode icon  
appears to the right of the Output item in the dropdown, then it indicates that 
the Audio Mode for the channel has been set to Disabled in Config Menu > 
Playout Configuration > Video Channels. If you select that item, then the output 
for the Audio Bus is disabled. 

 

​
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5.​ Using the spin box, set the Output Count as desired. 
6.​ From the Output Channel dropdown, select the desired Output Channels. For this 

example, leave the setting at Channel 1,2. 
7.​ The number of available Output Channels is the same as the value set in the Output 

Count. 
8.​ To configure additional Auxiliary Buses, repeat steps 2 through 7. 
9.​ When configuration is complete, then click Apply to continue other configuration, or OK 

to close the Playout Configuration Panel. 
10.​After closing the Playout Configuration Panel, close and restart PRIME Switcher. The 

newly configured Audio Buses display in the Audio Mixer. 

The following shows an Audio Mixer with five Auxiliary Buses: 

 

Display Audio Bus and Set Level(s) 
To display an Audio Bus: 

1.​ Click the button of the Audio Bus that you would like to display. 

2.​ Adjust the audio fader(s) to the desired level(s). The audio mix from this bus outputs on 
the channels specified for this bus.  
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Chapter 13: Assets Browser 

Overview 
The Assets Browser provides access to assets, such as graphics and clips, that the PRIME 
Switcher may use. You can add, remove, and change the display mode of an Assets Browser, 
navigate to other folders from within the browser, and perform operations such as Cut, Paste, 
and Delete. You can also drag clips and graphics into their respective players to quickly load 
and play. 

The following figure shows a Scenes Browser tab, and a Clips Browser tab. The Clips 
Browser displays thumbnails of the available clips. By default, PRIME Switcher displays the 
Scenes Browser and Clips Browser. 

 

If desired, a tab can be isolated, resized, and repositioned. See Tab Groups for details on tab 
operations. You can save an Assets Browser display as part of a custom layout. 

Assets Browser Types 

Overview 
There are two types of Assets Browsers: 

●​ Non-Asset Type-Specific Browser: This Assets Browser type displays all files in the 
open folder. 

●​ Asset Type-Specific Browser: This Assets Browser type displays only the files that 
are of the type specified for the browser. For example, if the browser is a Clips 
Browser, then only clip files are displayed. To set a browser type, see Change to a 
Different Assets Browser Type. 

There are functions common to both types of browsers and functions specific to each. 
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Non-Asset Type-Specific Browser 
A non-asset type-specific browser displays all contents of the folder that is open in the 

browser. This type of browser is identified by the Browse icon  and name at the upper left 
of the browser, and displays a navigation bar at the top of the browser. The following figure 
shows the contents of a Project folder. 

 

Asset Type-Specific Browser 
An Asset Type-Specific Browser displays only the files specific to that asset type. This type of 
browser is identified by the browser type icon and type name at the upper left of the browser. 
There is no navigation bar. The following figure shows a Clips browser. Note the Clips icon  
at the top left of the browser. 

 

​
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Similarities and Differences between the Assets Browser 
Types 
The following table lists the functions and components available to each browser type. 

Function/Component Non-Asset Type-Specific 
Browser 

Asset Type-Specific 
Browser 

Type Icon and Name Yes Yes 

Navigation Bar Limited - See Common 
Folder 

Yes, when Common folder is 
selected 

Import Assets No Yes 

Common Folder Yes, via navigation Yes 

Perform a Quick Search Yes Yes 

Save/Edit Searches Yes Yes 

Advanced Search Yes Yes 

Display Settings Yes Yes 

Navigation within the 
Browser Window 

Yes Yes 

Select a Browser in a Multi-tab Assets Browser 
To select a browser in a multi-tab Assets Browser: 

●​ Click the tab of the browser that you would like to view. The selected browser opens. 

Add an Assets Browser 
By default, the View menu displays the following Assets Browsers, which are available for 
display in the PRIME Switcher UI: 

●​ Scenes Browser, i.e., Scenes tab. 
●​ Clips Browser, i.e., Clips tab. 

It may be desirable to display one or more additional Assets Browsers, such as Images. 
​
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To add an Assets Browser: 

1.​ Go to View > Add Browser. The View menu closes 
2.​ Go to the View menu again. An Assets item is now displayed at the bottom of the 

menu. 
3.​ Select the Asset item to make it visible in the Switcher UI. The View menu closes. The 

Assets Browser displays a new tab, labeled Assets. The Assets Browser displays the 
assets for the currently loaded project. 
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4.​ If desired, double-click to open folders and files displayed within the window, or browse 
lower or higher in the system folder hierarchy: 

To navigate lower in the hierarchy: 

●​ Double-click the desired folder. 

To navigate higher in the hierarchy: 

1.​ Click a folder name in the navigation bar at the top of the Assets Browser, or 
click “..” at the left in the navigation bar. The higher levels in the folder hierarchy 
display. 

 

2.​ Select the desired level. 
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Change to a Different Assets Browser Type 
An Asset-specific Browser displays only assets that are of the specific Asset Type.  

To change the Assets Browser to a different Asset Type: 

●​ Click the Browse icon at the upper left of the Assets Browser. The Assets Browser 
Selection menu appears. 

 

●​ Choose the desired Asset Type. The browser displays the current project’s Asset Type 
folder (e.g., Transitions) ) and only the assets of that Asset Type within the folder. The 
browser name and icon on the tab, and in the View menu, reflect the asset type. 
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Delete an Assets Browser 
To delete an Assets Browser: 

●​ Right-click the tab of the browser that you would like to remove, and then select Close. 
The browser is removed, and no longer appears in the View menu. 

NOTE: When you delete an Assets Browser, only the view of the assets is deleted, not 
the assets themselves. 

Assets Browser Operations 
The Assets Browser provides operations that are the same as within a Windows browser, plus 

Content Distribution, a Chyron application that centrally manages and distributes assets. See 

the Content Distribution User Guide for additional information. 

To access Assets Browser folder operations: 

●​ Right-click one or more folders in the Assets Browser. 
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To access Assets Browser browser-wide operations: 

●​ Right-click the empty space in the Assets Browser. The same menu displays, but with 
different items enabled. 

Depending upon the location of the mouse-click, the following menu functions are available. 

 
Menu Item 

Available When Item Is 
Selected 

Available When Empty 
Space Is Selected 

Content Distribution 
●​ Publish 
●​ Unpublish 

Yes No 

Zip Selected Yes No 

Cut Yes No 

Copy Yes No 

Paste No Yes 

Rename Yes No 

Delete Yes No 

New Folder Yes Yes 

Open File Location Yes Yes 

Refresh Yes Yes 

Properties Yes Yes 
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To access file-specific browse operations: 

●​ Right-click the file. A file-type-specific menu appears. The following figure shows a 
scene-specific context menu. 

 

​
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●​ The following figure shows a clip-specific context menu. 

 

To exit the menu without selecting an item, do one of the following: 

●​ Press ESC. 

●​ Click outside of the menu. 
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Asset Viewer 
The Asset Viewer is available to many of the Asset-Specific Browsers, and displays the lists 
of Missing and Existing assets. This enables you to replace any missing assets prior to going 
on air. Asset-Specific Browser Types are as follows: 

 

​
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To access the Asset Viewer: 

1.​ Right-click the Assets Browser, and then select Asset Viewer. The Asset Viewer 
appears: 

 

2.​ Scroll down to see the Existing assets. 

 

​
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Asset Viewer tools are located along the top of the Asset Viewer. 

●​ Project: Displays the name of the current project. To display the assets for a different 
project: 

○​ Click the dropdown arrow at the right of the Project field, and then select 
project. 

●​ Assets: You can display assets as follows: 
○​ All Assets: Displays all assets in the currently selected project. 
○​ All Scene Assets: Displays the assets for the selected scene. 
○​ Folders: Displays the assets for the folder selected from the dropdown list. 
○​ Individual Assets: Displays the assets for the asset selected from the dropdown 

list. 
●​ Refresh: Click to refresh the Asset Viewer display. 
●​ Zip Assets: You can zip a project’s assets for future use on the same or other systems. 

To zip a project’s assets: 
1.​ Click Zip Assets. The Zip Files dialog appears: 
2.​ Select the files to export, then click Export Selected. 
3.​ Save to the desired location. 

●​ Unzip Assets: Click to unzip a project file, and display the assets in the Asset Viewer.  
●​ Thumbnail Size: Drag the slider to increase/decrease the thumbnail size. 

The bottom of the Asset Viewer displays the number of missing assets and the total number of 
assets for the project. 

The Asset Viewer columns are as follows: 

●​ File: Filepath of the file. 

○​ The Missing icon  appears to the left of any missing asset. The Asset Viewer 
displays the missing asset’s expected filepath. 

○​ If the asset exists, then the asset’s thumbnail appears to the left of the asset’s 
filepath. 

●​ Type: File format. 
●​ Size: File size. Unit is specified in each. 
●​ Modified: Date that the file was last modified. 
●​ Parent: The scene to which the asset belongs. Not every asset has a parent. 
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Common Folder 
The Common Folder contains assets that are accessible to all PRIME applications. For 
example, if a Scene is in the folder, then it may be loaded from the Common folder into the 
Graphics (Scene) Player. 

If the Common folder is selected from within an Asset Type-Specific Browser, then a 
navigation bar appears: 

 

The navigation bar may appear confusing, as the actual typical folder structure is as follows: 

 

​
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For example, for scenes in project “Evening News,” the folder structure is as follows: 

 

When the Common folder appears in the navigation, the folder hierarchy appears to be flipped: 

 

The “\” symbol does not specify hierarchy. It is simply a separator. 

●​ Selecting Scenes opens the Scenes folder for the currently open project, e.g., Projects 
> Evening News > Scenes. 

●​ Selecting Common opens the Common folder, e.g., Projects > Common > Scenes. 
●​ Scenes from other projects are not accessible from this browser. They are accessible 

from the Non Type-Specific Browser. 
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Search Assets Browser 

Overview 
The Assets Browser provides quick search, parameter-specific search and save search 
functions. The following figure shows a Clips Browser. 

 

Perform a Quick Search 
To perform a quick search: 

●​ In the Search field at the top of the browser, type a word from a file name, and then 
press Enter. Any file(s) that contains that word in its filename appears. 

Cancel Search 
To cancel a search and return the browser to display of all assets: 

●​ In the Search field, click the Close icon (x). 

What If the Search Produces No Results? 
If there are no results after performing a search, then the browser displays as empty. 

If search results were expected, then confirm that the search parameters were correctly 
entered. 

Save Search 
To save a search: 

1.​ Click the Search icon. 
2.​ In the dropdown menu, click the Save Search icon. The menu closes, and the search 

can be retrieved for future use. A search can be named. See Edit Search. 
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Retrieve Search 
To retrieve a saved search: 

1.​ Click the Search icon. 
2.​ In the dropdown menu, select the saved search that you would like to use. The menu 

closes, and the results display in the browser. 

Edit Search 
To edit a saved search: 

1.​ Click the Search icon. 
2.​ In the dropdown menu, select Edit saved searches. The <Assets Browser Type> Edit 

Searches dialog appears. For example, if searching a Scenes Browser, then the dialog 
title is Scenes: Edit Searches. 

 

​
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3.​ Click the search item to be edited, then edit as desired. You can rename the item, as 
well. 

 

4.​ When edits are complete, click the Close icon (x). 

Add Search 
To add a search from the Edit Searches dialog: 

1.​ Click the Search icon. 
2.​ In the dropdown menu, select Edit Saved Searches. The <Assets Browser Type> Edit 

Searches dialog appears. For example, if searching a Clips Browser, the then dialog 
title is Clips Edit Searches. 

3.​ Click the Add icon. A new search is added, with the name Untitled Search. 
4.​ If desired, edit the name, and then enter a query. 
5.​ When edits are complete, click the Close (x) icon. 

Remove Saved Search 
To remove a saved search: 

1.​ Click the Search icon. 
2.​ In the dropdown menu, select Edit saved searches. The <Assets Browser Type> Edit 

Searches dialog appears. For example, if searching a Clips Browser, then the dialog 
title is Clips Edit Searches. 

3.​ Click the search item to be removed, and then click the Remove icon. 
4.​ When edits are complete, click the Close icon (x). 
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Clear Search 
To clear a search: 

●​ Click the Close icon to the right of the search string. 

 

Advanced Search 
PRIME Switcher provides a Boolean search tool to more precisely specify search parameters.  

To access Boolean Search: 

1.​ Click the Advanced Search icon. The Advanced Search dialog appears. 
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2.​ Set the desired parameters, and then click Search. The search results display in the 
browser. 

NOTE: The Properties field defaults to the File description. This is not the same as 
the file name. To specify a file name, select Name from the Properties dropdown, a 
Condition from the Conditions dropdown, and then enter a search term in the Value 
field. 

You can save an Advanced Search. See Save Search. 

Assets Browser Display Settings 
You can set the display mode of the assets within the browser in a similar manner as in 
Microsoft Windows. 

To set the display mode for the browser: 

1.​ Click the Display Settings icon. 
2.​ From the dropdown menu, select desired display mode: 

○​ Details: Displays a list of file names with file details. When Details is selected, a 
Columns item displays in the menu, from which you can select column visibility 
for Path, Type, File Size and Last Modified. 

○​ Icons: Displays the file thumbnails or icons. 
○​ List: Displays a list of file names without file details. 
○​ Slider: Sets the size of the thumbnails/icons. 

■​ Slide left to reduce the size of the thumbnails/icons. 
■​ Slide right to increase the size of the thumbnails/icons. 

○​ Appearance: When selected, open the PRIME Settings dialog, accessible from 
Config Menu > Settings, from which you can set color, font style, etc., for the 
PRIME interface. See the PRIME User Guide for details. 

3.​ Once parameters are set, then click Close. 
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Chapter 14: Work with Main and Mix Effect 
(ME) Banks and Transitions 

Overview 
PRIME Switcher displays, by default, a Main Bank, from which you select Program, Preset 
and Key video sources, and perform transitions. 

You can add a Mix Effects (ME1) Bank, from which you can set transition effects, and then 
specify the ME1 Bank as a source in the Main Bank. See Add the ME1 Bank for details on 
how to add the ME1 Bank. 

The ME1 Bank also provides the ability to create Mix Effect Presets, i.e., specific groups of 
settings, that you can save, edit, and recall. See Mix Effect Presets for details. 
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Each bank comprises the following main areas: 

●​ Buses: 
○​ General: The bus, i.e., the row of buttons, from which a video source is 

selected. Each bank has three buses: 
■​ PRESET Bus: Specifies the video source for the Background video to 

transition to Program. 
■​ PROGRAM Bus: Specifies the video source for the Background video 

to be displayed on the PRIME Switcher output. 
■​ Key Bus: 

●​ Specifies the source for the active Key, as indicated by the Key 
Bus label. 

●​ Can change the source of the corresponding Key in the 
Downstream Keyer. 

○​ On the ME1 Bank, you can create, load and trigger ME1 Presets, and save Mix 
Effects Presets for reuse. See Mix Effect Presets. 

●​ Transition Area: 
○​ The controls that determine: 

■​ The Background and/or Key video that transition on and off Program, 
and on and off Preview when a transition is performed. 

■​ The Transition Effect that is applied. 
■​ The active Key(s) in the Key Bus. 
■​ The Key(s) currently in Program. 

○​ Video/Key transitions can be performed from this panel. 
●​ Downstream Keyer: 

○​ The set of controls that determine the source for each Key. 
○​ The type of key for each Key (Linear or Chroma). 
○​ The source of the active Key in the Key bus. 
○​ Key transitions can be performed from this panel. 

The Key Bus, Transition Area and Downstream Keyer interact with each other. It is best to 
understand how each of them work, and then tie together how a change to one affects one or 
both of the others. 
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Main Bank vs. Mix Effect (ME1) Bank 
The Main Switcher Bank and ME1 Bank provide mostly the same functions, with a few 
differences: 

●​ From the ME1 Bank, you can configure, save, edit and recall (load) Mix Effect (ME1) 
Presets. 

○​ The ME1 Bank includes an ID entry field, a Save button, and a Load button. 
○​ There is no ID field, Save button, or Load button in the Main Bank. As such, 

you can configure, but not save or load, a Mix Effect in the Main Bank. 

●​ A Mix Effect from the ME1 Bank can act as a source for the Main Bank Preset, 
Program or Key, but not vice versa. If the ME1 Bank is configured in the PRIME 
Switcher interface, then an ME1 button appears in each of the three Main Bank Buses: 
Preset, Program, Key. 

●​ The ME1 Bank does not transition directly to Program. Rather, it transitions from its 
own Preview to its own ME1 output, which is not the PRIME Switcher Program output. 
The ME1 Program displays on the ME1 monitor. 

○​ If the Main Bank Program video source is set to ME1, then any transitions 
performed from the ME1 Bank are routed to the Main Bank Program bus. 

○​ If the Main Bank Preset video source is set to ME1, then the Main Bank Preset 
must be transitioned to Program, in order for ME1 Program contents to display 
as the PRIME Switcher output. 

 

Mix Effect Bank vs. Mix Effect (ME1) Preset 
PRIME Switcher provides one Mix Effect Bank (ME1); however, you can create multiple Mix 
Effect Presets that you can save, edit, and recall from the Mix Effect Bank. A Mix Effect 
Preset loaded in the Mix Effect Bank can act as a source to the Main Bank. See Mix Effect 
Presets for details. 
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Set Preset, Program, Key Buses 

 

You can set a Preset source and a Program source in each of the banks. 

●​ When you trigger a transition in the Main Bank, the contents of Preview transition to 
Program. 

●​ When you trigger a transition in the ME1 Bank, the contents of Mix Effects Preview 
transitions to the Mix Effects Output. 

○​ PRIME Switcher provides a monitor (labeled ME1) dedicated to the ME1 Bank, 
which displays the contents of the ME1 Output. The Cut and Auto buttons act 
as toggles to view both the ME1 Preview and ME1 Output. 

■​ To view the contents of the ME1 Preview, click Cut or Auto in the 
Transition Area. 

■​ To again view the contents of the ME1 Output, click Cut or Auto in the 
Transition Area. 

○​ To display the Mix Effect Output in PRIME Switcher Program, you must select 
ME1 as the Main Bank Program source. 

To set a bank: 

●​ In the Preset bus, select the desired source. 
●​ In the Program bus, select the desired source. 
●​ Key Bus: The Key Bus is actually four Key Buses: KEY1, KEY2, KEY3, KEY4. You can 

select the Key Bus that you would like to display, and select the Key Type: LINEAR or 
CHROMA. For each KEY on each Bank, you can also select and configure a DVE. 

○​ If the button is red, then the source is part of the Program mix. 
○​ If the button is white, then the source is part of the Preview mix. 
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To select a Key Bus: 

●​ In the top row of the bank, click the Key Bus that you would like to display. The 
selected Key button becomes lit, and the Key Bus displays the name of the 
selected Key at the left of the Bus. The following shows KEY1 selected. 

 

To select a Key type, do one of the following: 

●​ Click the Linear or Chroma button. The selected Key Type button becomes lit, 
and the Key Bus displays the name of the selected Key Type at the left of the 
Bus. The following shows LINEAR selected. 

 

​
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If you change the source on the Key Bus, then the change is reflected in the source for 
that Key in the Downstream Keyer. 

If you change the Key Source in the Key Bus, then the change is reflected in the Key 
Mode in the Downstream Keyer. For example, if you change the KEY3 source from 
GFX1 to CLP2, then KEY3 in the Downstream Keyer changes to CLP2. 

Transitions 
A transition is a visual effect that is applied when Preview transitions to Program. A transition 
can be simple, such as a Cut, Wipe or Dissolve, or a more complex effect created within 
PRIME and performed by the PRIME Switcher. 

PRIME Switcher is an A-B switcher, i.e., when a transition is performed, the contents of 
Program and Preview swap: 

1.​ The Program monitor displays the source selected in the Program Bus (also referred to 
as Background), plus any Key source(s). 

2.​ The source selected in the Preset Bus, plus any Key source(s), are next in line to 
transition to Program. 

3.​ When you perform a transition, the contents of the Program Bus and Preset Bus 
swap. The active (selected) Transition Effect is applied as the contents swap. The 
following figure shows a Wipe transition, as Preview video replaces Program video. 

 

NOTE: You may not want all elements in Preview to swap with all elements in 
Program. You can control which elements (BKGD, KEY1, KEY2, KEY3, KEY4) 
swap via the Next Transition Selection settings in the Transition Area. 

​
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You can trigger Background video, Background and Key, or Key transitions from the 
following PRIME Switcher areas: 

●​ From the Main Bank Program bus: Transitions only the Background video using a 
Cut. 

●​ From the Transition Area: Transitions Background video and Key using a Cut or the 
selected Transition Effect. 

●​ From the Downstream Keyer: Transitions the selected Key only using a Cut or the 
Transition Effect selected in the Transition Area. 

If you perform a transition from the ME1 Bank, and the ME1 Bank is selected as a Main Bank 
Program source, then the transition in the ME1 Bank displays in Program. 

You can select and perform a transition from the Transition Area (outlined in red on the left) 
and Downstream Keyer (outlined in red on the right): 

●​ From the Transition Area, you can select the specific Transition Effect, and perform 
either that transition (AUTO) or a CUT. 

●​ From the Downstream Keyer, you can perform either the transition set in the 
Transition Area (AUTO) or a CUT. 
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What Can Transition? 
In addition to a video source such as a camera or clip, key sources such as a Lower 3rd, OTS 
and/or Live Bug can overlay the video source, and independently transition to and from 
Program. The following figure shows a Lower 3rd graphic, an OTS graphic and a Live Bug. 

 

Even if a Video Source is selected in Preview to transition to Program, it may be desirable to 
take new graphics to Program, while leaving the Background Video in the Program Channel 
in Program, or to leave one Key in Program while transitioning a different key off Program. 
The following figures show a Lower 3rd graphic added to an OTS graphic. The BKGD does not 
change. 

➔ 

 

​
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What is a Key? 
A Key is video that “cuts a hole” in other video. Keying is used to overlay graphics and/or clips 
over Background video. An area of a Key can have full opacity or varying levels of 
transparency: 

●​ If an area of a Key is completely opaque, then the video that it overlays is not visible. In 
the following figure, the Live Bug is completely opaque. None of the underlying video is 
visible. 

●​ If an area of a Key is transparent, then both the Key and the video that it overlays are 
visible. In the following figure, the Lower 3rd and the OTS have opaque and transparent 
areas. The underlying video is visible in the transparent areas. 

PRIME Switcher provides two Key Modes: 

●​ Linear Key: The graphics are keyed into the video. Linear Key is typically used to 
overlay graphics over video. 

●​ Chroma Key: Composites video based on a specified Key Color, also known as a 
Target Color. The specified chrominance (Target Color) is removed, and is replaced by 
other video. Chroma Key is commonly used for weather reports and virtual sets. The 
meteorologists/anchors present in front of a green screen, and the weather or virtual set 
graphics are keyed in any area that is the color specified as the Key Color. 

 

Each PRIME Switcher Bank provides four Key Presets. Key transparency is set in the graphic 
itself, and not in the PRIME Switcher. 

You can set each Key Preset to any available source. Linear Keys are most commonly used to 
display Lower 3rd, Over-the-Shoulder (OTS) and Live Bug graphics over video, or to display 
a partially transparent clip that plays over Background video. Chroma Keys are commonly 
used to display virtual sets and weather maps. 
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Set Transition Area 

Overview 
The Transition Area provides the ability to: 

●​ Specify, via the Next Transition Selection buttons, which sources (BKGD, KEY1, 
KEY2, KEY3, KEY4) display, and how they transition to Program. 

●​ Specify the Transition Effect that is applied to a transition. 
●​ Perform CUT transitions 
●​ Perform other transitions using preset durations (AUTO TRANS, PRESET BLACK), or 

manually, using the Fader Bar. 
●​ Monitor which Keyer(s) is active/inactive. 
●​ The ME1 Bank provides the ability to save and load Mix Effects for reuse. 

 

Next Transition Selection 
Overview 
In each bank, you can independently specify the elements (Background (BKGD), KEY1, KEY2, 
KEY3, KEY4) that will transition when you trigger a transition effect (CUT, AUTO, PRESET 
BLACK). 

●​ A button that is lit indicates that the element will transition when you trigger a transition 
effect. As such: 

○​ If the element is in Program, then when a transition is triggered, it transitions off 
Program. 
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○​ If the element is in Preview, then when a transition is triggered, it transitions to 
Program. 

●​ A button that is unlit indicates that the element will not transition when you trigger a 
transition. 

○​ If the element is in Program, then when a transition is triggered, it remains in 
Program. 

○​ If the element is in Preview, then when a transition is triggered, it remains in 
Preview. 

For example, the following figure shows BKGD, KEY1 and KEY2 specified for transition. The lit 
Active Keyer Indicator alerts that KEY1 is active in the output for that Bank. 

●​ If active in the Main Bank, then active on the PRIME Switcher Program output. 
●​ If active in the ME1 Bank, then active on the ME1 output. 

 

When a transition is triggered, then: 

●​ The BKGD video, KEY1 and KEY2 transition. 
●​ KEY3 and KEY4 do not transition. 

​
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Each button in the ON AIR row and the Source column in the Downstream Keyer display the 
Source Name for each KEY. In addition, ON AIR row and the small “LED” lights on the Next 
Transition Selection KEY Buttons both indicate the status of the KEYS: 

●​ In the Main Bank: 

○​ In the ON AIR row and Downstream Keyer, if the KEY’s Source Name is lit 
red, then the KEY is in Program. The KEY’s Next Transition Selection KEY 
Button “LED” is also lit red.  

○​ In the ON AIR row and Downstream Keyer, if the KEY’s Source Name is 
green, then the KEY is not in Program. The KEY’s Next Transition Selection 
KEY Button “LED” is unlit. 

●​ In the ME1 Bank: 

○​ In the ON AIR row and Downstream Keyer, if the KEY’s Source Name is lit 
red, then the KEY is in ME1’s output, and displays on the ME1 monitor. The 
KEY’s “LED” is also lit red.  

○​ In the ON AIR row and Downstream Keyer, if the KEY’s Source Name is 
green, then the KEY is not in ME1’s output. The KEY’s “LED” is unlit. 

To turn a Next Transition Selection button ON or OFF: 

●​ Click the Next Transition Selection button. 

Background (BKGD) 
Turning ON the BKGD Next Transition Selection button specifies that when a transition is 
performed, the BKGD transitions: 

●​ If the BKGD button is turned ON, then when the transition is performed, the Preview 
video transitions to Program, and the Program video transitions to Preview, i.e., they 
are swapped. 

●​ If the BKGD button is turned OFF, then: 

○​ The Program Background Video remains in Program, and replaces the 
Preview Background Video. Note that turning the BKGD OFF does not change 
the video source setting in the Preset bus. 

○​ When you perform the transition, the video source currently in Program remains 
in Program. 
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KEY 1 - 4 (KEY1, KEY2, KEY3, KEY4) 
Turning a KEY Next Transition Selection button ON specifies that when a transition is 
performed, the selected Key transitions. 

To describe the operation of a KEY Next Transition Selection button, KEY1 is used in the 
following, and the KEY1 source is GFX1. 

●​ If the KEY1 Next Transition Selection button is ON, then when the transition is 
performed, the KEY1 (GFX1) transitions as follows: 

○​ If the KEY1 (GFX1) displays in Program, then KEY1 (GFX1) transitions to 
Preview. 

○​ If the KEY1 (GFX1) displays in Preview, then Key1 (GFX1) transitions to 
Program. 

●​ If the KEY1 Next Transition Selection button is OFF, then when the transition is 
performed, KEY1 (GFX1) does not transition, i.e.: 

○​ If the KEY1 graphic displays in Program, then it remains in Program; and, 
○​ The KEY1 graphic also displays in Preview. 

●​ If the KEY1 Next Transition Selection button is turned OFF while the KEY1 graphic 
displays in Preview, then the KEY1 graphic is removed from Preview. When the 
transition is performed, then there is no graphic to transition to Program. 

​
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Transitions 
PRIME Switcher provides the following Transition Types: 

●​ Cut is always available in the PRIME Switcher interface 
●​ Built-in: Dissolve and Wipe are built-in custom transitions that are configurable within 

PRIME Switcher. 
●​ Custom: You can create custom transitions using PRIME Designer and save as *.pst or 

*.pct files for use in PRIME Switcher. 
●​ Preset Black: Transitions the contents of Program to black, and then transitions the 

contents of Preview to Program, applying the active transition. For example: 

○​ If Dissolve is the active transition, then Program dissolves to Black, and then 
dissolves to the contents that were transitioned from Preview. On a hardware 
switcher, this corresponds with fade to Black and fade up from Black. This is 
the most typical use of Preset Black. 

○​ If Wipe is the active transition, then Program wipes to Black, and then wipes to 
the contents that were transitioned from Preview..  

The PRIME Switcher UI can provide up to five built-in and/or custom Transition Effects at any 
time. To configure the Transition Effects, see Configure Transitions. The following figure shows 
DISS as the active transition. 

 

When you select a transition, it becomes active, i.e., when you click AUTO or PRESET 
BLACK, or you use the Fader Bar, then PRIME Switcher performs the active transition. To 
select a transition: 

●​ Click the Transition Effect button. Note that the transition is not performed when it is 
selected. Transitions are performed from the Perform Transition row of buttons below 
this row or using the Fader Bar. 
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Perform Transition 
Overview 
Video and graphics transitions are performed from the buttons in the bottom row of the 
Transition Area and using the Fader Bar.  

Each button has a different function: 

●​ CUT: Performs a Cut, swapping the contents of Preview with the contents of Program. 
●​ AUTO TRANS: Performs the active transition, i.e., the transition that you selected in the 

Select Transition row. See Transitions. 
●​ PRESET BLACK: Transitions the contents of Program to black, and then transitions the 

contents of Preview to Program, applying the active transition. 

 

You can also perform the selected Active Transition by clicking and dragging the Fader Bar 
up or down. When you use the Fader Bar, you can control the speed of the transitions.  

Note also that when you click the AUTO TRANS or PRESET BLACK button to perform a 
transition, then: 

●​ If the Fader Bar is at the bottom position, then it moves to the top. 
●​ If the Fader Bar is at the top position, then it moves to the bottom. 

Perform CUT 
To perform a Cut from the Transition Area: 

●​ Click CUT. 
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Perform Transition 
To perform a built-in or custom transition: 

1.​ If not already selected, then click the desired Transition Effect, to make it active. 
2.​ Click AUTO or use the Fader Bar. 

Note that to continue using the selected (active) transition, it is not necessary to click it each 
time that you would like to use it. Simply click AUTO or use the Fader Bar to perform the 
transition. 

Perform Transition to Black then to Program 
To perform a transition to Black and then to Program: 

1.​ If not already selected, then click the desired Transition Effect, to make it active. 
2.​ Click PRESET BLACK. 

​
 

246 | PRIME 5.3 Switcher User Guide​
​
 



Set a Key Source 
There are two methods to assign source video to a Key: 

From the Downstream Keyer: 

1.​ Right-click the Key Source button for the specific Key (KEY1, KEY2, KEY3, KEY4) in 
the specific bank (MAIN, ME1). 

2.​ From the context menu, select a Key Source. This example displays the sources for 
KEY2. The active source has a checkmark to the left. 

 

3.​ Click the desired source. The menu closes. The Source Button displays the updated 
source. 

From the Key Bus: 

1.​ In the top row of the Bank in which you are working, above the buses, select the Key 
Bus. In the following, KEY3 is selected. 

 

2.​ In the Key Bus, click the desired source. 
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The Source column in the Downstream Keyer and each button in the ON AIR row display the 
Source Name for each KEY. In addition, the small “LED” lights on the Next Transition 
Selection KEY Buttons both indicate the status of the KEYS: 

●​ In the Main Bank: 

○​ In the Downstream Keyer and the ON AIR row, if the KEY’s Source Name is lit 
red, then the KEY is in Program. The KEY’s Next Transition Selection KEY 
Button “LED” is also lit red.  

○​ In the Downstream Keyer and the ON AIR row, if the KEY’s Source Name is 
green, then the KEY is not in Program. The KEY’s Next Transition Selection 
KEY Button “LED” is unlit. 

●​ In the ME1 Bank: 

○​ In the Downstream Keyer and the ON AIR row, if the KEY’s Source Name is lit 
red, then the KEY is in ME1’s output, and displays on the ME1 monitor. The 
KEY’s “LED” is also lit red.  

○​ In the Downstream Keyer and the ON AIR row, if the KEY’s Source Name is 
green, then the KEY is not in ME1’s output. The KEY’s “LED” is unlit. 
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Downstream Keyer 

Overview 
Each Bank has a dedicated Downstream Keyer that provides four Downstream 
Keyers—KEY1, KEY2, KEY3 and KEY4—each of which you can set as Linear Key or 
Chroma Key. 

Key layer priority is as follows: 

●​ KEY1 has the highest priority and displays on top of KEY2, KEY3, KEY4, and BKGD. 
●​ KEY2 displays behind KEY1, and on top of KEY3, KEY4, and BKGD. 
●​ KEY3 displays behind KEY1 and KEY2, and on top of KEY4 and BKGD. 
●​ KEY4 displays behind KEY 1, KEY2, and KEY3, and on top of BKGD. 
●​ All KEYS display on top of BKGD. 

 

A Downstream Keyer has the following functions: 

●​ Specifies the type of Key: Linear Key or Chroma Key. 
●​ Specifies source for each Downstream Keyer. 
●​ Transitions a selected Key. When a Downstream Keyer Source Button is red, then the 

Key Source is in Program. 
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Set Key Mode 
Key Mode Overview 
Each Keyer can act as either a Linear Keyer or a Chroma Keyer. By Default, the Keyers are 
Linear. 

●​ Linear: Composites one or more video layers. 
●​ Chroma: Composites video based on a specified Key Color, also known as a Target 

Color. The specified chrominance (Target Color) is removed, and is replaced by other 
video.  

You can use a mix of Linear and Chroma Keys. The following shows a virtual set keyed in via 
Chroma Key with a graphics overlay keyed in via Linear Key: 

 

Linear/Chroma Key settings are included when saving a Mix Effect Preset.  

Set Linear Key 
To specify a Keyer as Linear: 

1.​ In the Downstream Keyer, click the Key Mode label, located underneath the Keyer 
number. 

2.​ From the dropdown, select Linear. 
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Set Chroma Key 
To specify a Keyer as Chroma: 

1.​ In the top row of the Bank in which you are working, above the buses, select the KEY 
to set to CHROMA, and select CHROMA. In the following, KEY3 is selected. 

 

The Chroma Key settings display. 

 

2.​ Set the following parameters. As you adjust parameters, the adjustments reflect in the 
PRIME Switcher display. 

●​ Color Indicator: Displays the color that is the current Key Color, also referred 
to as the Target Color. You can set Key Color using one or more of the 
following methods: 

○​ Color Picker Standard Settings 
○​ Color Picker Advanced Settings 
○​ Eyedropper 

See Set Key Color via Color Picker Standard Settings, Set Key Color via Color 
Picker Advanced Settings, and Set Key Color via Eyedropper for details. 
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●​ Gain: The hue threshold for the Target Color. 

○​ Increasing this value makes colors similar to the Target Color also 
transparent. 

○​ Decreasing this value makes colors similar to the Target Color less 
transparent. 

●​ Softness: Sets pixels within the gain threshold to semi-transparent. 

●​ Shape: Linear to non-linear softness value adjustments. 

●​ Despill: Removes some of the key color from the remaining pixels, correcting for 
spillage of the Key Color. 

●​ Matte: Displays the alpha values as grayscale. If desired, then enable Matte to 
fine-tune the key, and then disable Matte when fine-tuning is complete. 

3.​ Click outside of the Chroma Key settings. The Chroma Key settings close. 

Set Key Color via Color Picker Standard Settings 
You can set Key Color via the Color Picker Standard Settings, in which you select a 
pre-existing color to act as the Key Color. 

To use the Color Picker Standard Settings to set Key Color: 

1.​ In the Downstream Keyer, click the Key Mode label, located underneath the Keyer 
number. 

2.​ From the dropdown, select Chroma. The Chroma Key settings display. 

3.​ Click the Color Indicator. 

​
 

252 | PRIME 5.3 Switcher User Guide​
​
 



4.​ If not already displayed, then click the Standard tab. The Standard Color Palette 
appears. 

 

5.​ Click a color chip from either the Available Colors or Standard Colors. As you select a 
color, PRIME Switcher reflects the selection in real time. 

6.​ Do one of the following: 

●​ Click outside of the Standard Color Palette, but on the Chroma Key settings 
dialog to return to the Chroma Key settings. 

●​ Click outside of both the Standard Color Palette and the Chroma Key settings 
dialog to return to PRIME Switcher. 

Set Key Color via Color Picker Advanced Settings 
You can set Key Color via the Color Picker Advanced Settings, in which you precisely set a 
color and alpha to act as the Key Color. 

To use the Color Picker Standard Settings to set Key Color: 

1.​ In the Downstream Keyer, click the Key Mode label, located underneath the Keyer 
number. 

2.​ From the dropdown, select Chroma. The Chroma Key settings display. 
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3.​ Click the Color Indicator. 
4.​ If not already displayed, then click the Advanced tab. The Advanced Color Palette 

appears. 

 

5.​ Set a Key Color and Key Alpha using one or more of the following methods: 

●​ In the Color Canvas, drag the cursor to the desired location. 

●​ In the Color Slider, drag the slider to the desired location. 

●​ Set the HTML or RGBA parameters. Note that in the HTML setting: 

○​ Digits 1 and 2 of the HTML specify A (Alpha). 
○​ Digits 3 and 4 of the HTML specify R (Red). 
○​ Digits 5 and 6 of the HTML specify G (Green). 
○​ Digits 7 and 8 of the HTML specify B (Blue). 

As you adjust the settings, PRIME Switcher reflects the changes in real time. 

6.​ Do one of the following: 

●​ Click outside of the Advanced Color Palette, but on the Chroma Key settings 
dialog to return to the Chroma Key settings. 
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●​ Click outside of both the Advanced Color Palette and the Chroma Key 
settings dialog to return to PRIME Switcher. 

Set Key Color via Eyedropper 
The Eyedropper operates much like the eyedropper in many graphics applications, and 
enables you to quickly clone a Key Color from the PRIME Switcher interface, or even from a 
different application on your desktop. 

To use the Eyedropper to set Key Color: 

1.​ In the Downstream Keyer, click the Key Mode label, located underneath the Keyer 
number. 

2.​ From the dropdown, select Chroma. The Chroma Key settings display. 

3.​ Click the Eyedropper icon, located to the right of the Color Indicator. 

 

The Eyedropper cursor appears. 

 

​
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4.​ Drag the Eyedropper cursor to the location from which you would like to clone the 
color, and then click. You can select from within the PRIME Switcher interface, or from 
any other open application, window, or the desktop. The color appears in the Color 
indicator, and now acts as the Chroma Key color. 

5.​ If desired, then adjust the Gain, Softness, Shape, and Despill settings. If desired, then 
enable Matte to fine-tune the key, and then disable Matte when fine-tuning is 
complete. 

Perform a Key Transition 
An individual Key can transition, independent of the background (BKGD) and other Key video. 

To perform a Cut transition: 

●​ Click CUT for the specific Key. 

To perform the currently active built-in or Custom transition that is active in the Transition 
Area: 

●​ Click AUTO for the specific Key. 
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PRIME Switcher DVE (Digital Video Effect) 
PRIME Switcher DVE Overview 
PRIME Switcher can apply DVE crop and border to the Key in any Key Bus in the Main and 
ME1 Banks. You can set a DVE independently for each Key Bus in each Bank. The following 
shows ME1 Bank DVEs set for KEY1, KEY2, KEY3 and KEY4. You can save DVE setups as 
Mix Effect Presets. 

 

​
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To access the DVE settings for a Bus: 

1.​ In the top row of the Main or ME1 Bank, select the Key to which to apply the DVE. 

2.​ In the top row of the same Bank, click the DVE button to make it active, and then 
right-click the DVE button. The DVE dialog displays. 

 

The DVE dialog comprises the following areas: 

●​ Enable/Disable DVE 
●​ Position 
●​ Size 

●​ Crop 
●​ Border 

In order to view the DVE as you edit: 

●​ If working in the Main Bank, ensure that the Key to which the DVE is applied is 
displayed in Program. 

●​ If working in the ME1 Bank, ensure that the Key to which the DVE is applied is 
displayed in the ME1 Bank monitor. 

Changes to settings are immediately applied, and are reflected in PRIME Switcher. 

In addition to DVEs created within PRIME Switcher, you can display complex DVE scenes 
created in PRIME Scene Designer. See Create a PRIME DVE Scene. 
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Reset Settings to Default 
While you are working, you may want to reset a setting to the default value. To perform a reset: 

●​ Click the label of the setting that you would like to reset. The value resets to the default. 

When there are two settings for a category, such as Position, which has X and Y components, 
you can reset an individual component by clicking the X label or the Y label, or reset both 
components, by clicking the Position label. 

Enable/Disable DVE 
The state of the DVE button indicates whether or not the DVE is active, i.e., enabled. 

●​ If the DVE button is lit, then the DVE is enabled. 

●​ If the DVE button is not lit, then the DVE is disabled. 

You can enable/disable the DVE from directly from the PRIME Switcher Bank or from within the 
DVE dialog: 

●​ From the PRIME Switcher Bank, click the DVE button to toggle it between enabled and 
disabled. 

●​ From the DVE dialog, click the Enabled checkbox to enable/disable the DVE. 

Note that you can set up the DVE, disable it, and then click the DVE button at any time during 
a broadcast to apply the DVE. 
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Set DVE Position 
The origin point (0,0) of the x, y parameters of the DVE is at the lower left of the screen. 

The (x,y) parameters specify the center point of the DVE Position. For example, in a 1920 x 
1080 format, (960, 540) specifies that the center point of the DVE is at the horizontal and 
vertical center of the screen. The following shows four DVEs and their center points, sizes and 
crop settings. 

 

Note that in the above image, the KEY sources are resized from full screen; however, they are 
not cropped. As such, there is no need to change the Crop settings from the default values. 

​
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Following are the DVE settings for each of the KEYs. 

KEY1

 

KEY2 

 

KEY3 

 

KEY4 

 

Set DVE Size 
Changing the size of the DVE changes the size of the contents of the entire selected KEY. 

To set the Width and Height of the DVE: 

●​ Enter the Width and Height settings or use the spin boxes. 

You can lock the Aspect Ratio, so that when you adjust the Width and/or Height, the Aspect 
Ratio is preserved. Default setting is Locked. To lock/unlock the Aspect Ratio: 

●​ Click the Aspect Ratio Lock icon to toggle between Locked  or Unlocked . 
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Set Crop 
Crop is applied to the currently selected Key. The Left, Top, Right, and Bottom settings are 
measured using the center point of the DVE. The crop settings are in relation to the center point 
of the DVE. The Crop settings are not based on the Position of the DVE, only the Size, even if 
the DVE is resized or repositioned. As with the Size, the (0,0) point is at the center of the DVE. 

The following shows a DVE OTS that is not cropped. 

 

The DVE Size is 879 x 494. The Crop settings are the default Crop settings, fall outside of the 
borders of the DVE, and therefore, do not affect the DVE. 
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The following shows a DVE with a cropped and repositioned OTS: 

 

Note the comparison between the Size and the Crop settings. The Size is still 879 x 494, but 
as shown by the following settings, it has been cropped on all sides. 

 

To set the the DVE Crop parameters: 

●​ Enter the Left, Top, Right, and Bottom settings, or use the spin boxes. 

​
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NOTE: Be aware that even though the KEYS in the previous example all display when 
the DVEs are enabled, they are still layered. KEY1 is the top layer, followed by KEY2, 
KEY3, and then KEY4 as the bottom layer. As such: 

●​ If you disable the DVE associated with KEY1, then the KEY1 Source displays full 
screen, covering the KEY2, KEY3, and KEY4 DVEs. 

●​ If you disable the DVE associated with KEY2, then: 

○​ The KEY1 DVE displays. 

○​ The KEY2 Source displays full screen, under the KEY1 DVE, and covering 
the KEY3 and KEY4 DVEs. 

●​ If you disable the DVE associated with KEY3, then: 

○​ The KEY1 and KEY2 DVEs display. 

○​ The KEY3 Source displays full screen, under the KEY1 and KEY2 DVEs, 
and covering the KEY4 DVE. 

●​ If you disable the DVE associated with KEY4, then: 

○​ The KEY1, KEY2, and KEY3 DVEs display. 

○​ The KEY4 Source displays full screen under the other KEYS. 

If, however, you deactivate a KEY, then the remaining KEYS continue to display. 
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Set Border 
The DVE can have a border for which you can set the width and the color. 

To enable/disable the visibility of the Border: 

●​ Check the Enabled checkbox to enable the visibility of the Border, or uncheck the 
enabled checkbox to disable the visibility of the Border. 

You can set the Border parameters and then disable visibility until you need to display it. 

To set Border Thickness: 

●​ Enter the setting, or use the spin box. The Size of the area surrounded by the Border 
stays the same. The border extends out from the specified Size of the DVE. 

For example, if the DVE Width = 500, DVE Height = 400, and Border Thickness = 20, 
then: 

○​  DVE Width plus Border Thickness (left + right) = 540 

○​ DVE Height plus Border Thickness (top + bottom)= 440. 

 To set Border Color: 

●​ Click the Color dropdown arrow, and then use the Color Picker to set the color. The 
Color Picker and Advanced Color Picker settings operate in the same manner as 
those used for setting Chroma Key. See Set Key Color via Color Picker Standard 
Settings and Set Key Color via Color Picker Advanced Settings. 

Exit and Apply DVE Settings 
To exit the DVE dialog and apply the settings: 

●​ Click outside of the DVE dialog. The dialog closes. As the settings were applied as you 
edited them, they are retained upon exiting the DVE dialog. 

Remember that you can retain the settings, disable the DVE, and then enable the DVE as 
needed. 
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DVE Exercise 
You can incorporate DVEs to create complex, eye-catching effects, such as transitioning DVEs 
into Program as an anchor promos each story. 

 

​
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 The basic steps are as follows: 

1.​ In the ME1 Bank, set up four DVEs, so that each occupies a quadrant of the screen. 
Ensure that each DVE is cropped to the size of its DVE. Set each DVE to display video 
corresponding to the anchor script. 

2.​ In the ME1 Bank, set a clip as the ME1 Program source. 

3.​ Save as a Mix Effect Preset. 

4.​ Load the Mix Effect Preset. It loads into the ME1 Bank. 

5.​ In the Downstream Keyer, set all DVEs to OFF AIR. Their buttons should display 
green. 

6.​ Set the Main Bank Preset Source to ME1. 

7.​ In the Main Bank, perform a transition. 

8.​ As the anchor introduces each story, click the corresponding CUT or AUTO KEY in the 
Downstream Keyer. As you click each KEY’s CUT or AUTO KEY, the DVE associated 
with that KEY transitions into Program. 

​
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Tying Together the Transition Area, Key Bus and Downstream 
Keyer 

Overview 
The Transition Area, Key Bus and Downstream Keyer interact with each other. For example, 
when you make a change to the Key Bus, it affects the Downstream Keyer. When you 
activate or deactivate a Transition Area button, it can affect both the Key Bus and the 
Downstream Keyer. 

What Happens When You Activate (Select) a Key Source? 
If you click a KEY button in the Transition Area to make it active, then: 

●​ The most recent KEY button that was made active in the Transition Area causes the 
following to occur: 

○​ The Key Bus Label changes to match the Key number of the most recent KEY 
button that was made active in the Transition Area. 

○​ Any change to the Key Bus source is reflected in its corresponding 
Downstream Keyer source. 

For example, if you activate KEY2 in the Transition Area, then: 

●​ The Key Bus Label changes to KEY2. 

●​ Any change to the selected source in the Key Bus is reflected in KEY2 of the 
Downstream Keyer. For example, if you set the Key Bus to CLP1, then KEY2 in the 
Downstream Keyer changes to CLP1. 

This behavior holds, even if other KEY buttons are active in the Transition Area. 

If no KEY buttons are active in the Transition Area and then you click a source button, (e.g. 
CAM2), in the KEY bus, then: 

●​ The same source (CAM2) is reflected in the Downstream Keyer KEY number of the 
KEY specified in the Key Bus Label. 

●​ The Key Bus Label is determined by the KEY number of the last active KEY button in 
the Transition Area. You can change the Key Bus Label From the Key Bus dropdown 
See Set Preset, Program, Key Buses. 
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What Happens When You Deactivate (Deselect) a Key Source? 
If you click a KEY button in the Transition Area to make it inactive, then the lowest-priority 
active KEY determines which Downstream Keyer source reflects a change in the Key Bus 
source. 

Key layer priority is as follows: 

●​ KEY1 has the highest priority and displays on top of KEY2, KEY3, KEY4, and BKGD. 
●​ KEY2 displays behind KEY1, and on top of KEY3, KEY4, and BKGD. 
●​ KEY3 displays behind KEY1 and KEY2, and on top of KEY4 and BKGD. 
●​ KEY4 displays behind KEY 1, KEY2, and KEY3, and on top of BKGD. 
●​ All KEYS display on top of BKGD. 

For example: 

●​ If KEY2 and KEY4 are active, then a change in the Key Bus source is reflected in KEY2 
of the Downstream Keyer. 

●​ If KEY1, KEY3 and KEY4 are active, then a change in the Key Bus source is reflected 
in KEY1 of the Downstream Keyer. 

What Happens When You Change a Key Bus or Downstream Keyer 
Source? 
You can change the source of any Key Bus or of any KEY button in the Downstream Keyer. 

●​ If you change the source of the currently selected Key Bus, as indicated by the Key 
Bus Label, then the change is reflected in the corresponding Downstream Keyer KEY 
button. 

●​ If you change the source of a Downstream Keyer KEY button, then the change is 
reflected in the corresponding Key Bus 

For example: 

●​ If you change the KEY2 Bus source from CAM6 to CAM7, then the change is reflected 
in the Downstream Keyer KEY3 button. 

●​ If you change the KEY3 source in the Downstream Keyer from GFX1 to CLP1, then 
the change is reflected in the KEY3 Bus. 
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Set up Graphics 1 on Program, and Graphics 2 on Preview 
You may like to set up Graphics 1 and Graphics 2 so that when Graphics 1 displays on 
Program, then Graphics 2 displays on Preview, and vice versa. These instructions assume 
that the KEY1 source is Graphics 1, and the KEY2 source is Graphics 2. See Downstream 
Keyer for instructions on how to assign a Key source. 

To do so: 

1.​ In the Transition Area, click KEY1, so that it is active (lit). 

2.​ Load a graphic into Graphics 1. 

3.​ Depending upon the state of the switcher, Graphics 1 appears on either Program or 
Preview. 

●​ If Graphics 1 displays in the Program monitor, then proceed to step 4. 

●​ If Graphics 1 displays in the Preview monitor, then in the Transition Area, click 
CUT, AUTO or PRESET BLACK to perform a transition. Graphics 1 should then 
display in Program. 

4.​ In the Transition Area, click KEY2 so that it is active (lit). 

5.​ Load a graphic into Graphics 2. Graphics 2 should display in the Preview monitor. 

6.​ In the Transition Area, click CUT, AUTO or PRESET BLACK to perform a transition. 
Graphics 1 swaps to Preview, and Graphics 2 swaps to Program. Each time that you 
perform a subsequent transition, the contents of Graphics 1 and Graphics 2 swap 
monitors. 

Mix Effect Presets 

Mix Effect Overview 
You can create, save and recall Program/Preview/Key/Transition settings on the ME1 Bank 
as Mix Effect Presets. The Mix Effect Preset outputs on ME1 Bank Program, which the 
Main Bank can then use as a source, enabling the creation of more complex mixes. 

The output of the ME1 Bank displays in its own monitor. As such, you can perform and adjust 
Mix Effect Preset settings without affecting Program output, as long as the ME1 Bank is not 
the selected Program source for the Main Bank. 

​
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Mix Effect Operations 

Mix Effect Preset Operations from the Keypad 
The Keypad provides the following Mix Effect Preset operations: 

●​ ID Entry: Numeric keypad to enter Mix Effect Preset ID numbers in the Recall Box. 

●​ LOAD: Applies the Mix Effect Preset whose ID is displayed in the Recall Box, and 
advances the Mix Effect Preset ID in the Recall Box to the next available Mix Effect 
Preset ID. 

●​ SAVE: Saves the Mix Effect Preset to the ID displayed in the Recall Box. 

●​ PLAY: Applies the Mix Effect Preset whose ID is displayed in the Recall Box. Does not 
advance the Mix Effect Preset ID in the Recall Box to the next available Mix Effect 
Preset ID. 

●​ PREV: In the Recall Box, displays the Mix Effect Preset ID of the previous available 
Mix Effect Preset. 

●​ NEXT: In the Recall Box, displays the Mix Effect Preset ID of the next available Mix 
Effect Preset. 

●​ CLEAR: Not applicable to Mix Effects. As such, the button is grayed out. 

●​ DEL: Clears the Mix Effect Preset ID from the Recall Area Recall Box. 

Mix Effect Preset Operations from the Recall Area/Recall Box 
The Recall Area/Recall Box provides the following operations: 

●​ ID Entry: Enter Mix Effect Preset ID. The ID can be numeric or alphanumeric. 

●​ Press Enter: Applies (loads) a Mix Effect and advances the ID to the next available ID. 

Create a New or Edit an Existing Mix Effect Preset 
To create a new Mix Effect Preset or edit an existing Mix Effect Preset: 

1.​ Do one of the following: 

○​ If creating a new Mix Effect Preset, then in the ME1 Bank, perform the desired 
modifications, and then save the Mix Effect Preset. 

or 

a.​ If working from an existing Mix Effect Preset that is not loaded, then load the 
saved Mix Effect Preset on which the new Mix Effect Preset is to be based. 
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b.​ Perform the desired modifications, and then save the Mix Effect Preset. 

Save a Mix Effect Preset 
If you would like to reuse a specific Mix Effect, then you can save the ME1 Bank settings to a 
Mix Effect Preset for quick recall. The following settings are saved: 

●​ Preset, Program and Key Bus settings, including any DVEs created within PRIME 
Switcher. 

●​ Transition Area settings. 

●​ Downstream Keyer settings, including Linear/Chroma Key. 

To save a Mix Effect Preset: 

1.​ In the ME1 Bank, configure the settings that you would like to save. 

2.​ In the Recall Area or on the Keypad, click the ME1 button.  The ME1 button highlights 
in both areas, as shown in the following figures. 

 

 

3.​ Do one of the following: 

○​ To save the Mix Effect Preset to the ID number currently displayed in the 
Recall Box, click SAVE on the Keypad. The edited settings overwrite the 
previously saved settings. 

○​ To save the Mix Effect Preset to a different ID number: 

■​ If using the Keypad or a physical keypad, enter an ID number. The 
number displays in the Recall Area Recall Box. 

■​ If using an alphanumeric keyboard, then click the Recall Box and enter 
an ID number. 

The number displays in the Recall Area Recall Box. 

4.​ On the Keypad, click SAVE. The Mix Effect Preset is saved to the specified ID number. 

​
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WARNING! There is no prompt when saving over an existing Mix Effect ID number. If you 
save a Mix Effect Preset over an existing Mix Effect ID number, overwrite permission is 
NOT requested. The Mix Effect Preset is overwritten. Be careful not to accidentally 
overwrite an existing Mix Effect Preset. 

Load/Play (Apply) a Mix Effect Preset 
Load/Play (Apply) Overview 
The Recall Area and Keypad provides two methods to apply a Mix Effect Preset to the ME1 
Bank: 

●​ LOAD/Enter: Applies the Mix Effect Preset whose ID is displayed in the Recall Box 
and advances the Mix Effect ID in the Recall Box to the next available Mix Effect ID. 

●​ PLAY: Applies the Mix Effect Preset whose ID is displayed in the Recall Box, and 
does not advance the Mix Effect ID in the Recall Box to the next ID. PLAY is available 
only from the Keypad. 

Load/Play (Apply) Mix Effect Presets 
When you load or play a Mix Effect Preset, the Mix Effect Preset settings are applied to the 
ME1 Bank. You can load or play a Mix Effect Preset from the Recall Area or the Keypad. 

To apply a saved Mix Effect Preset: 

1.​ In the Recall Area or on the Keypad, click the ME1 button. The ME1 button highlights 
in both areas, as shown in the following figures. 

 

 

2.​ Do one of the following: 

○​ Using the Keypad or a physical keyboard/keypad, enter the ID number of the 
Mix Effect Preset that you would like to load. The ID number displays in the 
Recall Box. The following figure shows ID 1 entered. 

 

​
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○​ On the Keypad, click PREV or NEXT to navigate to the desired ID. 

Note that If you do not enter an ID number and click LOAD, then the next available Mix 
Effect Preset is applied in the ME1 Bank Transition Area. 

3.​ Do one of the following: 

○​ To apply the Mix Effect Preset and advance the ID in the Recall Box to the next 
available Mix Effects Preset ID, press Enter, or on the Keypad, click LOAD. 

○​ To apply the Mix Effect Preset and retain the same Mix Effect ID in the Recall 
Box, on the Keypad, click PLAY. 

4.​ To apply additional Mix Effect Presets, repeat steps 2 and 3. 

To set up a sequence of Mix Effect Presets to play in order, save the IDs in the 
numerical/alphabetical order, and then use the LOAD function to apply and advance the ID to 
the next available ID. 

Delete Mix Effects ID from Recall Box 
To clear, i.e., erase the ID in the Recall Box in the Recall Area, do one of the following: 

●​ In the Recall Box, erase the ID. 

●​ On the Keypad, click DEL. 

Troubleshoot Transitions 

Preview Video Does Not Transition to Program 
In the Transition Area, BKGD is not active (unlit). 

●​ Click BKGD to activate (lit). 

Preview Video Transitions to Program, When It Should Not 
In the Transition Area, BKGD is active (lit). 

●​ Click BKGD to deactivate (unlit). 

Key Video Does Not Transition to Program​
In the Transition Area, the desired KEY is not active (unlit). 

●​ Click the desired KEY to activate (lit). 
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Key Video Transitions to Program, When It Should Not​
In the Transition Area, the desired KEY is active (lit). 

●​ Click the desired KEY to deactivate (unlit). 

Graphics 1 and Graphics 2 Both Display in Program, or​
Both Display in Preview, When They Should Alternate 
Graphics 1 and Graphics 2 are not properly set up to alternate. 

●​ See Set up Graphics 1 on Program, and Graphics 2 on Preview. 

The Graphic(s) Plays, but Does Not Transition to/from​
Switcher Program 
If a graphic(s) is playing, and does not transition to/from Program, then ensure that the 
Graphics Player is associated with a Key, and that the Key is active in the Transitions Area, 
i.e., the Key button is lit. 

For example, if you would like Graphics 1 to transition as a source for Key 1, then you must 
associate it with Key 1. To specify that it should transition, then you must activate the Key 1 
button in the Transition Area. 

See Set Transition Area, Set a Key Source, and Tying Together the Transition Area, Key Bus and 
Downstream Keyer for additional details. 

ME1 (Mix Effect) Output Does Not Display on Program or Preview 
ME1 is not selected as a PROGRAM or PREVIEW source in the Main Switcher Bank. 

●​ Select ME1 in the PROGRAM or PRESET bus. 
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Chapter 15: Work with Clips 

Overview 
The Prime Switcher Clip Player can cue, load, preview, scrub, play, pause, return to frame 0, 
stop, and loop a clip, as well as apply a Transition Effect between clips. 

 

The Clip Player can display clips and images in the following file formats: 

●​ *.gtc: Proprietary PRIME clip file format. 
●​ *.ppc: Proprietary PRIME clip file format. 
●​ *.mov: Apple QuickTime® Movie format - same codec as PRIME. ProRes is the *.mov 

wrapper. 
●​ *.mp4: MPEG-4 video file format. 
●​ Various image file formats. 

 

BEST PRACTICES 
Ensure that clips have the same resolution and frame rate as PRIME Switcher 
configuration; otherwise, they may not play correctly. 
 
Ensure that images that are to be played in the Clip Player have the same resolution as 
PRIME Switcher; otherwise, they may not display correctly. 
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Clips Browser 
The Clips Browser works in conjunction with the Clip Player. Clip resources are managed 
within the Clips Browser. 

 

PRIME Switcher can import clips. To import a clip: 

1.​ Click the Import Clip icon. The file browser opens. 
2.​ From the browser, select the desired clip(s), and then click Open. The clip(s) is added to 

the Clips Browser. 
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The Clips Browser also provides features accessible from the Clips Browser context menu. 
To access: 

●​ In the Clips Browser, right-click a clip thumbnail. The Clips Browser context menu 
displays: 

 

​
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Many of the items on this menu are available to all Assets Browsers. Items specific to clips are 
as follows: 

●​ Clip Edit functions, with which you can edit existing clips and create subclips. 

 

●​ Clip Player Control functions: Cue (Load), Play, Stop and Clear. 

 

Other items, including the following, are available to multiple types of browsers: 

●​ Quality Control provides the ability to view the state of PRIME clips. 

 

See the PRIME User Guide for information about this feature. 

●​ Content Distribution is a Chyron application that centrally manages and distributes 
assets. From this menu, you can publish or unpublish assets. 

 

See the Content Distribution User Guide for information about this feature. 
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Clip Edit Functions 

Edit Clip 
You can edit the parameters of an individual clip, including clip characteristics, clip metadata 
and playback parameters. 

CAUTION: Make sure that you retain a copy of the clip in its original version, as any 
edits to a clip are permanent. Generate Sub Clip provides the ability to create a new 
clip while preserving the original clip. 

To edit a clip: 

1.​ In the Clips Browser, right-click the clip thumbnail, and then select Edit Clip. The Edit 
Clip dialog appears. 

 

2.​ Edit clip parameters. 
3.​ When complete, click OK. The edits are permanently applied to the clip. 

​
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Clip/Sub Clip Parameters 
Overview 
PRIME Switcher provides the ability to customize the metadata and playback parameters of 
each clip as follows. 

Clip 
The Clip settings display the basic information about the clip.  

●​ Name: Edit name. 

●​ Path: Displays the location of the clip. Not editable. 

●​ Dimensions: Displays the clip resolution. Not editable. 

●​ Codec: Displays the clip codec. Not editable. 

Metadata 
You can add clip metadata for easier searching and sorting. 

●​ Title: Enter title, which can be different from the clip Name. 

●​ Keywords: Enter keywords to categorize and improve searchability. 

●​ Description: Enter description. 

●​ Message ID: Enter a clip ID. 

●​ Thumbnail: Displays clip thumbnail. 

●​ Update: Set the frame to display as the thumbnail. 
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Playback 
The Playback settings include volume control, transition, first/last frame hold, and trim and 
loop parameters, and the ability to preview the clip. See Set Trim and Loop for information on 
setting trim and loop. 

●​ Volume: Set audio playback volume. 

●​ Transition: Select a transition to apply as the clip starts to play. 

●​ CAMIO Channel: If connected to CAMIO, then select the CAMIO channel on which the 
clip is to play. 

●​ Show First Frame: 

○​ Enable to display and hold the first frame of the clip upon loading the clip to Clip 
Player Program. 

○​ Disable to not display and hold the first frame of the clip upon loading the clip to 
Clip Player Program. 

●​ Hold Last Frame: 

○​ Enable to display and hold the last frame of the clip when clip playback is 
complete. 

○​ Disable to not display and hold the last frame of the clip when clip playback is 
complete. 

●​ Progressive Still: 

○​ Enable to hold as a Progressive frame. 

○​ Disable to hold as a Field. 
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Set Trim and Loop 
You can trim the length of a clip by adjusting the Trim In and/or Trim Out points, and loop the 
clip by setting Loop In and Loop Out points. 

The Position field displays the current frame. The position of the Scrub Control slider reflects 
the frame number displayed in the Position field, and vice versa. 

●​ Drag the Scrub Control slider to the left to scrub in reverse, and to the right to scrub 
forward. 

To set Trim In and Trim Out: 

●​ Drag the Trim In marker and Trim Out set In and Out points. You can also enter frame 
numbers into the Trim In and Trim Out fields. 

The following figure shows Loop disabled. 

 

You can loop the entire length of the clip, or set a 3-Point or 4-Point Loop. 

To loop a clip: 

●​ Enable (check) the Loop checkbox. 

There are two Loop modes: 

●​ Linked: The entire clip, as bounded by the Trim In and Trim Out points, loops. The 
Loop In frame is the same as the Trim In frame, and the Loop Out frame is the same as 
the Trim Out frame. To link Loop and Trim settings, click the Link icon so that it is 
highlighted and displays a blue background. 

 

​
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The following figure shows Loop enabled, and Loop linked with Trim. The Loop In and 
Loop Out markers are locked to the Trim In and Trim Out markers. 

 

●​ Unlinked: A segment of the clip loops. The Loop In frame is independent of the Trim In 
frame, and the Loop Out frame is independent of the Trim Out frame. To unlink Loop 
and Trim settings, click the Link icon so that it is not highlighted and displays no 
background. 

 

The following figure shows Loop enabled, and Loop unlinked with Trim. You can set 
Trim In, Loop In, Trim Out and Loop Out markers independent of each other. 

 

​
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In Unlinked Mode, you can set a 3-Point Loop or a 4-Point Loop. 

○​ 3-Point Loop: 

■​ The Trim In and Loop In frame is the same. The Trim Out and Loop Out 
frames are different. 

■​ The Trim In and Loop In frames are different. The Trim Out and Loop 
Out frame is the same. 

○​ 4-point Loop: The Trim In, Loop In, Trim Out and Loop Out frames are all 
different. 

To set Loop In and Loop Out: 

●​ Drag the Loop In marker and Loop Out set In and Out points. You can also enter frame 
numbers into the Loop In and Loop Out fields. 

To set the number of times that a clip plays in when looping: 

●​ Select loop type from dropdown: 

○​ Indefinite: Starts clip playout from the Trim In point and plays the portion of the 
clip bounded by the Loop In and Loop Out markers until stopped or 
transitioned off by another clip. 

○​ 2: Starts clip playout from the Trim In point and plays the portion of the clip 
bounded by the Loop In and Loop Out markers twice. 

○​ 3: Starts clip playout from the Trim In point and plays the portion of the clip 
bounded by the Loop In and Loop Out markers three times. 

○​ 4: Starts clip playout from the Trim In point and plays the portion of the clip 
bounded by the Loop In and Loop Out markers four times. 

○​ 5: Starts clip playout from the Trim In point and plays the portion of the clip 
bounded by the Loop In and Loop Out markers five times. 

○​ Disable to play clip once. 
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Preview the Clip 
As you edit, you can preview the clip using the Scrub Control slider or the Transport 
Controls:  

 

From left to right, the Transport Controls are as follows: 

●​ Rewind: Returns the clip to frame 0. You can restart the clip. 

○​ If Show First Frame is enabled, then displays the first frame. 

○​ If Show First Frame is not enabled, then displays black. 

●​ Play: Plays the clip at normal speed. 

●​ Pause: Pauses the clip at the current frame. 

●​ Stop: Stops the clip. The clip player displays black. To replay the clip, you must reload 
it. 

●​ Reverse: Plays the clip in reverse. 

●​ Fast Forward: Plays the clip forward at faster speed for quick preview. 

Edit Power Clip 
Power Clips (*.ppc) are clips that are not part of individual PRIME scenes, but that can play 
from the independent Clip Players created within the PRIME configuration. You can edit a clip 
as a PRIME Power Clip. See the PRIME User Guide and the PRIME Playout Configuration 
Guide for additional information. 

To edit the clip as a Power Clip: 

1.​ In the Clips Browser, right-click the clip thumbnail, and then select Edit Power Clip. 
The PRIME Scene Designer opens. 

2.​ Edit the clip as desired. 
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To close the Scene Designer and return to the PRIME Switcher interface: 

●​ At the upper right corner of the PRIME Switcher interface, do one of the following: 
○​ Click the Playout icon. 

 

○​ Press Alt+Tab to cycle through the open applications, until you reach the PRIME 
Switcher application. You may have to press Alt+Tab more than once. 

○​ In the taskbar, typically at the bottom of the screen, right-click the Chyron logo 
icon and then select the PRIME Switcher window. 

The PRIME Switcher interface displays. 
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Generate Sub Clip 
You can create a sub-clip from an existing clip. The process is similar to editing a clip, but 
creates a new clip, instead of overwriting the existing clip. 

To create sub-clip: 

1.​ In the Clips Browser, right-click the clip thumbnail, and then select Generate Sub Clip. 
The Generate Sub Clip dialog appears. 

 

2.​ Edit sub clip parameters. When complete, click OK. The new sub clip is added to the 
Clips Browser. 
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Clip Player 
Clip Player Overview 
The Clip Player plays clips and images, provides the ability to loop the clip, and to apply a 
transition as the clip starts to play. 

 

      

 

​
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Clip Player Cued and Playing Channels vs. Switcher Preview and 
Program Channels 
In the PRIME Switcher, the Preview and Program channels each contain background video, 
and clips and/or graphics. 

●​ Contents of the Preview channel are “next up” for transition to Program. 

●​ Contents of the Program channel are on Program. 

The Clip Player Cued and Playing channels work differently. 

●​ The Clip Player Cued channel contains the clip that is to be played to the Clip Player 
Playing channel. 

●​ The Clip Player Playing channel displays the clip that is playing on Clip Player. 

​
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Clip Operations 
Clip Player Selection 
To perform most Clip Player operations, you must first select the specific Graphics Player. To 
do so, use any of the following methods: 

●​ Click the Clip Player. 

 

●​ Click the Clip Player button on the Keypad. 

 

●​ Click the Clip Player button in the Recall Area. 

 

​
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Clip Operations from the Clip Player 
The Clip Player provides two sets of transport controls. Except where noted, click a Transport 
Controls to operate: 

●​ Playing: Playback controls for currently loaded clip. 

○​ Rewind: Returns the clip to frame 0. You can restart the clip. 

■​ If Show First Frame is enabled, then displays the first frame. 

■​ If Show First Frame is not enabled, then displays black. 

○​ Play: Plays the clip. If the clip is the selected Program source, then it plays to 
Program. 

○​ Pause: Pauses the clip. The clip displays at the paused frame. 

○​ Stop: Stops the clip and rewinds the clip to frame 0. The Clip Player displays 
black. You can restart the clip. 

○​ Clear Clip: Clears the clip from the Clip Player. The Clip Player cuts to black. 

○​ Loop: Loops the clip. See Loop a Clip for details. 

●​ Cued: Playback controls for cued clip. 

○​ Play First Frame: Plays and holds the first frame of the clip. 

○​ Play: Simultaneously plays and transitions the cued clip to Playing, transitioning 
off the clip in Playing. 

○​ Clear Clip: Clears the clip from the Clip Player. 

Frame Counters display the elapsed and remaining durations during clip playback. 

●​ The Current Frame Counter displays the frame, i.e., elapsed duration, of the clip as it 
plays. You cannot edit the Current Frame Counter. 

●​ The Frames Remaining Counter displays the remaining duration left in the clip. You 
cannot edit the Frames Remaining Counter. 

The Scrub Control provides the ability to scrub through the clip. To do so: 

●​ Drag the Scrub Control slider to the left to scrub in reverse, and to the right to scrub 
forward. 
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If the Clip Player is added as an Audio Mixer source, then the Audio Level Display displays 
the audio level of the clip, which is also reflected in the Audio Mixer. 

Clip Operations from the Keypad 
The Keypad provides the following clip operations: 

●​ ID Entry: Numeric keypad to enter clip ID numbers in the Recall Box. 

●​ LOAD: Loads a clip into the Clip Player Cued channel, and advances the ID in the 
Recall Box to the next ID. 

●​ SAVE: Not applicable to clips. As such, the button is grayed out. 

●​ PLAY: Plays the loaded clip. Does not advance the clip ID in the Recall Box. Note that 
when a PLAY is performed, the clip specified in the Recall Box overrides the clip 
that is loaded in the Clip Player Cued channel. 

●​ PREV: In the Recall Box, displays the ID of the previous clip listed in the Browser. 

●​ NEXT: In the Recall Box, displays the ID of the next clip listed in the Browser. 

●​ CLEAR: Clears the clip from the Clip Player Playing channel. The Clip Player cuts to 
black. 

●​ DEL: Clears the ID from the Recall Box. 

Clip Operations from the Recall Box Are/Recall Box 
The Recall Box provides the following clip operations: 

●​ ID Entry: Enter clip ID numbers. 

●​ Load: Press Enter to load a clip into Cued. 

Clip Operations from the Clips Browser 
From the Clips Browsers, you can drag and drop a clip into a Clip Player Cued or Playing 
channel. 

●​ If you drop the clip into the Clip Player Cued channel, then it loads into the Graphics 
Player Cued channel. 

●​ If you drop the clip into the Graphics Player Playing channel, then it immediately plays 
in the Graphics Player Playing channel. 
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You can also Cue, Play, Stop and Clear a graphic from the selected Clip Player as follows: 

1.​ In the Clips Browser, right-click the clip’s thumbnail. The clip’s context menu appears: 

 

2.​ Select the desired action. 

○​ Cue: Loads the clip into the Cued channel of the selected Clip Player. 

○​ Play: Plays the clip on the selected Clip Player. 

○​ Stop: Stops the clip playout on the selected Clip Player and transfers it to the 
Clip Player Cued channel. 

○​ Clear: Clears the clip from the selected Clip Player. 
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Clip Operations Summary 
The following table summarizes the availability of clip operations from the various PRIME 
Switcher UI components: See legend below table for abbreviations. 

Operation 
⇨ 

Component ⇩ 
Select Clip 

Player 
Enter Clip 

ID Play Clip Load Clip Stop Clip Clear Clip 

PREV/ 
NEXT/ 
DEL 

Clip Player Click 
Clip Player 

NA NA NA NA NA NA 

Clip Player 
Playing 
Channel 

Click 
Clip Player 

NA NA NA Click Stop 
icon 

Click Clear 
icon 

NA 

Clip Player 
Cued 
Channel 

Click 
Clip Player 

NA Click Play 
icon 

NA NA Click Clear 
icon 

NA 

Keypad Click Clip 
Player 
button 

Click ID 
numbers 

Click Play 
button 

Click ID 
numbers, 
then click 

LOAD 
button 

NA Click 
CLEAR 
button 

Click PREV/ 
NEXT/DEL 

button 

Recall Area Click Clip 
Player 
button 

Enter (type) 
ID 

NA Enter ID, 
then press 

Enter 

NA NA PREV: NA 
NEXT: NA 
DEL: Erase 
Recall Box 

Clips 
Browser 
D&D 

NA NA D&D into 
Playing 
channel 

D&D into 
Cued 

channel 

NA NA NA 

Clips 
Browser 
Item DD 

NA NA Select item, 
then select 
Play icon. 
Plays in 
selected 

Clip Player 
Playing 
channel. 

Select item, 
then select 
Cue icon. 
Loads in 
selected 

Clip Player 
Cued 

channel. 

Select item, 
then select 
Stop icon. 

Stops 
selected 

clip. 

Select item, 
then select 
Clear icon. 

Clears 
selected 

clip. 

NA 

 

LEGEND 
D&D: 

 
Drag and drop 

 
DD: 

 
Drop-down 

 
NA: 

 
Not applicable 
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Enable/Disable Transport Controls 
You can set the Clip Player to enable or disable the display of: 

●​ Transport Controls 

●​ Current Frame Counter 

●​ Frames Remaining Counter 

The following figure shows Transport Controls, including Current and Remaining Frames: 

 

​
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The following shows Current and Remaining Frames display disabled. 

 

To enable/disable Transport Control display: 

1.​ Click the dropdown arrow at the upper right of the Clip Player. 

 

​
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2.​ Click Show Playback Controls to either enable or disable Transport Control display. 

○​ Check to enable Transport Control visibility. 
○​ Uncheck to disable Transport Control visibility. 

The following figure shows the Clip Player with Transport Control visibility disabled: 

 

​
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To enable/disable Current Frames and/or Frame Remaining display: 

1.​ Go to Config Menu > Playout Configuration > Clip Players. The Clip Controllers 
Playout Configuration dialog appears. 

 

2.​ For each Clip Player, click Show Current Frames to either enable or disable Current 
Frame display: 

○​ Check to enable Current Frame display. 
○​ Uncheck to disable Current Frame display. 

3.​ For each Clip Player, click Show Frame Remaining to either enable or disable 
Remaining Frames display: 

○​ Check to enable Remaining Frames display. 
○​ Uncheck to disable Remaining Frames display. 

4.​ Do one of the following: 

○​ Click Apply to continue modifying other settings. 
○​ Click OK to apply Clip Player settings and close the dialog. 

5.​ Close and restart PRIME Switcher to apply modifications. 
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Navigate the Clips Browser 

When you select a Clip Player and enter an ID into the Recall Box, either directly or via the 
Keypad or external keypad or keyboard, PRIME Switcher automatically locates the clip with 
that ID in the Clips Browser. Any PREV, NEXT, LOAD and PLAY operation from the Keypad 
then occurs in the Clips Browser. 

You can also load and play a clip using drag and drop, or play directly from the Clip Player. 

Display the ID of the Previous Clip in the Browser 
Clips in a Browser are ordered numerically, followed by alphabetically. To display the ID of the 
previous available clip: 

1.​ If the Clip Player button is already selected in the Recall Area or the Keypad, then 
proceed to the next step. If the Clip Player button is not already selected, then click the 
desired button. 

2.​ Click PREV. 

This operation does not load the clip into the Clip Player Cued channel. As such, you can click 
PREV multiple times to display the ID of the clip that you would like to load, and then click 
LOAD to load the clip into Cued. 

Display the ID of the Next Clip in the Browser 
Clips in a Browser are ordered numerically, followed by alphabetically. To display the ID of the 
next available clip: 

1.​ If the Clip Player button is already selected in the Recall Area or the Keypad, then 
proceed to the next step. If the Clip Player button is not already selected, then click the 
desired button. 

2.​ Click NEXT. 

This operation does not load the clip into the Clip Player Cued channel. As such, you can click 
NEXT multiple times to display the ID of the clip that you would like to load, and then click 
LOAD to load the clip into Cued. 

Load and Play Clips 
Clip Load and Play Overview 
Clip playout can be a one or two-step process: 

●​ Play: The clip plays in the Clip Player Playing channel in one operation.  

​
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●​ Load, then Play: The clip loads into the Clip Player Cued channel, and then a separate 
operation plays the clip in the Clip Player Playing channel. 

You can perform clip Load and Play operations using any of the following methods, and can 
mix and match them: 

●​ Drag and drop from Clips Browser into Clip Player 

●​ Clip Player Transport Controls 

●​ Keypad 

●​ Recall Area/Recall Box 

●​ Clips Browser Transport Controls 

To display a clip in PRIME Switcher Preview or Program, the Clip Player must be selected as 
a switcher source, or, if acting as a key, then the Clip Player must be selected as a Key 
source. See Set Transition Area, Set a Key Source, and Tying Together the Transition Area, Key 
Bus and Downstream Keyer, and The Clip Plays, but Does Not Display in Switcher Program or 
Preview for additional information. 
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Play a Clip via Drag and Drop 
You can load/play a clip in a single operation by dragging the clip directly into the Playing 
channel of the Clip Player. This operation loads the clip into the Cued channel and 
immediately plays it to the Playing channel, applying the specified transition (if any). As such, if 
a clip is already loaded into the Clip Player Cued channel, then this operation replaces the 
previously loaded clip. 

To play a clip via drag and drop: 

1.​ From the Clips Browser, drag the desired clip to the Clip Player monitor, until the Clip 
Player monitor and the Playing transport controls are highlighted. 

 

​
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2.​ Release the mouse button. The clip loads and immediately plays. The clip’s thumbnail 
briefly appears next to “Cued,” and then immediately switches to the Playing channel. 

 

You can drag a clip into the Clip Player while another clip is playing. The selected Transition 
Effect is applied as the current clip transitions off screen and the dragged clip transitions on 
screen. 

​
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Load a Clip via Drag-and-Drop, then Play 
You can load a clip into the Cued channel via drag and drop, and then play the Cued clip when 
ready. 

To load a clip into the Cued channel: 

1.​ From the Clips Browser, drag the desired clip to the Cued row until the Cued row is 
highlighted. 

 

​
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2.​ Release the mouse/touchpad select button. The clip is now loaded. The clip’s thumbnail 
appears next to “Cued.” 

 

To play the clip, do one of the following: 

●​ From the Cued transport controls, click the Play icon. 

●​ On the Keypad, click PLAY. 

Play a Clip from the Recall Area/Keypad 
You can load/play a clip from the Recall Area and Keypad. This operation loads the clip into 
the Cued channel and immediately plays it to the Playing channel, applying the specified 
transition (if any). As such, if a clip is already loaded into the Clip Player Cued channel, then 
this operation replaces the previously loaded clip. 

You can repeat this operation to play a sequence of clips. The selected Transition Effect is 
applied as the current clip transitions off screen and the next clip transitions on screen. 
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To play a clip from the Recall Area/Keypad: 

1.​ In the Recall Area or the Keypad, click the name of the Clip Player in which the clip is 
to be loaded. The selected Clip Player highlights in the Recall Area and the Keypad. 
The following figures show Clip Player 2 selected: 

 

 

2.​ Do one of the following: 

○​ On the Keypad, enter the ID of the clip to be displayed. This method works only 
for numeric IDs. 

○​ Click NEXT or PREV until the ID clip to be displayed appears in the Recall Box. 
This method works for both numeric and alphanumeric IDs. 

○​ Click the Recall Box, and then enter the ID. This method works for both 
numeric and alphanumeric IDs. 

 

3.​ Do one of the following: 

○​ On the Keypad, click PLAY. 

○​ On the Clip Player, click the Play icon in the Cued channel Transport Controls. 

Load a Clip from the Recall Area/Keypad, then Play 
You can load a clip into the Cued channel via using the Recall Area/Keypad, and then play the 
Cued clip when ready. 

To load a clip from the Recall Area/Keypad: 

2.​ In the Recall Area or on the Keypad, click the name of the Clip Player in which the clip 
is to be loaded. The selected Clip Player highlights in the Recall Area and the Keypad. 
The following figures show Clip Player 2 selected: 

​
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3.​ Do one of the following: 

○​ On the Keypad, enter the ID of the clip to be displayed. This method works only 
for numeric IDs. 

○​ Click NEXT or PREV until the ID clip to be displayed appears in the Recall Box. 
This method works for both numeric and alphanumeric IDs. 

○​ Click the Recall Box, and then enter the ID. This method works for both 
numeric and alphanumeric IDs. 

4.​ Press Enter, or on the Keypad, click LOAD. The clip loads into the Cued area of the 
specified Clip Player, and the ID advances to the next available ID in the Clips 
Browser. 

To play the clip, do one of the following: 

●​ On the Keypad, click PLAY. 

●​ On the Clip Player, click the Play icon in the Cued channel Transport Controls. 

Since the Recall Box has advanced to the next available ID in the Clips Browser, you can 
repeat step 4, and then play the next clip. 

Play a Cued Clip from the Clip Player 
To play a clip that is in the Clip Player Cued channel from the Clip Player: 

●​ Click the Play icon  in the Clip Player Cued channel Transport Controls. The clip 
immediately transitions to the Clip Player Playing channel using the selected transition 
(if any), and starts to play. 

Play the Clip Whose ID is Currently Displayed in the Recall Box 
To play the clip whose ID is currently displayed in the Recall Box: 

●​ On the Keypad, click PLAY. The ID remains the same and does not advance to the next 
available clip or graphic ID. 
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Load and Play an Ordered Sequence of Clips 
Clip Sequence Playout Overview 
You can load and play an ordered sequence of clips. As a clip is loaded into the Cued area, the 
Clip ID of the next clip in the directory displays in the Recall Box. 

To ensure that you load only the intended clip files, in the order in which they will display: 

●​ Move the clips into the directory that will be open in the Clips Assets Brower. 
●​ Remove from the directory any files that you do not intend to display. 
●​ Name the clips in numerical/alphabetical order of their appearance. Clips with Clip IDs 

that start with numbers load before clips with Clip IDs that start with alphabetic 
characters. 

A clip sequence can be triggered from the Recall Area, the Keypad, or a combination of both. 
The following sets of instructions describe how to load and play a clip sequence from the 
Recall Area and from the Keypad. For clarity, the two sets of instructions are separate; 
however, you may switch between them. 

Note also that if you are playing sequences in the other components, i.e., the Graphics 
Players and ME1 (Mix Effects), you may want to set PRIME Switcher to independently keep 
track of each component’s last ID, so that you can resume where you left off. This applies to 
Keypad ID entry. 

Load and Play an Ordered Sequence of Clips from the Recall Area 
To recall and play an ordered sequence of clips from the Recall Area: 

1.​ In the Recall Area, click the name of the Clip Player in which the clip is to be loaded. 
The Keypad reflects the selection. The following figures show Clip Player 2 selected in 
the Recall Area and on the Keypad: 

 

 

2.​ Clear (erase) the Recall Box. 

​
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3.​ You can start the sequence from the first clip in the Clips Browser, or from a different 
clip in the Clips Browser. 

○​ If starting from the first clip in the Clips Browser, then with the cursor still in the 
Recall Box, press Enter. 

○​ If starting from a different clip in the Clips Browser, then in the Recall Box, 
enter the ID of the first clip to display in the sequence. 

4.​ With the cursor in the Recall Box, press Enter. The clip loads into the Clip Player 
Cued channel of the specified Clip Player. 

Note that any clip that is already in the Cued area is replaced. Only one clip can be 
loaded into the Cued Channel at any time. 

In addition, the ID of the next available clip in the Clips Browser displays in the Recall 
Area. 

5.​ Do one of the following to play the clip: 

○​ From the Clip Player Cued transport controls, click the Play icon. 

○​ On the Keypad, click PLAY. 

The Cued clip plays. 

6.​ Repeat steps 4 and 5 as needed to play through the sequence. 

Load and Play an Ordered Sequence of Clips from the Keypad 
To recall and play an ordered sequence of clips from the Keypad: 

1.​ On the Keypad, click the name of the Clip Player in which the clip is to be loaded. The 
Recall Area reflects the selection. The following figures show Clip Player 2 selected on 
the Keypad and in the Recall Area: 

 

 

2.​ Click DEL to clear the Recall Box. 
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3.​ You can start the sequence from the first clip in the Browser, or from a different clip in 
the Browser. 

○​ If starting from the first clip in the Browser, then on the Keypad, click LOAD. 

○​ If starting from a different clip in the Browser, then do one of the following: 

■​ On the Keypad, enter the ID of the first clip to display in the sequence. 
This method works only for numeric IDs. 

■​ Click NEXT or PREV until the ID first clip to be displayed appears in the 
Recall Box. This method works for both numeric and alphanumeric IDs. 

4.​ On the Keypad, click LOAD. 

The clip loads into the Cued channel of the specified Clip Player. Note that any clip 
that is already in the Cued area is replaced. Only one clip can be loaded into the Cued 
channel at any time. 

In addition, the ID of the next clip in the sequence displays in the Recall Area. 

5.​ Do one of the following to play the clip: 

○​ From the Clip Player Cued transport controls, click the Play icon. 

○​ On the Keypad, click PLAY. 

The Cued clip plays. 

6.​ Repeat steps 4 and 5 as needed to play through the sequence. 

Delete Clip ID from Recall Box 
To clear, i.e., erase the ID in the Recall Box in the Recall Area, do one of the following: 

●​ In the Recall Box, erase the ID. 

●​ On the Keypad, click DEL. 
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The Clip Plays, but Does Not Display in Switcher Program or Preview 
For a clip to appear on the switcher Preview or Program channel, you must do one of the 
following: 

●​ Select the Clip Player as a source for the Main Bank Preset or Program bus, 
respectively. 

●​ Select the Clip Player as a source for the ME1 Bank Program bus, and select ME1 as 
a source for the Main Bank Preset or Program bus, respectively. 

●​ Select the Clip Player as a KEY source for the Main Bank Preset or Program bus, 
respectively. 

●​ Select the Clip Player as a KEY source for the ME1 Bank Program bus, and select 
ME1 as a source for the Main Bank Preset or Program bus, respectively. 

Otherwise, the clip plays only in the Clip Player. 

Loop a Clip 
A clip can be looped prior to playing or while playing. To loop a clip: 

●​ Click the Loop icon in the Clip Player. Note that only the clip in Playing can be looped. 

 

​
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Stop a Clip, with Ability to Replay 
Stop Clip Overview 
When you stop a clip, the clip stops playing, but remains in the Clip Player Playing channel, so 
that you can replay it. The Stop operation does not affect the contents of the Clip Player Cued 
channel. 

Stop a Clip from the Clip Player, then Replay 
To stop a clip from the Clip Player’s Playing Channel: 

●​ In the Clip Player, click the Clip Player Stop icon . The clip stops, and remains in 
the Clip Player Playing channel. 

To replay the clip: 

●​ In the Clip Player Playing channel, click the Play icon . As the clip is already in the 
Clip Player Playing channel, if a transition is specified, it is not applied to the replay. 

Stop a Clip via the Clips Browser 
To stop a clip in the selected Clip Player, from the Clip Browser context menu: 

1.​ In the Clip Browser, right-click the clip’s thumbnail. The clip’s context menu appears: 

 

2.​ Click the Stop icon. 

To replay the clip: 

●​ In the Clip Browser, right-clip the clip’s thumbnail, and then click the Play icon. As the 
clip is already in the Clip Player Playing channel, if a transition is specified, it is not 
applied to the replay. 
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Clear a Clip from the Clip Player 
To clear a clip from a Clip Player: 

1.​ Click the Clip Player from which you would like to clear a clip, click the Clip Player 
button. If the button is already selected, then proceed to the next step. 

2.​ Click CLEAR. The following occurs, depending upon the Clip Player configuration: 

○​ If the Clip Player Cued Channel and Clip Player Program Channel display on 
discrete Clip Player monitors, then the clip clears from the last selected channel 
(Clip Player Cued or Clip Player Program). 

○​ If the Clip Player Cued Channel and Clip Player Program Channel display on 
the same Clip Player monitors, then: 

i.​ The clip clears from the Clip Player Program Channel. 

ii.​ Once the Clip Player Preview Channel is cleared, then the next click 
clears the Clip Player Program Channel. 
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Clearing a clip removes the clip from the Clip Payer. To clear a clip from either Playing or 
Cued, do one of the following: 

●​ In the Clip Player, click the Clear Clip icon in the Playing or Cued channel. If the clip 
that you cleared was in Playing, then the Clip Player monitor cuts to black. 

●​ On the Keypad or in the Recall Area, ensure that the correct Clip Player is selected, 
and then on the Keypad, click the CLEAR button. 

○​ If a clip is currently playing, then the clip is cleared from the Playing channel, 
and the Clip Player cuts to black. 

○​ If there is no clip in the Playing channel, and a clip is loaded in the Cued 
channel, then the clip is cleared from the Cued channel. 

○​ If a clip is playing and there is and a clip is loaded in the Cued channel, then: 

■​ The clip is cleared from the Clip Player, and the Clip Player monitor cuts 
to black. 

■​ To clear the clip in the Cued channel, click CLEAR again. 

Clip Transitions 
Overview 

A transition can be applied as a clip transition from Cued to Playing. This transition is 
independent of the transition that is set in the switcher Transition Area. 

The transition is applied only between clips, not when the first clip is played on screen, nor as 
the last clip is playing off screen. 

In the upper right corner of the Clip Player tab, the name of the active transition or “None” 
appears next to “Transition.” 
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Select a Clip Transition 

To select a clip transition: 

1.​ Click None or the transition name (whichever is displayed). 

2.​ From the browser, select the desired clip transition. 

 

3.​ Click OK. The selected transition is applied to clip-to-clip transitions. 

A Clip Transition file is in *.pct format. Switcher Transition files are in *.pst format. A *.pst file 
cannot be used as a Clip Transition. 

Switch to a Different Transition 
To switch from one transition to another: 

1.​ Click the transition name. The Clip Transitions \ Common folder opens, and displays 
the available transitions. 

2.​ Select the desired transition. 

3.​ Click OK. The selected transition is applied to clip-to-clip transitions. 
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Import a Transition 
If a desired transition(s) is located elsewhere, then it (they) can be imported into the Clips 
Transitions \ Common folder. 

To import a transition: 

1.​ Click None or the transition name. The Clip Transitions \ Common folder opens, and 
displays the available transitions. 

2.​ Click the Import Files icon. The Import PRIME Transition files browser opens. 

3.​ Browse to the desired file(s), select them, and then click Open. The browser closes. The 
imported transitions are now available to the Clip Player. 

Inactivate (Deselect) a Transition 

A transition can be made inactive, i.e., deselected, so that it is no longer applied to clip-to-clip 
transitions. 

To deselect a transition: 

1.​ Click the transition name. The Clip Transitions \ Common folder opens. The active 
transition is highlighted. 

2.​ Click Deselect. The Clip Transitions \ Common folder closes. The transition is no 
longer active. Transition Name appears as None. 
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Use Image as Clip in Clip Player 
The Clip Player can play images, and an image can be added to the Clips Browser. 

To play or cue an image to the Clip Player: 

●​ Drag the image into the Clip Player screen or Clip Player Cued in the same manner as 
you would a clip. 

or 

1.​ In the Images Browser, right-click the image thumbnail. The Images context menu 
appears: 

 

​
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2.​ Select the desired action. 

○​ Cue: Loads the image into Clip Player Cued. 

○​ Play: Plays the image in the Clip Player. Because the image is static, the Scrub 
Bar displays at the end point. The Current Frame Counter and Frames 
Remaining Counter both display 00:00:00.00. 

○​ Stop: Stops the image playout. The image thumbnail remains in Playing and 
can be replayed. 

○​ Clear: Clears the image from the Graphics Player. 

When the Clip Player displays an image, the Clip Player’s Transport Control Pause and Stop 
buttons are grayed out and do not operate. 

Add Image as Clip 
You can add an image to the Clips Browser. Doing so converts the image to *.ppc file, which 
is the PRIME Switcher native clip file format. 

To add an image to the Clips Browser: 

●​ In the Images Browser, right-click the image thumbnail, and then select Add to Clips. 
The image remains unchanged in the Images Browser, and the converted *.ppc clip 
version of the image appears in the Clips Browser. 

Note that to stop the clip, i.e., to remove it from the screen, but keep it in Playing, you select 
the Stop item from the clip’s context menu, as the Transport Control Stop is grayed out. 

Clip Playback via PRIME Playlist and PRIME Commander 
In addition to direct playout from the Clip Player(s), Keypad, Recall Area, and Clips Browser: 

1.​ The PRIME Playlist can trigger clip playback from within PRIME Switcher. 

2.​ Chyron PRIME Commander, an optional PRIME Live Platform control interface, can 
trigger clip playback. 

 

 

​
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Chapter 16: Work with Graphics 

Overview 
PRIME provides two Graphics Players in which one or more scenes and/or messages, 
collectively known as graphics, can be cued, loaded, previewed, and played. 

 

Scenes, clips, and images in the following formats can be displayed by PRIME Switcher: 

●​ *.pbx: PRIME scene file 

●​ *.pbm: PRIME message file 

●​ *.ppc: Proprietary PRIME Power Clip file format 

●​ *.gtc: Proprietary PRIME clip file format 

●​ Various image file formats 

 

BEST PRACTICES 
Ensure that scenes and clips have the same resolution and frame rate as PRIME 
Switcher configuration; otherwise, they may not play correctly. 

Ensure that images have the same resolution as PRIME Switcher; otherwise, they may 
not display correctly. 
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Scenes/Messages Browsers 
The Scenes  and Messages Browser work in conjunction with the Graphics Player. Graphics 
resources are managed within the Scenes and Messages Browsers. The following shows a 
Scenes Browser. 

 

The Messages Browser operates in the same manner. The Messages Browser displays the 

Messages Source Display Selection icon . 

For simplicity, a number of the operations are described in the following sections show the 
Scenes Browser. Unless otherwise noted, the Messages Browser provides the same 
functions. 
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The Scenes and Messages Browsers also provide features accessible from a context menu. 
To access: 

●​ In the Scenes or Messages Browser, right-click a scene thumbnail. The Scenes or 
Messages Browser context menu, respectively, displays: 

 

​
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Many of the items on this menu are available to all Assets Browsers. Items specific to 
graphics are as follows: 

●​ Scene and Message Edit Functions, with which you can edit existing scenes and 
messages. The following shows the Scenes Browser and Messages Browser menu 
items. 

Scene Edit Functions Message Edit Functions 

​
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You can also access the Scene Editor from the Recall Area. This works for both 
scenes and messages. 

 

○​ Click the Scene icon , and then select Edit Scene from the dropdown. 

You can create a new scene: 

○​ Click the Scene icon , and then select New Scene from the dropdown. 
The PRIME Scene Designer opens. 

See the PRIME User Guide for information on creating and editing scenes. 

●​ Graphics Player Control functions: Cue (Load), Play, Stop and Clear. 

 

Other items, including the following, are available to multiple types of browsers: 

●​ Quality Control provides the ability to view the state of PRIME scenes and messages. 

 

See the PRIME User Guide for information about this feature. 
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●​ Content Distribution is a Chyron application that centrally manages and distributes 
assets. From this menu, you can publish or unpublish assets. 

 

See the Content Distribution User Guide for additional information about this feature. 

Scene and Message Edit Functions 

Edit Scene 
Edit Scene opens the PRIME Editor. See the PRIME User Guide for information on editing 
PRIME scenes. 

Edit Message 
Overview 
Edit Message provides the ability to quickly create PRIME messages based on existing PRIME 
scene templates, and edit the replaceable text, graphics and/or clip elements of existing 
messages. See the PRIME User Guide for additional information about working with scenes 
and messages. 

For example, you can create a set of messages based on an Over-the-Shoulder (OTS) 
graphic. If you create multiple sets of messages based on different templates, then for easier 
playout OTS messages: 

 

​
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Save Mode 
Each edit to a message can automatically save, or you can save edits at will. 

●​ To automatically save edits, enable the Auto Save checkbox . The Save icon 
grays out. 

●​ To save at will, disable the Auto Save checkbox. The Save icon becomes active. To 

save edits, click the Save icon . 

Create Messages 
To create a set of messages: 

1.​ In the Scenes Browser, right-click the thumbnail of the scene on which you would like 
to base the messages. 

2.​ Each message that you create has a message ID number, which is used to recall the 
message for playout. As you create the list, assign the IDs in the order in which they will 
play. 

In the ID field, enter an ID number. If you enter an ID number of an existing message, 
then the following displays: 

 

Do one of the following: 

○​ Click Yes to replace the existing message. 

○​ Click No to save to a different ID number, and then enter a different message 
number in the ID field. 

3.​ If there is a text field(s), then enter the text in the text field(s). 

​
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4.​ If there is a graphics or clip field(s), then select the file by either selecting from as 
Assets Browser, or typing the filename: 

○​ To select the file from an Assets Browser: 

1.​ Double-click the field. The Assets Browser configured for that field 
appears. The specific Assets Browser is configured in PRIME when 
creating the scene template. You can also browse to a different location. 

2.​ Select the desired file. The file name populates the field. 

You can also click the arrow (when visible) at the right of the field to display the 
Assets Browser. 

 

○​ To type the file name: 

1.​ Click the field to highlight it, then double-click the field. The entry field 
appears. 

 

2.​ Type the name of the file. 

●​ If the file is in the current project’s folder for that asset, then only 
the filename is necessary. 

●​ If it is located outside of the project’s designated folder, then you 
must type the file path. 

5.​ Repeat steps 2 through 4 to create additional messages on subsequent rows. 

Edit Existing Message 
You can edit existing messages, using steps 2, 3, and/or 4 in Create Messages. 

​
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View Asset File Path 
To view the filepath of an asset, hover over the field that displays the name of the file. 

 

Sort Messages 
You can sort the messages by any column: 

●​ Click the column heading to toggle sorting in numerical/alphabetical or reverse 
numerical/alphabetical order. 

Refresh View 
To refresh the view and re-sort by ID: 

●​ Click the Refresh icon . 

Play Messages 
To play out the messages: 

1.​ In the Recall Area or on the Keypad, click the Graphics Player button that 
corresponds to the Graphics Player on which to play the graphics. 

2.​ In the Recall Box, enter the first number of the list of messages that you would like to 
play. 

3.​ Press Enter. The message loads into the Graphics Player Preview. 

​
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4.​ Press Enter for each subsequent message to load into the Graphics Player Preview. 
To view the list of messages that are loaded in Graphics Player Preview, click the 
arrow directly to the right of “Preview.” 

 

5.​ When you have finished loading the messages, then in the Graphics Player Preview, 
click Play to play the first message in the list. 

 

6.​ Click Play to play each subsequent message. 
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Import Graphic(s) 
To import a graphic(s): 

1.​ Click the Import Graphic icon. The file browser opens. 

2.​ From the browser, select the desired graphic(s), and then click Open. The graphic(s) is 
added to the Scenes Browser. 

​
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Graphics Player 
Graphics Player Overview 
The Graphics Player plays scenes and messages created in PRIME, as well as images and 
clips. 

 

 

 

 

​
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Unless otherwise specified, references to graphics apply to both scenes and messages in the 
remainder of this chapter. 

Graphics Player Preview and Program Channels vs. Switcher Preview 
and Program Channels 
In the PRIME Switcher, the Preview and Program channels each contain background video, 
and clips and/or graphics. 

●​ Contents of the Preview channel are “next up” for transition to Program. 

●​ Contents of the Program channel are on Program. 

The Graphics Player Preview and Program channels work differently. 

●​ The Graphics Player Preview channel contains the graphics that are to be played to 
the Graphics Player Program channel. 

●​ The Graphics Player Program channel displays the graphics that are playing on 
Graphics Player. 

For the graphics in the Graphics Player Program channel and graphics playing from the 
Graphics Player Preview channel to the Graphics Player Program channel to display on the 
PRIME Switcher Program channel: 

●​ The Graphics Player must be set as a switcher Key source; and, 

●​ That Key source must be active (lit red) on the Key Bus. 

​
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Display Graphics Player Program and Preview Channels in Separate 
Monitors 
A Graphics Player can display its Program channel and contain the contents of its Preview 
channels in the same monitor, or it can display them in separate monitors. The default is single 
monitor. 

The following  shows the Graphics Player Program and Preview channels in a single monitor. 
You cannot view the graphics in the Preview channel, although you can view the list of 
graphics in the Preview channel 

 

The following shows the same set of graphics, with the Graphics Player Program and 
Preview channels each in their own monitor. The Graphics Player Preview monitor plays 
graphics to the Graphics Player Program monitor. 

The Preview monitor displays the last graphic that was added to the Preview list. 

 

​
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When playing back graphics from the Preview channel in either configuration, they play in the 
order in which they were added to the Preview list. You can, however, select any graphic from 
the list to play, in any order. See Select a Graphic in the Graphics Player Program or Preview 
Channel for additional information. 

To configure a separate Graphics Preview monitor: 

1.​ Go to Config > Playout Configuration > Video Channels, and then scroll to a 
Graphics channel. For this exercise use Graphics 1. 

2.​ Click the Preview Channel drop-down, and then select Add Preview Channel. 

 

​
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3.​ Scroll right until you reach the new Preview Channel. 

 

​
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4.​ In the Name field, rename Preview 1 to Graphics Preview 1. 

 

5.​ Scroll back to the Graphics channel. Note that the Preview Channel name is now 
Graphics Preview 1. 

 

6.​ Click OK. Close and restart PRIME Switcher. 

7.​ In the View menu, the Graphics Player Preview and Program now list as two separate 
components: Graphics 1 Preview and Graphics 1 Program. Go to the View menu and 
enable visibility for each. 
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To display Graphics Preview and Program channels in a single monitor: 

1.​ Go to Config > Playout Configuration > VIdeo Channels, and then scroll to the 
Graphics channel. 

2.​ From the Preview Channel drop-down, select No Preview. 

3.​ Do one of the following: 

○​ If you would like to retain the Graphics 1 Preview Channel for future use, then 
proceed to step 4. 

○​ If you would like to delete the Preview Channel, then scroll to the Graphics 

Preview 1 channel, and then click the Remove icon  at the top right of the 
settings. 

 

4.​ Click OK. Close and restart PRIME Switcher. 

5.​ In the View menu, the Graphics Player Preview and Program now list as a single 
component: Graphics 1. Go to the View menu and enable visibility. 
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Graphics Operations 
Graphics Player Selection 
To perform most Graphics Player operations, you must first select the specific Graphics 
Player. To do so, use any of the following methods: 

●​ Click the Graphics Player. 

 

If the Graphics Player Program channel and the Graphics Player Preview channel are 
displayed in separate monitors, then click either to select the specific Graphics Player. 

 

●​ Click the Graphics Player button on the Keypad. 

 

●​ Click the Graphics Player button in the Recall Area. 

 

​
 

338 | PRIME 5.3 Switcher User Guide​
​
 



Graphics Operations from the Graphics Player 
Each Graphics Player provides two sets of Transport Controls. 

●​ Graphics Player Program Channel: Provides controls for graphic(s) currently displayed 
in the Graphics Player Program channel. 

○​ Stop: Transitions the graphic displayed in the thumbnail from Graphics Player 
Program to Graphics Player Preview, applying the Effect Out set in the 
graphic. 

○​ Clear Graphic: Cuts the graphic displayed in the thumbnail off screen. The 
graphic is cleared from the Graphics Player. 

●​ Graphics Player Preview Channel: Provides controls for graphic(s) loaded into the 
Graphics Player Preview channel. 

○​ Play: Plays the graphic specified in the thumbnail from Preview to Program, 
applying the Effect In set in the graphic. If a separate Graphics Player Preview 
monitor is configured, then the graphic displayed on the Graphics Player 
Preview monitor may be different from the thumbnail that indicates the next 
graphic to play.  

○​ Clear Graphic: Cuts the graphic displayed in the thumbnail off screen. The 
graphic is cleared from the Graphics Player. 

Play and Stop are complementary operations: 

●​ Play plays the graphic from the Graphics Player Preview channel to the Graphics 
Player Program channel. 

●​ Stop transitions the graphic from the Graphics Player Program channel to the 
Graphics Player Preview channel. 

NOTE: A graphic may behave differently depending upon the logic built into the 
graphic. Before going live on air, ensure that you become familiar with how each 
graphic behaves when transitioning on and off Program, and when interacting with 
other graphics. 

To operate a transport control: 

●​ Click the desired transport control button. 

​
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Graphics Operations from the Keypad 

The Keypad provides the following graphics operations: 

●​ Select Graphics 1 or Graphics 2 Graphics Player. 

●​ ID Entry: Numeric keypad to enter graphics ID numbers. 

●​ LOAD: Loads a graphic into the Graphics Player Preview channel. Advances the 
Recall Box to the next ID listed in the Browser. 

●​ SAVE: Not applicable to graphics. As such, the button is grayed out. 

●​ PLAY: Plays the loaded graphic. Does not advance the graphics ID in the Recall Box. 
Note that when a PLAY is performed from the Keypad, the graphic specified in the 
Recall Box overrides the graphic that is loaded in the Graphics Player Preview 
channel. 

●​ PREV: In the Recall Box, displays the ID of the previous graphic listed in the Browser. 

●​ NEXT: In the Recall Box, displays the ID of the next graphic listed in the Browser. 

●​ CLEAR: Clears (cuts) the graphic whose thumbnail is displayed in the Graphics 
Player’s Program or Preview channel, whichever is active. A channel is considered 
active as follows: 

○​ When an operation is performed in the channel, e.g., a graphic plays in the 
Graphics Player Program channel or a graphics is loaded into the Graphics 
Player Preview channel, the channel becomes active; or, 

○​ When the Graphics Player Program and Preview channels are displayed in 
separate monitors, the monitor that you click becomes the active channel.  

●​ DEL: Clears the Recall Box. 

Graphics Operations from the Recall Area/Recall Box 

The Recall Box provides the following functions: 

●​ Select Graphics 1 or Graphics 2 Graphics Player. 

●​ ID Entry: Enter graphics ID numbers. 

●​ Load: Press Enter to load a graphic. Each subsequent Enter press loads the next 
graphic listed in the Browser. 

​
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Graphics Operations from the Scenes and Messages Browsers 
From the Scenes and Messages Browsers, you can drag and drop a graphic into a Graphics 
Player Preview or Program channel. 

●​ If you drop the graphic into the Graphics Player Preview channel, then it loads into the 
Graphics Player Preview channel. 

●​ If you drop the graphic into the Graphics Player Program channel, then it immediately 
plays in the Graphics Player Program channel. 

You can also Cue, Play, Stop and Clear a graphic from the selected Graphics Player as 
follows: 

1.​ In the Scenes or Messages Browser, right-click the graphic’s thumbnail. The graphic’s 
context menu appears: 

 

2.​ Select the desired action. 

○​ Cue: Loads the graphic into the Graphics Player Preview channel. 

○​ Play: Plays the graphic. 

○​ Stop: Stops the graphic playout and transfers it to the Graphics Player Preview 
channel. 

○​ Clear: Clears the graphic from the Graphics Player. 

 

​
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Graphics Operations Summary 
The following table summarizes the availability of graphics operations from the various PRIME 
Switcher UI components. See legend below table for abbreviations. 

Operation 
⇨ 

Componen
t ⇩ 

Select 
Graphics 

Player 

Enter 
Graphic 

ID 
Play 

Graphic 
Load 

Graphic 
Stop 

Graphic 

Close 
(Remove) 
Graphic 

Clear 
Graphic 

PREV/ 
NEXT/ 
DEL 

Player Click GP NA NA NA NA NA NA NA 

GP Pgm 
Ch 

Click GP NA NA NA Click 
Stop icon. 
Transfers 
graphic to 
GP Prev 

Ch 

Click 
Close 
icon 

NA NA 

GP Prev 
Ch 

Click GP NA Click Play 
icon 

NA NA Click 
Close 
icon 

NA NA 

GP Pgm 
Ch DD 

NA NA NA NA Select 
graphic, 

then click 
Stop icon 

NA NA NA 

GP Prev 
Ch DD 

NA NA Select 
graphic, 

then click 
Play icon 

NA NA NA NA NA 

Keypad Click GP 
button 

Click ID 
numbers 

Click 
PLAY 
button 

Click ID 
numbers, 
then click 

LOAD 
button 

NA NA Click 
CLEAR 
button 

Click 
PREV/ 

NEXT/DE
L button 

Recall 
Area 

Click GP 
button 

Enter 
(type) ID 

NA Enter ID, 
then 
press 
Enter 

NA NA NA PREV: NA 
NEXT: NA 
DEL: Erase 
Recall Box 

Graphics/
Message
s 
Browser 
D&D 

NA NA D&D into 
GP Pgm 

Ch 

D&D into 
GP Prev 

Ch 

NA NA NA NA 

Graphics/
Message
s 
Browser 
Item DD 

NA NA Select 
item, then 

select 
Play icon. 
Plays in 
selected 
GP Pgm 

Ch. 

Select 
item, then 

select 
Cue icon. 
Loads in 
selected 
GP Prev 

Ch. 

Select 
item, then 

select 
Stop icon. 

Stops 
selected 
graphic, 
transfers 
it to GP 

NA Select 
item, then 

select 
Clear 
icon. 

Clears 
selected 
graphic. 

NA 
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Prev Ch. 
 

LEGEND 
D&D: 

DD: 

 
Drag and drop 
Drop-down 

 
GP: 
NA: 

 
Graphics Player 
Not applicable 

 
Prev Ch: 
Pgm Ch: 

 
Graphics Player Preview channel 
Graphics Player Program channel 

Navigate the Graphics Browser 
Set Active Scenes or Messages Browser 
When you select a Graphics Player and enter an ID into the Recall Box, either directly or via 
the Keypad or external keypad or keyboard, PRIME Switcher automatically locates the graphic 
with that ID in the Scenes or the Messages Browser, depending on where the ID is located. 
Any PREV, NEXT, LOAD and PLAY operation from the Keypad then occurs in that Browser. 

As such, scenes and messages should not have the same IDs. 

For example, if the Scenes Browser contains scenes with IDs 100, 101, 102, and 103, and the 
Messages Browser contains messages with IDs 1, 2, 3, and 4. 

●​ If you enter ID 100, then the focus switches to the Scenes Browser. If you 
subsequently perform a PREV, NEXT, LOAD, and PLAY operations, they will occur in 
the Scenes Browser. 

●​ If you enter ID 2, then the focus switches to the Messages Browser. If you 
subsequently perform a PREV, NEXT, LOAD, and PLAY operations, they will occur in 
the Messages Browser. 

You can also load and play a graphic using drag and drop, or play directly from the Graphics 
Player. 

Display the ID of the Previous Graphic 
Graphics in a Browser are ordered numerically, followed by alphabetically. To display the ID of 
the previous available graphic: 

1.​ If the Graphics Player button is already selected in the Recall Area or the Keypad, 
then proceed to the next step. If the Graphics Player button is not already selected, 
then click the desired button. 

2.​ Click PREV. 

This operation does not load the graphic into the Graphics Player Preview channel. As such, 
you can click PREV multiple times to display the ID of the graphic that you would like to load, 
and then click LOAD to load the clip into the Graphics Player Preview channel. 

​
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Display the ID of the Next Graphic 
Graphics in a Browser are ordered numerically, followed by alphabetically. To display the ID of 
the next available graphic: 

1.​ If the Graphics Player button is already selected in the Recall Area or the Keypad, 
then proceed to the next step. If the Graphics Player button is not already selected, 
then click the desired button. 

2.​ Click NEXT. 

This operation does not load the graphic into the Graphics Player Preview channel. As such, 
you can click NEXT multiple times to display the ID of the graphic that you would like to load, 
and then click LOAD to load the clip into the Graphics Player Preview channel. 

Load and Play Graphics 
Graphics Load and Play Overview 
To display a graphic in PRIME Switcher Preview or Program, the Graphics Player must be 
selected as a Key source, or if acting as a switcher source (as opposed to a key), then the 
Graphics Player must be selected as a switcher source. See Set Transition Area, Set a Key 
Source, and Tying Together the Transition Area, Key Bus and Downstream Keyer, and The 
Graphic Plays, but Does Not Display in Switcher Program or Preview for additional information. 

Graphics playout can be a one or two-step process: 

●​ Play: The graphic plays in the Graphics Player Program channel in one operation. The 
graphic’s Effect In is applied. 

●​ Load, then Play: The graphic loads into the Graphics Player Preview channel, and 
then a separate operation plays the clip in the Graphics Player Program channel. The 
graphic’s Effect In is applied. 

You can load or play a single graphic, or a sequence of ordered or unordered graphics: 

●​ Ordered graphics are those that are arranged, in the Scenes or Messages Browser, in 
the numerical/alphabetical order in which they will load/play. 

●​ Ordered graphics are those that are not necessarily arranged, in the Scenes or 
Messages Browser, in the numerical/alphabetical order in which they will load/play. 

​
 

344 | PRIME 5.3 Switcher User Guide​
​
 



You can perform clip Load and Play operations using any of the following methods, and can 
mix and match them: 

●​ Drag and drop from Scenes or Message Browser into Graphics Player 

●​ Graphics Player Transport Controls 

●​ Keypad 

●​ Recall Area/Recall Box 

●​ Scenes or Messages Browser Transport Controls 

Note that Keypad operations are based on the ID that is displayed in the Recall Box, not on 
the graphic that is current in the Graphics Player. 
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Select from Multiple Graphics in the Graphics Player Program or Preview 
Channel 
When multiple graphics are present in the Graphics Player Program or Preview channel, you 
can select and play, stop, or close (remove) the graphic from the Graphics Player. 

The currently selected graphic is displayed in the thumbnail, along with its name. The following 
shows that in the Graphics Player Program channel, L3 - Live Bug is selected, and in the 
Graphics Player Preview channel, 14 is selected. As such: 

●​ In the Graphics Player Program channel, a Stop or Close operation performed from 
the Graphics Player is applied to the L3 - Live Bug graphic. 

●​ In the Graphics Player Preview channel, a Play or Close operation performed from the 
Graphics Player  is applied to the 14 graphic. 

 

When multiple graphics are in the Graphics Player Program and/or Preview channel, a 
dropdown arrow appears next to Preview and/or Program in the Graphics Player interface. 

 

​
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Selecting a graphic does not change the state of the graphics in the Graphics Player Program 
or Preview channel. It changes the target of the next Play, Stop or Close operation, as 
performed directly from the Graphics Player. 

To select a different graphic: 

1.​ In the Graphics Player Preview or Program channel, click “Preview” or “Program,” 
respectively. The channel’s drop-down displays. The following shows graphic 11 
thumbnail in the the Program drop-down: 

 

2.​ Select the desired graphic. In this exercise, select L3 - Live Bug. 

 
​
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The Graphics Player Program channel thumbnail now displays L3 - Live Bug.  

 

Following is an example of a list of graphics in the Graphics Player Preview channel: 

 

​
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Play Graphics via Drag and Drop 
You can play one or more graphics by dragging the graphics directly into the Graphics Player 
Program channel. 

To play a graphic: 

1.​ From the Scenes Browser, drag the desired graphic from the Scenes Browser to the 
Graphics Player monitor, until the Graphics Player monitor and the Program transport 
controls are highlighted. 

 

If the Graphics Program channel and Preview channel monitors are separate, then 
drag the graphic into the Program channel monitor. 
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2.​ Release the mouse/touchpad select button. The graphic loads and immediately plays. 
The graphic’s thumbnail appears to the right of the Stop button, along with the 
graphic’s title and type. 

 

3.​ To play additional graphics, repeat steps 1 and 2. Depending on the logic built into a 
graphic, playing a new graphic may transition one or more previous graphics off screen, 
or they may play simultaneously. 
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Load Graphics Using Drag and Drop 
You can load one or more graphics into the Graphics Player Preview channel, and can then 
trigger the graphic to play to the Graphics Player Program channel. 

To load a graphic to Preview from the Scenes or Messages Browser: 

1.​ From the Scenes or Messages Browser, do one of the following: 

○​ Drag the desired graphic into the Preview channel row until the Preview 
channel row is highlighted. 

 

○​ If the Graphics Program channel and Preview channel monitors are separate, 
then drag the graphic into the Preview channel monitor. 

​
 

351 | PRIME 5.3 Switcher User Guide​
​
 



2.​ Release the mouse/touchpad select button. The graphic is cued. The graphic’s 
thumbnail appears next to “Preview.” 

 

To load additional graphics, repeat steps 1 and 2. 

​
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Load Graphics Using the Keypad/Recall Area 

To load a graphic using the Keypad: 

1.​ If the Graphics Player button is already selected in the Recall Area or the Keypad, 
then proceed to the next step. If the Graphics Player button is not already selected, 
then click the desired button. The Recall Area reflects the selection. The following 
figures show Graphics 1 selected on the Keypad and in the Recall Area: 

 

 

2.​ Do one of the following: 

○​ On the Keypad, enter the ID of the graphic to be displayed. This method works 
only for numeric IDs. 

○​ Click NEXT or PREV until the ID clip to be displayed appears in the Recall Box. 
This method works for both numeric and alphanumeric IDs. 

○​ Enter the ID from a physical keypad or keyboard by clicking the Recall Box, and 
then entering the ID. 

3.​ Do one of the following: 

○​ Press Enter. 

○​ On the Keypad, click LOAD. 

The graphic loads into the Graphics Player Preview channel, and the ID in the Recall 
Box advances to the next available ID. 

4.​ To load additional graphics, do one of the following: 

○​ If you are loading a graphic that is out of numerical/alphabetical order in the 
Scenes or Messages Browser, then repeat steps 2 and 3. 

○​ If you are loading graphics in numerical/alphabetical order in the Scenes or 
Messages Browser, then repeat step 3. 
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Load Graphics via the Scenes or Messages Browser Context Menu 
To load a graphic into the selected Graphics Player from the Scenes or Messages Browser 
context menu: 

1.​ In the Scenes or Messages Browser, right-click the graphic’s thumbnail. The graphic’s 
context menu appears: 

 

2.​ Click the Cue icon. 

3.​ To load additional graphics, repeat steps 1 and 2. 

Play Graphics from the Graphics Player Preview Channel 
To play a graphic that is in the Graphics Player Preview channel: 

1.​ Do one of the following: 

○​ If the thumbnail of the graphic that you would like to play is displayed in the 
Graphics Player Preview channel, then proceed to step 2. 

○​ If the graphic that you would like to play is not displayed in the Graphics Player 
Preview channel, then in the Graphics Player Preview dropdown list, select the 
graphic to be stopped. 

2.​ Click the Play icon  in the Graphics Player Preview transport controls. The 
graphic immediately transitions to Graphics Player Program applying the Effect In set 
in the graphic and starts to play. 

3.​ To play additional graphics, repeat steps 1 and 2. Depending on the logic built into a 
graphic, playing a new graphic may transition one or more current graphics off screen, 
or they may play simultaneously. 
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Play Graphics Using the Keypad 
To play a graphic using the Keypad: 

1.​ If the Graphics Player button is already selected in the Recall Area or the Keypad, 
then proceed to the next step. If the Graphics Player button is not already selected, 
then click the desired button. The Recall Area reflects the selection. The following 
figures show Graphics 1 selected on the Keypad and in the Recall Area: 

 

 

2.​ If the Recall Box already displays the ID of the graphic to play, then proceed to step 3. 
If not, then do one of the following: 

○​ On the Keypad, enter the ID of the graphic to be displayed. This method works 
only for numeric IDs. 

○​ Click NEXT or PREV until the ID clip to be displayed appears in the Recall Box. 
This method works for both numeric and alphanumeric IDs. 

○​ Enter the ID from a physical keypad or keyboard by clicking the Recall Box, and 
then entering the ID. 

3.​ On the Keypad, click PLAY. The graphic plays. 

4.​ To play additional graphics, repeat steps 2 and 3. Depending on the logic built into a 
graphic, playing a new graphic may transition one or more current graphics off screen, 
or they may play simultaneously. 
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Play a Graphic via the Scenes or Messages Browser Context Menu 
To play a graphic from the selected Scenes or Messages Browser context menu: 

1.​ In the Scenes or Messages Browser, right-click the graphic’s thumbnail. The graphic’s 
context menu appears: 

 

2.​ Click the Play icon. 

3.​ To play additional graphics, repeat steps 1 and 2. Depending on the logic built into a 
graphic, playing a new graphic may transition one or more current graphics off screen, 
or they may play simultaneously. 

Play Graphics from the Keypad/Recall Area without Loading Graphics  
You can play a graphic or an unordered or ordered sequence of graphics from the 
Keypad/Recall Area without loading the graphics into Graphics Player Preview. An ordered 
sequence is based on the numerical/alphabetical order of the graphics in the Browser. 

1.​ In the Keypad or Recall Area, click the Graphics 1 or Graphics 2 button. 

2.​ Press DEL to clear the Recall Box. 

3.​ Do one of the following: 

○​ On the Keypad, enter the ID of the first graphic to be displayed. This method 
works only for numeric IDs. 

○​ Click NEXT or PREV until the ID clip to be displayed appears in the Recall Box. 
This method works for both numeric and alphanumeric IDs. 

○​ Click the Recall Box and enter the ID. 

4.​ Click PLAY. The graphic whose ID is displayed in the Recall Box plays. 

5.​ Click NEXT, then PLAY. The next graphic in the sequence plays. 

6.​ To play each subsequent graphic in the sequence, repeat step 5. 
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Note the following: 

●​ Try this method prior to going on air. Depending upon the logic built into the graphics, 
they may behave differently from described above, e.g., playing a new graphic may 
transition one or more current graphics off screen, or they may play simultaneously. 

●​ When playing messages in this manner: 

○​ No new thumbnail displays in the Graphics Player Preview channel. 

○​ The thumbnail already in the Graphics Player Program channel does not 
update as each message is played. 

●​ When playing scenes in this manner: 

○​ No new thumbnail displays in the Graphics Player Preview channel. 

○​ The thumbnail in the Graphics Player Program channel updates as each scene 
is played. 

​
 

357 | PRIME 5.3 Switcher User Guide​
​
 



Stop: Apply Effect Out and Transfer to Graphics Player Preview 
Stop Overview 
The Stop operation transitions the graphic off the Graphics Player Program channel using the 
graphic’s Effect Out and transfers it to the Graphics Player Preview channel. It can then be 
played again to the Graphics Player Program channel. 

Stop a Graphic from the Graphics Player  
To stop a graphic from the Graphic Player’s Program Channel: 

●​ Do one of the following: 

○​ If the thumbnail of the graphic that you would like to stop is displayed in the 
Graphics Player Program channel, then proceed to step 2. 

○​ If the thumbnail of the graphic that you would like to stop is not displayed in the 
Graphics Player Program channel, then in the Graphics Player Preview 
dropdown list, select the graphic to be stopped. 

●​ In the Graphics Player, click the Stop icon . The graphic transitions to Preview, 
applying the Effect Out set in the graphic. 

Stop a Graphic via the Scenes or Messages Browser Context Menu 
To stop a graphic in the selected Graphics Player, from the Scenes or Messages Browser 
context menu: 

3.​ In the Scenes or Messages Browser, right-click the graphic’s thumbnail. The graphic’s 
context menu appears: 

 

4.​ Click the Stop icon. 
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Close: Apply Effect Out, Do Not Transfer to Preview Channel 
The Close operation removes a graphic from either the Graphics Player Program or Preview 
channel, depending upon the channel in which the Close operation is performed: 

●​ If performed in the Graphics Player Program channel, transitions the graphic whose 
thumbnail is displayed off the Graphics Player Program channel, applying the 
graphic’s Effect Out. Unlike the Stop operation, the Close operation does not transfer 
the graphic to the Graphics Player Preview channel. 

●​ If performed in the Graphics Player Preview channel, removes the graphic whose 
thumbnail is displayed from the Graphics Player Preview channel. 

To transition a graphic off the Graphics Player Program channel or remove the graphic from 
the Graphics Player Preview channel: 

1.​ Do one of the following: 

○​ If the thumbnail of the graphic that you would like to transition off (Graphics 
Player Program channel) or remove (Graphics Player Preview channel) is 
displayed in the respective channel control, then proceed to step 2. 

○​ If the thumbnail of the graphic that you would like to transition off/remove is not 
displayed in the Graphics Player Program or Preview channel control, then 
from the channel’s dropdown list, select the graphic to be closed. 

2.​ Click the Close icon in the channel. The following shows the Close icon unhighlighted 
and highlighted when the mouse hovers over the icon. 

  

The graphic is removed. 
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Clear: Remove Graphic Using a Cut 
Clear Graphic Overview 
The Clear operation removes a graphic from either the Graphics Player Program or Preview 
channel, depending upon the channel in which the Close operation is performed: 

●​ If performed in the Graphics Player Program channel, removes the graphic whose 
thumbnail is displayed off the Graphics Player Program channel. The graphic’s 
transition is not applied and cuts off of the Graphics Player Program channel. 

●​ If performed in the Graphics Player Preview channel, removes the graphic whose 
thumbnail is displayed from the Graphics Player Preview channel. 

Clear a Graphic via the Scenes or Messages Browser 
To clear a graphic from the selected Graphics Player, from the Scenes or Messages Browser 
context menu: 

1.​ In the Scenes or Messages Browser, right-click the graphic’s thumbnail. The graphic’s 
context menu appears: 

 

2.​ Click the Clear icon. 

  
Clear a Graphic Using the Keypad 
To clear a graphic from a Graphics Player using the Keypad: 

1.​ Click the Graphics Player from which you would like to clear a graphic, click the 
Graphics Player button. If the button is already selected, then proceed to the next step. 

2.​ Click CLEAR. The following occurs, depending upon the Graphics Player 
configuration: 

○​ If the Graphics Player Preview Channel and Graphics Player Program 
Channel display on their own Graphics Player monitors, then with each CLEAR 
click, the a scene clears from the last selected channel as follows: 

■​ If the last selected Graphics Player channel is Graphic Player Preview, 
then the most recently loaded scene clears. 
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■​ If the last selected Graphics Player channel is Graphic Player Program, 
then the currently active scene clears. 

○​ If the Graphics Player Preview Channel and Graphics Player Program 
Channel share the same Graphics Player monitor, then: 

■​ If there are one or more graphics in the Graphics Player Preview 
channel, then with each CLEAR click, the most recently loaded scene 
clears from the Graphics Player Preview channel. 

■​ Once all graphics are cleared from the Graphics Player Preview 
channel, then with each CLEAR button click, the currently active scene 
clears from the Graphics Player Program channel. 

Delete Graphics ID from the Recall Box 
To clear the Recall Box in the Recall Area, do one of the following: 

●​ In the Recall Box, erase the ID. 

●​ On the Keypad, click DEL. 

The Graphic Plays, but Does Not Display in Switcher Program or 
Preview  
For a graphic to appear on the switcher Preview or Program channel, you must do one of the 
following: 

●​ Select the Graphics Player as a KEY source for the Main Bank Preset or Program 
bus, respectively. 

●​ Select the Graphics Player as a KEY source for the ME1 Bank Program bus, and 
select ME1 as a source for the Main Bank Preset or Program bus, respectively. 

●​ Select the Graphics Player as a source for the Main Bank Preset or Program bus, 
respectively. 

●​ Select the Graphics Player as a source for the ME1 Bank Program bus, and select 
ME1 as a source for the Main Bank Preset or Program bus, respectively. 

Otherwise, the graphic plays only in the Graphics Player. 
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The Graphic Plays, but Does Not Display in Switcher Program or 
Preview 
If a graphic(s) is playing, and does not transition to switcher Program, then ensure that the 
Graphics Player is associated with a Key, and that the Key is active in the Transitions Area, 
i.e., the Key button is lit. 

For example, if you would like Graphics 1 to transition as a source for Key 1, then you must 
associate it with Key 1. To specify that it should transition, then you must activate the Key 1 
button in the Transition Area. 

See Set Transition Area, Set a Key Source, and Tying Together the Transition Area, Key Bus and 
Downstream Keyer for additional details. 

Graphics Playback via PRIME Playlist and PRIME 
Commander 
In addition to direct playout from the Graphics Player(s), Keypad, Recall Area, and 
Scenes/Message Browsers: 

3.​ The PRIME Playlist can trigger graphics playback from within PRIME Switcher. 

4.​ Chyron PRIME Commander, an optional PRIME Live Platform control interface, can 
trigger graphics playback. See the PRIME Commander User Guide for additional 
information.  
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Chapter 17: PRIME Playlist Graphics and​
Clip Playback within PRIME Switcher 

Overview 
PRIME Switcher can play back scenes, messages, images, and clips from a PRIME Playlist. 
The PRIME playlist plays within the PRIME Playlist Player. 

Playlist Players are configured in the Config Menu > Playout Configuration > Playlists. You 
can add Playlist Players, and specify if they should auto-advance to the next playlist item after 
an item is played. The name of any Playlist Player that is configured in the currently active 
PRIME configuration displays in the View menu. See Configure Playlist Players for additional 
information. 

The playlists display in the View menu, between the CLP (Clips) and GFX (Graphics) Players: 

 

​
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Display Playlist Player 
To display a Playlist Player: 

●​ From the View menu, check the desired playlist. The Playlist Player opens. The 
Playlist Player may initially display along the bottom of the PRIME Switcher UI. 

You can simultaneously display multiple playlists. This could be advantageous for displaying 
different playlists by program segment, or for displaying separate playlists for different types of 
graphics and clips. 

The following figure shows a blank Playlist Player. Note that if you would like to see more of 
the playlist, then you can move it to a different location and resize it for easier viewing. 

 

Playout Modes 
Each Playlist Player provides two playout modes: 

●​ Take List Mode: You can add/delete/modify playlist items at any time, and play the 
playlist in any order. 

●​ Sequence Mode: The playlist operates as sequencer. Items can have pauses and play 
in a linear fashion. You can set a pause for one or more playlist items. 

The icon to the left of the Playlist Name specifies the currently active mode. 

 
Take List Mode 

 
Sequence Mode 

​
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To select a playout mode: 

1.​ In the Playlist Player toolbar, click the playlist Name. The Playout Mode dropdown 
appears: 

 

2.​ Select the playout mode. 

The following figure shows an example of a playlist in Take List Mode. Note the Take List 

Mode icon  to the left of the Playlist Name. 

 

​
 

365 | PRIME 5.3 Switcher User Guide​
​
 



The following figure shows an example of a playlist in Sequence Mode. Note the Sequence 

Mode icon  to the left of the Playlist Name. 

 

Playlist Player in Detail 
The Playlist Player provides many tools with which to customize playout. The Take List Mode 
and Sequence Mode interfaces feature most of the same tools, with a few differences, noted 
as follows: 

Playlist Player toolbar: 

●​ Playlist Player Name: Name of the Playlist Player. 
●​ Mode: 

○​  Take List Mode: Indicates Take List Mode. 

○​  Sequence Mode: Indicates Sequence Mode. 

●​ Playlist Name: Name of the playlist. 

●​  New Playlist: Creates new playlist. 

●​  Open Playlist: Displays browser, from which you can select and open a playlist. 

●​  Save/Save As: 
○​ Save saves changes to the currently loaded playlist. 
○​ Save As saves current playlist to a different/new playlist file. 

●​  Auto Advance (Take List Mode Only): Automatically advances to the 
next item in the playlist, after the current item has been triggered. 
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●​  Play (Sequence Mode Only): Starts sequence playout. Is grayed out while 
the playlist is playing. 

●​  Trigger (Sequence Mode Only): Triggers the next item in the playlist. This may be 
an effect within a scene or message, or the next item in the list. When active, the 
Trigger icon displays in the same space on the toolbar as the Play icon. 

●​  Stop (Sequence Mode Only): Stops sequence playout, transitioning the 
graphic(s)/clips off air. Is grayed out while inactive. 

●​  Loop: (Sequence Mode Only): Loops sequence playout. Displays gray 
background when active, black background when inactive.. 

●​  Recall Box: Provides the ability to enter an ID number to recall and load an 
item into the Playlist Player. 

●​  Comment: Inserts a text line above the currently selected item in the 
playlist, in which you can enter a comment. The comment is strictly informational, and 
does not play. 

●​  Remove: Removes the item from the playlist. 

●​  Dropdown Arrow: Accesses Playlist Appearance settings, and provides the ability 
to close the Playlist Player. 

Playlist Player columns: 

●​  Information: Indicates the status of the playlist items, e.g., loaded in Graphics 
Player Preview. 

○​  Pause: Displays when waiting for a trigger, and when the item has 
completed playout. 

○​  Play: Item currently playing. 

○​  Cued: Playlist item is in Graphics Player Preview or Clip Player Cued.  

○​  Disabled: Skip item in playlist. 

●​  Pause before Play (Sequence Only): A playlist item marked with a Pause before 

Play icon waits for a trigger  prior to playing. 

●​  Duration (Sequence Only): The duration of an item marked with a Duration icon 
can be modified. 
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●​ ID: The number that is used to play the item to air. If the scene, message, image, or clip 
does not have a Message ID associated with it, then the playlist assigns the next 
available ID. IDs are assigned from the PRIME Scene Property Editor, or from Edit 
Message, available from the PRIME Switcher Assets Browser. 

●​ Name: Name of the playlist item. 
●​ Channel: Channel to which the item plays out. You can change the playout Channel. 
●​ Layer: Layer within the Channel to which the item plays out. You can change the 

playout Layer. 
●​ Transition (Clips/Images Only): Transition Effect (if any) to be applied to the clip or 

image as it transitions on screen. You can change or remove the Transition Effect. 
●​ Status: Displays the duration of the current effect in a scene or message, e.g., an 

Effect In, and the progress bar of the playout of the current item. 
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Edit Playlist Appearance 
You can control how the playlist displays the various states of the playlist items. To access the 
settings: 

●​ In the playlist toolbar, click the dropdown arrow at the far right . The Edit Playlist 
Appearance dialog displays. 

 

●​ Set the fonts and colors as desired. 

○​ To set colors that are different from the Theme Colors and/or Draw System 
Selection colors, disable their respective checkboxes, and then set font and 
colors as desired. 

○​ The Theme colors include all settings except Selected Color and Hot Color. To 
set to Theme colors, select (check) the Use Theme Colors checkbox. 

○​ The Draw System Selection settings include Selected Color and Hot Color. 
To set to Draw System Selection colors, select (check) the Use Theme Colors 
checkbox. 
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Note that if a playlist item is selected, or the cursor is hovered over a playlist item, then the 
playlist item displays the selection color. As the Selected Color and Hot Color are transparent, 
the underlying color also shows through. 

Create New Playlist 
To create a new playlist: 

1.​ In the toolbar, click the New Playlist icon . A blank Playlist Player appears. 
2.​ From the PRIME Switcher Scenes, Messages, Images and Clips browsers, drag the 

item’s thumbnail from the browser into the playlist. 
3.​ Repeat step 2 to build the playlist. 

Load Existing Playlist 
To load an existing playlist into a Playlist Player, do one of the following: 

●​ Open the Playlists Browser, and then drag the desired playlist to the Playlist Player. 

●​ Click the Open Playlist icon , and then browse to and select the desired playlist 
file. 

The playlist loads into the Playlist Player. 

You can drag items from the PRIME Switcher Assets Browser into an existing playlist. 

Reposition a Playlist Item 
To reposition a playlist item, i.e., move it up or down in the playlist: 

●​ Drag and drop it to the new position. 
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Add Comment to Playlist 
You may like to add a comment, e.g., a description, to an upcoming item on the playlist. The 
comment is strictly informational, and does not play. To add: 

1.​ Select the playlist item to which you would like to add the comment. 

2.​ In the playlist toolbar, click the Comment icon . A row appears above the 
selected item. 

3.​ Type the text in the comment field, and then press Enter. 

 

​
 

371 | PRIME 5.3 Switcher User Guide​
​
 



Override Scene/Message Replaceables and Play Transitions 
You can view and edit a scene or message that has replaceable text, image, and clip fields, and 
specify transitions. For example, you can change the text in a field, or transition in/out a graphic 
element. 

To modify a scene or message: 

●​ Select the scene/message, and then click the arrow directly to the left of its Name. 

 

The modifiable elements display. 

​
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The following figures display message 10 in the playlist, expanded to display the elements, and 
the same message on screen: 

 

 

​
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Suppose that you would like to add a middle initial to Joseph Biden’s name. To edit the text 
field: 

●​ Click the Status field, and then edit the name. 

 

The change is reflected in the graphic upon playout: 
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The checkboxes in the playlist indicate available transitions. To enable the transition: 

●​ Check the transition’s checkbox. The following playlist shows the Top Bar (Live) 
transition activated. 

 

The Top Bar (Live) transitions on screen: 
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In scenes and messages that have replaceable images and/or movies, you can modify them, 
as well. For example to override an image: 

1.​ Click on the link to the image to open the browser. 

 

 

2.​ Select the desired image, and then click OK. 
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Disable/Enable Playlist Item 
You can disable an item in the playlist, without removing it. When an item is disabled, it is 
grayed out. To disable playout of an item: 

●​ Select the item, and then click the Information field  for the item. Make sure that 
you click within the Information field, and not in the fields to the right of the 
Information field. 

○​ If the Information field is blank, then the Disabled icon  appears, and the 
playlist item grays out. 

○​ If the Information field already displays a Cued icon , then the Disabled 
icon does not appear. The playlist item grays out. 

To re-enable playout: 

●​ Select the item, and then click the Information field  for the item. Make sure that 
you click within the Information field, and not in the fields to the right of the 
Information field. 

○​ If the Information field displayed the Disabled icon , then it disappears, and 
the playlist item is no longer grayed out. 

○​ If the Information field displayed a Cued icon , then the Cued icon 
continues to display, and the playlist item is no longer grayed out. 

Delete Item from the Playlist 
To delete an item from a playlist, do one of the following: 

●​ Select the item, and then press Delete. 

●​ Select the item, and then click . The item is removed from the playlist. 

Note that if Remove is grayed out in the toolbar , it indicates that the selected item 
cannot be removed at that time. The item may be in a Play or Pause mode. 

​
 

377 | PRIME 5.3 Switcher User Guide​
​
 



Play the Playlist 
You can play the playlist in either Take List Mode or Sequence Mode. Multiple messages can 
play simultaneously. 

Sequence Mode 
If in Sequence Mode: 

1.​ In the playlist toolbar, click the Play icon  or press Enter to start playlist playout. The 
playlist automatically plays through the items in the list. Notice that the Play icon 

becomes gray , and the Stop icon  becomes red. 

 

2.​ When the Trigger icon  appears in the Playlist Player toolbar, it indicates that the 
Playlist Player is waiting for an item or an effect within an item trigger. Click the Trigger 
icon to play. The item plays and the playlist displays a green highlight. 

 

If the item is a scene that has multiple transitions, e.g., bullet reveals, then the playlist item 
flashes, and displays a message Waiting for Trigger. 

●​ In the playlist toolbar, click the Trigger icon  or press Enter to trigger each 
transition. 

You can set items to pause before playing. See Set Pause before Play for an Item. 
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Set Pause before Play for an Item 
In Sequence Mode, the playlist automatically advances and plays each item. To require a 
trigger to play and item: 

●​ Click the Playlist Pause before Play field for the item.  

 

The Pause before Play icon appears. 

 

When playlist playout reaches this item, the playlist will pause until you trigger the item.  

To disable Pause before Play: 

●​ Click the Playlist Pause before Play icon for the item. The Pause before Play icon 
disappears, and when playlist playout reaches the item, the item plays automatically. 
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Take List Mode 
If in Take List Mode: 

●​ Click the item that you would like to play, end then press Enter. 

 

If the item is a scene that has multiple transitions, e.g., bullet reveals, then the playlist item 
flashes. 

●​ Press Enter to trigger each transition, and to trigger subsequent playlist items. 

In Take List Mode, you can set a playlist to automatically advance to the next item in the list, 
as the current item plays. The next item is then ready to trigger. To set: 

●​ In the Playlist Player toolbar, click Auto Advance . The Auto Advance 

tool displays a gray background when active . 

To disable Auto Advance: 

●​ In the Playlist Player toolbar, click Auto Advance. 
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Playlist Playout State 

The playlist highlights items based on their playout status, in the colors as set in the Edit 

Playlist Appearance dialog. As the playlist plays, the Information column  also displays 
icons that specify playout status.  

●​  Currently Playing: The item is currently playing. Note that if the scene/message 
has multiple effects, then the progress bar shows the status of the current effect. If the 
playlist item is flashing, then it is waiting for a trigger. 

●​  Cued: Playlist item is in Graphics Player Preview or Clip Player Cued.  

●​  Paused: Displays when waiting for a trigger, and when the item has completed 
playout. If the playlist item is flashing, then it is waiting for a trigger. 

●​  Disabled: The item is disabled, and is skipped during playlist playout. 

The Status displays the duration of the current effect in a scene or message, e.g., an Effect In, 
and the progress bar of the playout of the entire scene/message. 

The left side of the Status column displays the duration of the current effect in a scene or 
message, e.g., an Effect In. 

The right side of the Status column displays one of the following: 

●​ The progress bar of the playout of the entire scene/message. 
●​ Loading message. 
●​ Waiting for Trigger message. 

Set Duration 
To modify the duration of an item: 

●​ If in Take List Mode, then in the Status field for the item, enter the duration or use the 
spin box to set the duration. 
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●​ If in Sequence Mode: 

1.​ Directly to the left of the item name, click the Duration field. 

 

2.​ The Duration icon appears. 

 

3.​ In the Status field for the item, enter the duration, then press Enter or click 
outside of the field. 

 

When the Duration icon is present, you can edit the image duration. When the Duration icon is 
not present, then you cannot edit the duration. 

Stop a Playlist (Sequence Mode Only) 
To stop Sequence Mode playlist playout: 

●​ In the playlist toolbar, click the Stop  icon. 
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Loop the Playlist (Sequence Mode Only) 
A playlist in Sequence Mode can loop. To loop a playlist: 

●​ In the playlist toolbar, click the Loop icon . 

When active, the Loop icon displays a gray background . After the last transition in the last 
item in the playlist starts to play, then the playlist cursor moves to the first item in the playlist. 

Change Playout Channel 
To change the playout Channel of a playlist item: 

●​ Click the item in the playlist, and then from the dropdown menu, select the desired 
Channel. 

Change Playout Layer 
To change the playout Layer of a playlist item: 

●​ Click the item in the playlist, and then do one of the following: 

○​ Enter the Layer number in the Layer field. 
○​ Use the Layer spin box to set the Layer number. 

Change Clip/Image Transition Effect 
To change the Transition Effect of a clip or image in the playlist: 

●​ Click the item‘s Transition field in the playlist, and then from the Clip Transitions \ 
Common dialog, select the desired Transition Effect. 

To change the Transition Effect to None: 

●​ Click the item‘s Transition field in the playlist, and then from the Clip Transitions \ 
Common dialog, click Deselect. 

Clear Playlist 
To clear the playlist of all items: 

●​ In the toolbar, click the New icon . 
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Close Playlist Player 
To close the Playlist Player, do one of the following: 

●​ Click the Playlist Player window Close icon (x) at the upper right corner. 

●​ In the Playlist Player toolbar, click the dropdown arrow  at the far right of the 
Playlist Player, and then select Close. The Playlist Player closes. 

Closing the Playlist Player does not remove it from current PRIME Switcher configuration. To 
reopen the Playlist Player: 

●​ From the PRIME Switcher View menu, select (check) the Playlist Player to enable 
visibility. 

 

​
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Chapter 18: Create a PRIME DVE Scene 
In addition to the DVEs provided within PRIME Switcher, you can create complex DVEs in 
PRIME Designer, enabling the flexibility to display complex effects that are not possible via a 
switcher. 

One of the most common DVEs is a multi-box (2-box, 3-box, 4-box, etc.), in which two or more 
people, e.g., an interviewer and guest(s), are each displayed in their own box. The following 
figure shows a 2-box DVE with input video. 

 

The following figure shows a 4-box DVE as it appears without input video. 

 

​
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Following is the general process for creating a multi-box graphic, and making it accessible to 
PRIME Switcher. It is assumed that the PRIME user has been trained prior to creating DVE 
graphics. For each video input region in the scene: 

1.​ In PRIME Designer, select Video Input in the Graphics Area of the Toolbox. 

 

​
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2.​ Add a Crop Effect to the Video Input region, and scale and position the Video Input. 

 

​
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Note that this scene shows two video input regions, with a pod behind each video input 
to act as a frame. The pod serves only an aesthetic purpose, and is not necessary to 
create a DVE scene. 

​
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3.​ Select the Video Input in the Objects Scene Tree, then in the Properties panel, select 
the desired Video Input from the Input list. 

 

4.​ After all video input regions have been configured, save the PRIME Scene (*.pbx file) to 
the Scenes folder that PRIME Switcher will access. The scene thumbnail should be 
visible in the Scenes folder of the PRIME Switcher Scenes Browser. 

5.​ Ensure that the specified input settings saved to the Scene file are configured in PRIME 
Switcher. For example, if the leftmost box in a 2-box is set to display Video Input 2 in 
Video In Left, then make sure that the correct source is feeding Video Input 2 of the 
PRIME Switcher. 
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To verify that a video source(s) is correct: 

●​ In PRIME Switcher UI, drag the scene from the Scenes Browser into a PRIME Switcher 
graphics player. The source(s) display in the Video Input region(s). 

A typical switcher configuration employs the ME1 bank. Through replaceables, scripting and 
conditions, the video feed can be linked to ME1. 

The following PRIME Switcher UI shows the following Mix Effects setup: 

●​ DVE 2-Box scene is in ME1 Bank GFX1. 
●​ CAM2 is the input to the left box. 
●​ CAM4 is the input to the right box. 
●​ ME1 Bank Program Bus is set to CLP1. 
●​ ME1 Bank Key Bus is set to GFX1. 
●​ Main Bank Program Bus is set to ME1. 
●​ Main Bank Preset Bus is set to CAM1. 

 

​
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If a live video region in a graphic either displays no video or the incorrect video source, then 
ensure that the PRIME Switcher source(s) is the Video Input(s) intended for the Video Input(s) 
specified in the PRIME DVE scene. If they are not, then you can change the Video Input(s) in 
the PRIME Scene, via the Scene Editor. See Scenes Browser and Scene Edit Functions for 
additional information. 
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Chapter 19: Work with Audio 

Overview 
PRIME Switcher’s audio mixer provides the ability to mix embedded audio from video sources. 
Audio sources are configured in the Switcher Configuration Audio Panel. See Configure 
Audio Channels for details on how to configure audio. 

All inputs that have embedded audio are supported. 

Audio Controls 

Overview 
As in a hardware audio mixer, PRIME Switcher Audio Mixer’s Audio Faders control the audio 
source levels, as well as the Master audio level for the entire Audio Mixer. You can 
mute/unmute an audio channel, and set an audio channel to follow one or more video sources.  

PRIME Switcher provides the ability to create Auxiliary Audio Buses, enabling the creation of 
custom Mix Minus outputs. An Audio Mixer with Auxiliary Audio Buses displays an 
additional column of buttons at the left of the Audio Faders, as shown in the following figure. If 
no Auxiliary Audio Buses are configured, then these buttons do not appear. Only the Main 
Bus appears, with no MAIN Bus button at the left. 

 

​
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The Follow Video button associated with each Audio Fader is replaced by a PRE button  
that is not yet operational. 

See Configure Audio Buses - Mix Minus, Pre Fade Listen for additional information about 
Auxiliary Audio Bus configuration. 

Change Audio Level 
The audio level for each source can be individually set and dynamically changed. An audio bus 
displays two sets of levels: 

●​ Source Level (displays in gray): Source Audio level. 
●​ Audio Bus Level (displays in green): Audio level as set in the Audio Bus. When the 

Audio Bus is set to the maximum level, it matches the Source Audio level, and only the 
green is visible. 

If source audio is: 

●​ Mono, then the bus displays one audio level. 
●​ Stereo, then the bus displays two levels. 
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To set/adjust audio level: 

●​ Drag the fader to the desired level. The level can be adjusted live while the video is in 
Program. The Digital VU Meter reflects the fader setting, in decibels (dB). If the 
channel is muted, then the Digital VU Meter continues to display the source level (in 
gray), although the channel is muted. 

Display Audio Bus and Set Level(s) 

In an Audio Mixer that has one or more Auxiliary Buses, you can set custom mixes, i.e., Mix 
Minus. To display and set a specific Audio Bus: 

1.​ Click the button of the Audio Bus that you would like to display. 

2.​ Adjust the audio fader(s) to the desired level(s). 

 

You can change Auxiliary Bus fader levels at any time. 

Set Mute 
A muted channel does not output audio, regardless of the fader setting. You can set a level for 
a channel, and mute the channel until needed. 

To mute/unmute a channel: 

●​ Click the Mute button for the channel . When Mute is active, then the Mute button 

is red . 
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Set Delay 
If the audio output must be delayed in order to synchronize with the Program video output, 
then: 

●​ Click the Source Name, and then in the drop-down, then enter the value or use the 
spin box to set the appropriate Delay, in ms; otherwise, leave at 0. Range: 0 - 192 ms. 

 

Set Follow Video (MAIN Audio Bus Only) 
Follow Video vs. Follow Audio 
PRIME Switcher provides the ability to set audio to follow video, i.e., when a video source 
transitions to Program, then the audio input(s) set to follow that video source outputs at a 
preset level(s). 

PRIME Audio Director is a separate application that is included with PRIME Switcher, and that 
provides the ability to set video to follow audio input levels. You can create rules based on 
audio input levels, and, for example, automatically trigger a transition to the anchor camera, 
when the anchor speaks, or trigger a transition to a guest camera when the guest speaks, etc. 
Audio Director requires an ASIO-compatible audio card. See the PRIME Audio Director User 
Guide for information. 
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Set Follow Video 
Follow Video enables one or more audio sources to automatically output at the level(s) set in 
the Audio Mixer’s Main Audio Bus when a source set as a Follow Source transitions to 
Program. Once the source transitions off Program, then the audio input automatically mutes. 
The same applies to multiple sources with Follow Video enabled, that display simultaneously 
in Program (e.g., a 2-Box). 

For example, if CAM1 transitions to Program, then any audio input that has CAM1 specified as 
Follow Sources outputs at its preset level. For example: 

The following shows CAM1 in Program. 

 

CAM1 is set to follow CAM1. Note that the Master Fader is not shown in this and the 
following images in this section. 

 

​
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CAM4 is set to follow CAM1. As CAM1 is Program, then as shown in the following, 
CAM1 and CAM4 output audio at their preset levels. 

 

Note that as CAM4 is not set to follow itself, then if CAM4 transitions to Program, 
CAM4’s audio is not automatically raised, and must be manually raised. 

To set the audio for a Source to follow the video that is in Program: 

●​ Set the audio input to the level that will be used during the show. 

●​ Do one of the following: 

○​ Click the Follow Video button  for the audio input. When Follow Video is 

enabled, then the Follow Video button is blue . 

○​ Click the Source Name, and then select Follow Video from the menu. 

​
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The Follow Video item displays a checkmark. 

 

●​ Click Follow Sources, and then select the source(s) that you would like the Audio 
Input to follow. In this example, the Source follows itself. 

 

​
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You can select multiple Follow Video sources. For example, if you set: 

○​ CAM1’s Follow Source to CAM1, CAM3, and CAM4; 

○​ CAM3’s Follow Source to CAM3; and 

○​ CAM4’s Follow Source to CAM4; 

then: 

○​ Whenever CAM1 transitions to Program, CAM1’s audio outputs at the preset 
level. 

○​ Whenever CAM3 transitions to Program, then CAM1’s and CAM3’s audio  
outputs at the preset levels. 

○​ Whenever CAM4 transitions to Program, then CAM1’s and CAM4’s audio  
outputs at the preset levels. 

Remove a Follow Video Source 

To remove a Follow Video source: 

1.​ Click the source name of the fader of the source that you would like to set, then click 
Follow Sources. The sources are listed in the submenu. 

2.​ Select the source that you would like to remove. The check no longer appears next to 
the source name. 

3.​ Repeat steps 1 and 2 to remove each additional source. 

Disable Follow Video 
●​ Do one of the following: 

○​ Click the Follow Video button  for the audio input. When Follow Video is 

disabled, then the Follow Video button is gray . 

○​ Click the Source Name, and then select Follow Video from the menu. The 
Follow Video item no longer displays a checkmark. 

 

 

​
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Chapter 20: Keyboard Shortcut Manager 

Overview 
You can operate PRIME Switcher using the mouse, touchpad, keyboard, or a combination of all 
three. PRIME Switcher provides the ability to set, add, load, and save Keyboard Shortcuts. 
keyboard shortcuts. 

To access Keyboard Shortcuts configuration: 

●​ Go to Config Menu > Keyboard Shortcut Manager. The Edit Shortcut Keys Global 
settings dialog appears. From this dialog, you can also edit the Component and 
Scripts shortcut keys. 

WARNING: If you have created keyboard shortcuts, then prior to going on air, test 
operation to ensure that there are no inadvertent keystroke conflicts! Also note that 
numeric keypad numbers may be interpreted differently from the numbers in the top 
row of your keyboard. 
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There are three categories of functions: 

●​ Global 
●​ Component 
●​ Scripts 

Global Keyboard Shortcuts can change the focus (active component), play, and read 
graphics, and activate clips. 
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Component Keyboard Shortcuts can play and Read Next Scene, Play Previous Scene, 
Clear Scene, and set shortcuts for Recall Box operations. Note that Select Recall Box 
selects the Graphics/Clips/Mix Effects Recall Box, not the Layout Recall dropdown. 

 

​
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Scripts Keyboard Shortcuts can invoke scripts. 

 

​
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Set a Keyboard Shortcut to an Existing Function 
To set a Keyboard Shortcut: 

1.​ Click the name of the category of functions for which you would like to set a Keyboard 
Shortcut: 

○​ Global 
○​ Component 
○​ Scripts 

2.​ Click the Keys field of the shortcut that you would like to set. 
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3.​ Press the key combination that you would like to assign to the function. 

 

If you attempt to assign a Shortcut Key that is already assigned, then an alert similar to 
the following appears: 

 

Select Yes to set a duplicate Shortcut Key, or No to close the alert and enter a different 
Keyboard Shortcut. 

CAUTION: If you set the same Keyboard Shortcut for more than one function, 
then make sure that they do not conflict with each other. 
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4.​ Press the Tab key or select Apply. 

 

5.​ If you would like to set additional Keyboard Shortcuts, then repeat steps 2 through 4. 
You can switch among Global, Component and Scripts categories. 

6.​ When Keyboard Shortcut assignment(s) is complete, click OK. 

Save a Set of Keyboard Shortcuts 
You can save and recall currently configured Keyboard Shortcuts for future use. 

To save the currently configured Keyboard Shortcuts: 

1.​ Click the Save icon at the top of the Edit Shortcut Keys panel. 

2.​ Browse to the desired folder, enter a filename, and then click Save. The file is saved to 
a *.psk PRIME Keyboard Shortcuts file. It is recommended that the Keyboard 
Shortcut file be saved to Common > Keyboard Shortcuts. 
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Load Set of Keyboard Shortcuts 
To load a Keyboard Shortcuts file: 

1.​ Click the Load icon at the top of the Edit Shortcut Keys panel. 

2.​ Browse to the desired file, and then click Open. 

Add a New Keyboard Shortcut File 
To create a new Keyboard Shortcut file in which to store settings. 

1.​ Click the New icon at the top of the Edit Shortcut Keys panel. 

2.​ Browse to the desired folder, enter a filename, and then click Save. The new *.psk 
PRIME Keyboard Shortcuts file is created. It is recommended that the Keyboard 
Shortcut file be saved to Common > Keyboard Shortcuts. 

3.​ Edit the file as desired. 

Clear Selected Keyboard Shortcut(s) 
To clear selected Keyboard Shortcuts, without affecting other Keyboard Shortcuts: 

1.​ In a Global, Component or Keyboard Shortcut List, select the Keyboard Shortcuts 
using one or more of the following methods: 

○​ Select Single Item: Click the item that you would like to clear. 

○​ Select Range: While holding down the Shift key, click the first item in the list 
that you would like to clear, then click the last item in the list that you would like 
to clear. You can also click the last item in the list that you would like to clear, 
and then the first item. 

○​ Select Non-adjacent Items: While holding the Ctrl key, select the items in the 
list that you would like to clear. 

2.​ Click the Clear Selected icon. The selected item(s) display None. 
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Reset Keyboard Shortcuts to Default 
To reset all Keyboard Shortcuts: 

●​ From the Reset to Defaults dropdown menu, select the desired keyboard: 

○​ Standard: QWERTY keyboard. 
○​ Classic: Chyron Black Keyboard. 
○​ Blank: All Keyboard Shortcuts are set to None. 

 

Keyboard Shortcut Troubleshooting 
If a keyboard shortcut does not work or performs an unexpected action, then: 

●​ Ensure that you correctly assigned the keyboard shortcut. 

●​ Ensure that it does not conflict with an existing keyboard shortcut. 

●​ Ensure that you are typing the correct keyboard shortcut. It must be typed exactly as it 
was entered when creating the keyboard shortcut. 
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Troubleshooting 

PRIME Switcher Interface 

Video Inputs, Clips and Graphics Are Frozen 

Upon startup, if the Video Inputs, Clips and Graphics are frozen, then you may have 
accidentally closed the PRIME Engine window. This window does not usually appear upon 
startup. If, however, a user had configured the Clean Feed to display in a Desktop Window for 
testing, then it will appear when the PRIME Switcher interface opens. 

 

If the PRIME Engine window appears on top of the PRIME Switcher interface when it opens, 
then do not close the window. To hide the PRIME Engine window while operating PRIME 
Switcher, do one of the following: 

●​ Click the PRIME Switcher interface outside of the PRIME Engine window; or, 

●​ Click the PRIME icon  in the taskbar at the bottom of the screen. 

If you closed the PRIME Engine window, and the Video Input, Clips and Graphics displays have 
frozen, then close and reopen PRIME Switcher, making sure not to close the PRIME Engine 
window. 

You can reconfigure the Clean Feed to a different output (typically SDI), or use PRIME Switcher 
as is. 

If the production is not using the Clean Feed, then disable or delete it. 
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Components Are Missing from the Switcher Interface 
If components are missing from the interface, and they are not present in the View menu, then 
ensure that the components are properly configured for use in PRIME Switcher: 

●​ Configure PRIME Video and Audio 
●​ Configure PRIME Switcher 
●​ Configure Sources 
●​ Configure Atlas 
●​ Configure Clip Players 
●​ Configure Transitions 
●​ Configure Playlist Players 
●​ Configure Audio Channels 

Also see Enable/Disable Component Display and Troubleshoot Configuration for additional 
details. 

A Component Tab Had Displayed, but Is Now Missing 
If a component tab had displayed, but is now not visible, then see How Do I Locate a Hidden 
Tab? 

The Interface Displays Multiple Tabs with the Same Name 
If the interface displays multiple tabs labeled with the same name, e.g., CAM2, then you may 
have assigned the same video channel to multiple PRIME Switcher Sources in Config > 
Playout Configuration > Switcher > Sources. 

Ensure that you do not assign the same Video Channel to more than one Source. 

Example: Do not assign Video Input 2 to CAM2 and to CAM3. 
 

I Need to Reset the Layout 
If you need to reset the layout, then see Reset Layout to Default. 
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PRIME Switcher Application Message 

Exception - Not Enough Space on the Disk 
While operating PRIME Switcher, the following message may appear: 

 

​
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This message indicates that the disk is too full to run PRIME Switcher. There are a wide variety 
of reasons that the disk could be full. 

One possible cause could be an accumulation of PRIME Engine or PRIME log files. If this is the 
case, then to remedy: 

1.​ Click OK or click the Close (x) icon. PRIME Switcher halts, and then closes. 

2.​ Via File Explorer, manually delete the log files: 

○​ PRIME log files are typically located at C:\Chyron\Prime\Logs. 

○​ PRIME Engine log files are typically located at C:\log\ChyronHego. 

3.​ Restart PRIME Switcher. 

To avoid future PRIME log file accumulation, you can set PRIME to limit log file size and to 
delete log files after a specified duration. See the PRIME User Guide for additional information. 

There is currently no method to specify maximum PRIME Engine log file size or to delete them 
after a specified duration.  

Search 

I Performed a Search, but There were No Results 
If there are no results after performing a search, then the browser displays as empty. If search 
results were expected, then confirm that the search parameters were correctly entered. 

See Search Assets Browser for additional details. 

Transitions 

Preview Video Does Not Transition to Program 
In the Transition Area, BKGD is not active (unlit). 

●​ Click BKGD to activate (lit). 

Preview Video Transitions to Program, When It Should Not 
In the Transition Area, BKGD is active (lit). 

●​ Click BKGD to deactivate (unlit). 
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Key Video Does Not Transition to Program​
In the Transition Area, the desired KEY is not active (unlit). 

●​ Click the desired KEY to activate (lit). 

Key Video Transitions to Program, When It Should Not​
In the Transition Area, the desired KEY is active (lit). 

●​ Click the desired KEY to deactivate (unlit). 

Graphics 1 and Graphics 2 Both Display in Program, or​
Both Display in Preview, When They Should Alternate 
Graphics 1 and Graphics 2 are not properly set up to alternate. 

●​ See Set up Graphics 1 on Program, and Graphics 2 on Preview. 

ME1 (Mix Effect) Output Does Not Display in Program or Preview 
ME1 is not selected as a PROGRAM or PREVIEW source in the Main Switcher Bank. 

●​ Select ME1 in the PROGRAM or PRESET bus. 

Graphics 

The Graphic(s) Plays, but Does Not Transition to Switcher Program or 
Preview 
If a graphic(s) is playing, and does not transition to switcher Program, then ensure that the 
Graphics Player is associated with a Key, and that the Key is active in the Transitions Area, 
i.e., the Key button is lit. 

For example, if you would like Graphics 1 to transition as a source for Key 1, then you must 
associate it with Key 1. To specify that it should transition, then you must activate the Key 1 
button in the Transition Area. 

See Set Transition Area, Set a Key Source, and Tying Together the Transition Area, Key Bus and 
Downstream Keyer for additional details. 

Clips 

The Clip Plays at the Incorrect Speed and/or Aspect Ratio 

The clip is not configured to match the resolution and frame rate at which PRIME Switcher is 
configured. 
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Ensure that clips have the same resolution and frame rate as PRIME Switcher configuration; 
otherwise, they may not play correctly. 

The Clip Plays, but Does Not Display in Switcher Program or Preview 

If a clip is playing but does not display as intended in the switcher Program or Preview, see 
The Clip Plays, but Does Not Display in Switcher Program or Preview. 

DVE 

The DVE Graphic Displays, but the Video Input(s) Is​
Missing or Incorrect 

If a live video region in a graphic either displays no video or the incorrect video source, then 
ensure that the PRIME Switcher source(s) is the Video Input(s) intended for the Video Input(s) 
specified in the PRIME DVE scene. If they are not, then you can change the Video Input(s) in 
the PRIME Scene, via the Scene Editor. 

See Create a Digital Video Effect for additional details. 

Keyboard Shortcuts 

Note about Keyboard Shortcuts 
If you have created keyboard shortcuts, then prior to going on air, test operation to ensure that 
there are no inadvertent keystroke conflicts! Also note that numeric keypad numbers may be 
interpreted differently from the numbers in the top row of your keyboard. 

See Keyboard Shortcut Manager for additional information on setting and using keyboard 
shortcuts. 

Keyboard Shortcut Does Not Work 
If a keyboard shortcut does not work, then: 

●​ Ensure that you correctly assigned the keyboard shortcut. 

●​ Ensure that you are typing the correct keyboard shortcut. It must be typed exactly as it 
was entered when creating the keyboard shortcut. 

Keyboard Shortcut Performs an Unexpected Action 
If a keyboard shortcut performs an unexpected action, then: 

●​ Ensure that it does not conflict with an existing keyboard shortcut. 
​
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●​ Ensure that you are typing the correct keyboard shortcut. It must be typed exactly as it 
was entered when creating the keyboard shortcut. 

Glossary 

Overview 
Switcher terminology is, for the most part, universal, although some terms may be specific to 
geographical area or even facility. 

Active Transition 
In the Transition Area, the transition that is currently selected; the transition that is performed 
when you click AUTO or PRESET BLACK. 

Air 
Video and audio that the viewer sees and hears on their television or mobile device. 

Atlas (Specific to PRIME) 
Server application that streams the PRIME Switcher interface, including the multiviewer. See 
Configure Atlas for additional information. 

Background (BKGD) 
Video input in any mix effect, that can be overlaid by clips and graphics. In the following figure, 
the anchor is the BKGD (video input), and the surgical scene and the accompanying text are 
overlays of other sources applied via keying. 
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See Work with Work with Main and Mix Effect (ME) Banks and Transitions. 
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Bank - Main Bank 
Controls used to set a video mix effect, including a video source as the background for the 
video mix, the sources to be keyed over the background, and the transition effect performed as 
the video mix is transitioned to output. The output of the Main Bank is displayed in the 
Program monitor. A bank may be referred to as an ME Bank, or simply, an ME. 

 

See Work with Work with Main and Mix Effect (ME) Banks and Transitions. 

Bank - Mix Effect Bank (ME1) 
Controls used to create, save, and load a mix, which includes a video source as the 
background for the video mix, the sources to be keyed over the background, and the transition 
effect performed as the video mix is transitioned to output. You can select the output of ME1 
as a source for the Main Switcher Bank. The output of the ME1 Bank is displayed in the Mix 
Effects monitor. 

 

See Work with Work with Main and Mix Effect (ME) Banks and Transitions. 

Black (BLK) 
Reference (sync) signal. Also known as Genlock. 
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Box, 2-Box, 3-Box, 4-Box, Etc. 
Video layered over the background, scaled, and positioned to allow simultaneous display of 
multiple video sources. A common example is that of an anchor interviewing one or more 
remote interviewees. 

 

 

See Create a Digital Video Effect for information on how to create a simple DVE. 
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Bug 
Small graphic, usually displayed at a corner of the screen. There are many types of bugs, e.g., 
station logo, sponsor logo, “Live” graphic, sports scores. 

 

Bus 
Row of buttons, with each button accessing an input source - such as camera or external 
graphics device - or an internal source, such as PRIME CG graphics or the output of another 
ME Bank. When a Bus button is active, it displays as lit. Each PRIME Switcher ME Bank 
includes three Buses: 

​
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●​ Program: Selected source displays a red light when active. 
●​ Preset: Selected source displays a white light when active. 
●​ Key: Selected source displays a red light if active on Program, or a white light if active 

on Preview. 

The following figure shows the Main and ME1Bank Buses: 

 

See Work with Work with Main and Mix Effect (ME) Banks and Transitions. 

Chroma Key 
Chroma: Composites video based on a specified Key Color, also known as a Target Color. 
The specified chrominance (Target Color) is removed, and is replaced by other video. Chroma 
Key is commonly used for weather reports and virtual sets. The meteorologists/anchors 
present in front of a green screen, and the weather or virtual set graphics are keyed in any area 
that is the color specified as the Key Color. 
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Clean Feed 
Only the video that is in Main Bank Program, with no key video. A typical Clean Feed setting 
in a studio outputting SDI would be Matrox SDI. Note that a Clean Feed displays only on the 
Device specified Config > Playout Config > Video Channels, e.g., SDI, NDI, etc. It does not 
display in the PRIME Switcher interface. 

Clip 
Video recorded to a file. You can use clips as the background or an element of a graphic, as 
the background source for a switcher mix effect or as a switcher key source. See Work with 
Clips and Clip Player for information on working with clips. 

Clip Player 
PRIME Switcher interface component used to play a clip. The Clip Player can also play an 
image. See Work with Clips and Clip Player for information on working with clips. 

Crosspoint 
In a hardware-based switcher, a switch that enables video to be routed from a specific input to 
any output. In PRIME Switcher, this is achieved via software. 

​
 

424 | PRIME 5.3 Switcher User Guide​
​
 



Digital Video Effect (DVE) - PRIME Scene 
The application of sizing, rotation, positioning, croppings, or other manipulation to video within 
a PRIME Scene. In addition to the DVEs provided in PRIME Switcher, you can create complex 
DVEs with PRIME Designer. They are prepared in advance for use as keys in the PRIME 
Switcher. Examples include multi-boxes and complex transition effects. 

The following figure shows a 2-box DVE with input video. 

 

The following shows a 4-box DVE as it appears without input video. 

 

See Create a Digital Video Effect for information on how to create a simple DVE in PRIME 
Designer. 

​
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Digital Video Effect - PRIME Switcher 
The application of sizing, positioning, cropping, and/or a border to a Key channel from within 
PRIME Switcher. See PRIME Switcher DVE (Digital Video Effect). 

 

Downstream Keyer (DSK) 
Switcher function that transitions the selected Key On/Off. PRIME Switcher also provides the 
ability to set Key sources from the Downstream Keyer. See Work with Work with Main and 
Mix Effect (ME) Banks and Transitions. 

Graphic, Scene 
Image or animation that can overlay video or that can occupy the full screen, typically used as 
a person/place identifier, information/statistics display, logo display, score display, etc. In 
PRIME, a graphic is referred to as a Scene. “Graphic” and “Scene” are used interchangeably 
in this User Guide. A message is a type of scene that references assets, and is therefore 
smaller in file size than its corresponding scene. See Bug, Lower Third, Over-the-Shoulder 
(OTS) for examples. See Work with Graphics and Graphics Player for information on working 
with graphics. 

Graphics Player 
PRIME Switcher Interface component used to play a scene or message. The Graphics Player 
can also play an image or clip. See Work with Graphics and Graphics Player for information on 
working with graphics. 

​
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Key 
Video signal that is used to "cut a hole" in another video signal, allowing the insertion of other 
video elements (text, graphics, other video). Key video can have varying levels of transparency, 
enabling underlying video to show through. A Key can be set to a PRIME graphic or other 
source. See What is a Key?. 

Keypad 
A UI representation of a physical keypad that provides keypad functions, including clip, 
graphic, and Mix Effects Preset ID entry, plus Load, Play, Save, Delete and Clear. 

Keyer 
Button that inserts a Key in either Preview or Program. See Work with Work with Main and Mix 
Effect (ME) Banks and Transitions. 

Linear Key 
Key in which the video is composited with other video. Linear Key is typically used to overlay 
graphics over video. 

Lower Third, Lower 3rd 
Graphic that occupies the lower part of a screen. Typically, the graphic identifies a person, 
place, or event. 

 

​
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Mix Effect (ME) 
Mix Effect(s) is used in the following contexts in this PRIME Switcher: 

●​ The mixed video, which includes: 

○​ Selection of a source as the background. 
○​ Selection of the source(s) to be keyed over the background. 
○​ How the ME transitions. 

●​ Mix Effect Bank (ME1): When referencing the Preset, Program and Key Buses, 
Transition Area and Downstream Keyer associated with the Mix Effect Bank. 

●​ Mix Effect Preset: Mix Effect Bank settings that you can save, load, and modify. 

See Work with Work with Main and Mix Effect (ME) Banks and Transitions. 

Over-the-Shoulder (OTS) 
Graphic displayed to the upper left or right, i.e., over the shoulder of an anchor. 

 

Message 
A graphic, based on a scene template, that references replaceable text and/or replaceable 
scene assets. As such, a message file is smaller than its corresponding scene file. See Edit 
Message and the PRIME User Guide for additional information. See Work with Graphics and 
Graphics Player for information on working with messages. 

​
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Multiviewer 
Software/hardware that enables multiple video sources to be displayed on a single screen. The 
PRIME Switcher UI features a multiviewer. 

Physical Keypad 
A hardware-based external keypad that provides the ability to enter ID number, and depending 
upon type, may also include clip, graphic, and Mix Effects Load, Play, Save, Delete and 
Clear functions. A physical keypad may be free-standing, or incorporated into a larger 
keyboard, including the Chyron Advanced Keyboard, or a PC keyboard. 

Playlist 
A list of PRIME graphics and/or clips that can be played in or out of order through the 
Graphics Players and Clip Players. See Configure Playlist Players and PRIME Playlist 
Graphics and Clip Playback within PRIME Switcher. 

Preview 
Preview is used in the following contexts in PRIME Switcher: 

●​ Switcher: Video/clips/graphics/Mix Effects to be transitioned to Program. See Work 
with Work with Main and Mix Effect (ME) Banks and Transitions. 

●​ Graphics Player: Graphics mix to be transitioned to Graphics Player Program. See 
Work with Graphics. 

Program 
Program is used in the following contexts in PRIME Switcher: 

●​ Switcher Program Output: Video/clips/graphics mix that is output from the switcher. 
See Work with Work with Main and Mix Effect (ME) Banks and Transitions. 

●​ Main Program Bus: The video input that is selected for the video mix to be sent to 
Program output. The display of the video input selected in the Program Bus depends 
upon the Transition Area BKGD setting. See Next Transition Selection. 

●​ ME1 Program Bus: The video input that is selected for the video mix to be sent to Mix 
Effects output, which can, in turn, be sent to the Main Bank ME1 input. The display of 
the video input selected in the ME1 Program Bus depends upon the Transition Area 
BKGD setting. See Next Transition Selection. 

​
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●​ Graphics Player: Graphics mix that is output from the Graphics Player. In order for the 
contents of Graphics Player Program to route to switcher Program, the graphics 
channel (e.g., GFX1) associated with the Graphics Player (e.g., Graphics 1) must be 
selected as a graphics input on the Downstream Keyer. 

Project 
The main PRIME “container” that holds all of the assets associated with a specific show, 
production, look, etc. Assets include scenes, images, clips, playlists, scripts, and more. 

Scene, Graphic 
See Graphic, Scene, Work with Graphics and Graphics Player for information on working with 
graphics. 

Sub Channel 
In PRIME, defined areas of an output channel. Each Sub Channel, e.g., scene or clip, is 
defined by its resolution and its “X” and “Y” position within the output channel. Each PRIME 
Sub Channel can have its own preview and output in the main UI. 

Each Graphics and Clips Sub Channel can have an associated browser that shows, e.g., only 
scenes with the exact same resolution as the Sub Channel itself, to ensure that only scenes 
designed for that resolution are available. 

In PRIME Switcher, you can set a Sub Channel to Preview, Graphics, Clips or Mix Effects. 
“X” and “Y” are set to 0, 0, respectively, i.e., the entire screen area. 

See Configure PRIME Video and Audio and the PRIME Playout Configuration Guide. 

Swap 
Exchange of the contents of the Program channel and Preview channel when a transition is 
performed. See Work with Work with Main and Mix Effect (ME) Banks and Transitions. 

​
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Switcher/Video Mixer/Vision Mixer 

Software application or hardware device that receives inputs from cameras, routers, video 
servers, graphics and clip systems, web, and other sources, and provides the controls to mix 
and output video for a production.  

Throughout this document, the term “Switcher” is interchangeable with the terms “Video 
Mixer” and “Vision Mixer.” PRIME Switcher also provides audio mixing. 

Switcher/Technical Director (TD) 
Person who operates the switcher. 

Take 
Command given by the Director to the TD, to perform a specific action. Example: “Take 1” 
specifies that the TD transition Camera 1 to Program. 

Transition 

Change of state in which the contents of Preview are swapped with the contents of Program. 
“Transition” is used as both a noun and a verb. See Configure Transitions and Work with Main 
and Mix Effect (ME) Banks and Transitions. 

Transition Type, Transition Effect, Transition 
Effect that is applied as video transitions from Preview to Program. PRIME provides four 
built-in Transition Types: Cut, Dissolve, Wipe, and Preset Black. You can set Dissolve and 
Wipe parameters directly within the PRIME interface, and build more complex, custom 
transitions within PRIME that you can add to PRIME Switcher. See Configure Transitions and 
Work with Main and Mix Effect (ME) Banks and Transitions. 

 

​
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PRIME Switcher File Formats 
Overview 
PRIME and PRIME Switcher use many proprietary file formats. File formats employed by or 
specific to PRIME Switcher are as follows. 

*.config Configuration File 
PRIME configuration file. 

*.mep Mix Effect Preset 
Mix Effect Preset file. 

*.gtc PRIME Clip File 
PRIME Clip file format that can be incorporated into individual PRIME scenes. 

*.pbm PRIME Message File 
PRIME Message file, created within PRIME, and used as graphic overlays in PRIME Switcher. 

*.pbx PRIME Scene File 
PRIME Scene file, created within PRIME, and used as graphic overlays in PRIME Switcher. 

*.pct Clip Transition File 
PRIME Clip Transition file, created within PRIME, and that can be applied when transitioning 
between clips in the PRIME Switcher Clip Player, or when performing a PRIME Switcher 
transition. See Clip Transitions. 

*.ppc PRIME Power Clip File 
PRIME Clip file format that is not part of an individual PRIME scene, but that can play from an 
independent Clip Player created within PRIME configuration. You can edit a clip as a PRIME 
Power Clip. 

*.psk PRIME Keyboard Shortcut File 
PRIME Keyboard Shortcut file, created within PRIME Switcher (also available to PRIME), that 
stores a set of Keyboard Shortcuts. See Keyboard Shortcut Manager. 

​
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*.ppl PRIME Playlist File 
PRIME Playlist file, which contains the scene/message/clip rundown. See Play Back 
Graphics/Messages/Images/Clips from the PRIME Playlist. 

*.pst PRIME Switcher Transition File 
PRIME custom Switcher Transition file, created within PRIME and that is applied when 
performing a PRIME Switcher Transition. Examples include Slide, Split, Mask. A *.pst file 
cannot be set as a PRIME Switcher Clip Player transition. See Configure Transitions. 

*.swxpl PRIME Switcher Layout 
PRIME Switcher Layout file, saved within PRIME Switcher, that stores a PRIME Switcher UI 
layout. See UI Layout.  

​
 

433 | PRIME 5.3 Switcher User Guide​
​
 



 

​
 

434 | PRIME 5.3 Switcher User Guide​
​
 


	Chapter 1: Welcome 
	About the PRIME Live Platform 
	About PRIME Switcher 
	Flexible Usability 
	Function and Specification Overview 

	About Playout and Switcher Control 
	External Monitor Display 
	Device Control 
	Best Practices 
	Avoid Last-Minute Configuration Changes 
	Do Not Perform Updates without Testing 
	Save Layouts and Configurations for Future Use 
	Ensure that Scenes, Images, and Clips are Correctly Formatted 
	Ensure that All Necessary Assets Are Available 
	Ensure that There are No Keyboard Shortcuts Conflicts 
	Rehearse! 

	PRIME Documents 
	PRIME Document Location 
	About this Document 
	Conventions 


	Chapter 2: PRIME Switcher Basics 
	Switcher Operation 
	Basic Functions of a Switcher 

	Chapter 3: The PRIME Switcher User Interface 
	Start PRIME Switcher 
	Close and Restart PRIME 
	Close PRIME 
	PRIME Settings - General 
	Overview and Access PRIME Settings - General 
	General Settings 
	Prompt Before Closing 
	Prompt Administrator Warning on Startup 
	Prompt for Playout Configuration 
	Export Settings 
	Import Settings 

	Status Settings 
	Status Overview 
	In Circuit on Startup 
	Show Bypass Indicator 
	Show SDI Input Indicators 

	Layout Setting 
	Auto Save Layout 


	Close and Restart PRIME without Change to Configuration 
	Close and Restart PRIME with Change to Configuration 
	Configure Startup Scenes 
	Startup Scenes Overview 
	Add Startup Scenes 
	Remove Startup Scenes 


	UI Layout 
	Overview 
	Component Display 
	About the Default Layout 
	Display Recent Layout 
	 
	Reset Layout to Default 
	Edit the Layout 
	Revert from Edited Layout to Saved Layout 
	Save a Layout 
	Save a Layout under a Different Name 
	Load a Layout 
	Delete a Layout 

	Switcher Components Overview 
	What is a PRIME Switcher Component? 
	Enable/Disable Component Display 
	Close a Component 

	Resize and Reposition Components 
	Overview 
	Component Aspect Ratio 
	Resize Monitor Row or Switcher Bank Height 
	Resize Component Height 
	Resize Component Width 
	Reposition an Individual Component 
	Float a Component 
	Resize a Floated Component 
	Insert a Component to the Left, Right, Above or Below Another Component 
	Insert a Component at the Edge of the PRIME Switcher UI 

	Tab Groups 
	Tab Group Overview 
	Display Multiple Components in a Tab Group 
	Create Tab Group Using the Guide Diamond 
	Display a Specific Component of a Tab Group 
	Reposition a Tab within a Tab Group 
	Remove a Tab from a Tab Group 

	Other Tab Operations 
	How Do I Locate a Hidden Tab? 
	How Do I Reset the Tabs on the PRIME Switcher Interface? 

	Project Operations 
	Project Overview 
	Open a Project 
	Create a New Project 
	Delete a Project 
	Remove a Project 
	Remove All Projects 
	Display a Project that Has Been Removed 
	Publish, Unpublish a Project 
	Zip a Project 

	Recall Elements 
	Recall Element Overview 
	Recall Area/Recall Box 
	Recall Area/Recall Box Overview 
	Select a Graphics Player, Clip Player, or ME1 (Mix Effects) Bank 
	Set Visibility of Recall Area Components 
	Enter Clip, Graphic, or Mix Effect Preset ID Number Directly in the Recall Box 

	Keypad 
	Keypads and Keyboards 
	Keypad/Keyboard Type Overview 
	PRIME Switcher Numeric Keypad 
	Physical Numeric Keypad 
	Alphanumeric Keyboard 

	Keypad Overview 
	Set Operability of Keypad Components 
	Select a Graphics Player, Clip Player, or ME1 (Mix Effect) Bank 
	Enter Clip, Graphic, or Mix Effect Preset ID Number 
	Enter a Clip, Graphic, or Mix Effect Preset ID Number by Navigating the Browser 
	Clear the Recall Box in the Recall Area 

	Playout Settings 
	Playout Settings Overview 
	Set Physical Keypad Automatic Focus Enable/Disable 
	Set Keypad Entry Track Recall per Channel 
	Set Visibility/Operability of Recall Area and Keypad Components 

	Mix Effects Load/Save Recall Field 
	Layout Recall Dropdown 

	Assets Browser 
	Banks and Buses 
	Switcher Bank 
	Bus Overview 
	Set Source Names on Buttons 
	Set Video Input Display 
	Set Single Grid Window or Individual Windows 
	Adjust Spacing between Monitors in Single Grid WIndow 

	Preset Bus 
	Program Bus 
	Key Bus 

	Transition Area 
	Downstream Keyer 
	Clip Player 
	Graphics Players 
	Audio/Audio Mixing 
	Workflow Logger 
	Automation Monitor 
	Parameters 
	Playlist Player 
	SDI Input, Genlock, Bypass Status Indicators 

	Chapter 4: Configure PRIME Video and​Audio Channels 
	Overview 
	Switcher Component Display 
	Configure System Audio as an Output 
	Troubleshoot Configuration 

	Chapter 5: Configure PRIME Switcher 
	Overview 
	Access PRIME Switcher Configuration 
	Configure Switcher Opening Project, Layout and Shortcuts 
	Apply and Activate Configurations in PRIME Switcher 
	Switcher Output Configuration 
	Save PRIME Switcher Configuration 
	Recall Configuration 
	Create New Configuration 
	License 
	Auto Config 

	Chapter 6: Configure Clip Players 
	Overview 
	Add Clip Player 
	Configure Clip Player 
	Remove Clip Player 

	Chapter 7: Configure Sources 
	Overview 
	Access the Sources Configuration Panel 
	Enable GPI Tallies, Configure Tally Pins 
	Enable GPI Tallies 
	Configure Tally Pins 
	GPI Tally for NDI Source 

	Pass VANC from Background 
	Add a Video Source 
	Rename a Video Source 
	Reconfigure an Existing PRIME Switcher Video Source 
	Delete a Video Source 
	Configure Switcher Program, Preset, Key Bus Display Order 
	Add the ME1 Bank 

	Chapter 8: Configure Atlas 
	Overview 
	Configure Grid 
	Configure Label Display - Show Label 
	Add Channel Display 
	Relabel a Channel 
	Delete a Channel Display 
	Reorder Channel Display 

	Chapter 9: Configure Transitions 
	Overview 
	Access the Transitions Configuration Panel 
	Add Transition 
	Transition Types 
	Overview 
	Cut 
	Dissolve 
	Wipe 
	Custom 

	Rename Transition Effect 
	Reconfigure an Existing PRIME Switcher Transition Effect 
	Delete a Transition 
	Sort the Transition List 
	Configure Transition Effect Button Display Order 

	Chapter 10: Configure Playlist Players 
	Overview and Access the Playlist Configuration Panel 
	Add Playlist Player 
	Enable a Playlist 
	Delete a Playlist 

	Chapter 11: Configure Audio Channels 
	Overview 
	Access the Audio Channels Configuration Panel 
	Set Duck Frame Count 
	Add an Audio Channel 
	Rename an Audio Source 
	Reconfigure an Existing PRIME Switcher Audio Source 
	Delete an Audio Source 
	Configure Audio Fader Display Order 

	Chapter 12: Configure Audio Buses -​Mix Minus, Pre Fade Listen 
	Overview 
	Configure Auxiliary Audio Channels 
	Configure Audio Buses 
	Display Audio Bus and Set Level(s) 

	Chapter 13: Assets Browser 
	Overview 
	Assets Browser Types 
	Overview 
	Non-Asset Type-Specific Browser 
	Asset Type-Specific Browser 

	Similarities and Differences between the Assets Browser Types 
	Select a Browser in a Multi-tab Assets Browser 
	Add an Assets Browser 
	Change to a Different Assets Browser Type 
	Delete an Assets Browser 
	Assets Browser Operations 
	Asset Viewer 
	Common Folder 
	Search Assets Browser 
	Overview 
	Perform a Quick Search 
	Cancel Search 
	What If the Search Produces No Results? 
	Save Search 
	Retrieve Search 
	Edit Search 
	Add Search 
	Remove Saved Search 
	Clear Search 
	Advanced Search 

	Assets Browser Display Settings 

	Chapter 14: Work with Main and Mix Effect (ME) Banks and Transitions 
	Overview 
	Main Bank vs. Mix Effect (ME1) Bank 
	Mix Effect Bank vs. Mix Effect (ME1) Preset 
	Set Preset, Program, Key Buses 
	Transitions 
	What Can Transition? 
	What is a Key? 
	Set Transition Area 
	Overview 
	Next Transition Selection 
	Overview 
	Background (BKGD) 
	KEY 1 - 4 (KEY1, KEY2, KEY3, KEY4) 

	Transitions 
	Perform Transition 
	Overview 
	Perform CUT 
	Perform Transition 
	Perform Transition to Black then to Program 

	Set a Key Source 

	Downstream Keyer 
	Overview 
	Set Key Mode 
	Key Mode Overview 
	Set Linear Key 
	Set Chroma Key 
	Set Key Color via Color Picker Standard Settings 
	Set Key Color via Color Picker Advanced Settings 
	Set Key Color via Eyedropper 

	Perform a Key Transition 

	PRIME Switcher DVE (Digital Video Effect) 
	PRIME Switcher DVE Overview 
	Reset Settings to Default 
	Enable/Disable DVE 
	Set DVE Position 
	Set DVE Size 
	Set Crop 
	Set Border 
	Exit and Apply DVE Settings 
	DVE Exercise 

	Tying Together the Transition Area, Key Bus and Downstream Keyer 
	Overview 
	What Happens When You Activate (Select) a Key Source? 
	What Happens When You Deactivate (Deselect) a Key Source? 
	What Happens When You Change a Key Bus or Downstream Keyer Source? 
	Set up Graphics 1 on Program, and Graphics 2 on Preview 

	Mix Effect Presets 
	Mix Effect Overview 
	Mix Effect Operations 
	Mix Effect Preset Operations from the Keypad 
	Mix Effect Preset Operations from the Recall Area/Recall Box 

	Create a New or Edit an Existing Mix Effect Preset 
	Save a Mix Effect Preset 
	Load/Play (Apply) a Mix Effect Preset 
	Load/Play (Apply) Overview 
	Load/Play (Apply) Mix Effect Presets 

	Delete Mix Effects ID from Recall Box 

	Troubleshoot Transitions 
	Preview Video Does Not Transition to Program 
	Preview Video Transitions to Program, When It Should Not 
	Key Video Does Not Transition to Program​In the Transition Area, the desired KEY is not active (unlit). 
	Key Video Transitions to Program, When It Should Not​In the Transition Area, the desired KEY is active (lit). 
	Graphics 1 and Graphics 2 Both Display in Program, or​Both Display in Preview, When They Should Alternate 
	The Graphic(s) Plays, but Does Not Transition to/from​Switcher Program 
	ME1 (Mix Effect) Output Does Not Display on Program or Preview 


	Chapter 15: Work with Clips 
	Overview 
	Clips Browser 
	Clip Edit Functions 
	Edit Clip 
	Clip/Sub Clip Parameters 
	Overview 
	Clip 
	Metadata 
	Playback 
	Set Trim and Loop 
	Preview the Clip 

	Edit Power Clip 
	Generate Sub Clip 

	Clip Player 
	Clip Player Overview 
	Clip Player Cued and Playing Channels vs. Switcher Preview and Program Channels 
	Clip Operations 
	Clip Player Selection 
	Clip Operations from the Clip Player 
	Clip Operations from the Keypad 
	Clip Operations from the Recall Box Are/Recall Box 
	Clip Operations from the Clips Browser 
	Clip Operations Summary 

	Enable/Disable Transport Controls 
	Navigate the Clips Browser 
	Display the ID of the Previous Clip in the Browser 
	Display the ID of the Next Clip in the Browser 

	Load and Play Clips 
	Clip Load and Play Overview 
	Play a Clip via Drag and Drop 
	Load a Clip via Drag-and-Drop, then Play 
	Play a Clip from the Recall Area/Keypad 
	Load a Clip from the Recall Area/Keypad, then Play 
	Play a Cued Clip from the Clip Player 
	Play the Clip Whose ID is Currently Displayed in the Recall Box 

	Load and Play an Ordered Sequence of Clips 
	Clip Sequence Playout Overview 
	Load and Play an Ordered Sequence of Clips from the Recall Area 
	Load and Play an Ordered Sequence of Clips from the Keypad 

	Delete Clip ID from Recall Box 
	The Clip Plays, but Does Not Display in Switcher Program or Preview 
	Loop a Clip 
	Stop a Clip, with Ability to Replay 
	Stop Clip Overview 
	Stop a Clip from the Clip Player, then Replay 
	Stop a Clip via the Clips Browser 

	Clear a Clip from the Clip Player 
	Clip Transitions 
	Overview 
	Select a Clip Transition 
	Switch to a Different Transition 
	Import a Transition 
	Inactivate (Deselect) a Transition 


	Use Image as Clip in Clip Player 
	Add Image as Clip 
	Clip Playback via PRIME Playlist and PRIME Commander 

	Chapter 16: Work with Graphics 
	Overview 
	Scenes/Messages Browsers 
	Scene and Message Edit Functions 
	Edit Scene 
	Edit Message 
	Overview 
	Save Mode 
	Create Messages 
	Edit Existing Message 
	View Asset File Path 
	Sort Messages 
	Refresh View 
	Play Messages 


	Import Graphic(s) 
	Graphics Player 
	Graphics Player Overview 
	Graphics Player Preview and Program Channels vs. Switcher Preview and Program Channels 
	Display Graphics Player Program and Preview Channels in Separate Monitors 
	Graphics Operations 
	Graphics Player Selection 
	Graphics Operations from the Graphics Player 
	Graphics Operations from the Keypad 
	Graphics Operations from the Recall Area/Recall Box 
	Graphics Operations from the Scenes and Messages Browsers 
	Graphics Operations Summary 

	Navigate the Graphics Browser 
	Set Active Scenes or Messages Browser 
	Display the ID of the Previous Graphic 
	Display the ID of the Next Graphic 

	Load and Play Graphics 
	Graphics Load and Play Overview 
	Select from Multiple Graphics in the Graphics Player Program or Preview Channel 
	Play Graphics via Drag and Drop 
	Load Graphics Using Drag and Drop 
	Load Graphics Using the Keypad/Recall Area 
	Load Graphics via the Scenes or Messages Browser Context Menu 
	Play Graphics from the Graphics Player Preview Channel 
	Play Graphics Using the Keypad 
	Play a Graphic via the Scenes or Messages Browser Context Menu 
	Play Graphics from the Keypad/Recall Area without Loading Graphics  

	Stop: Apply Effect Out and Transfer to Graphics Player Preview 
	Stop Overview 
	Stop a Graphic from the Graphics Player  
	Stop a Graphic via the Scenes or Messages Browser Context Menu 

	Close: Apply Effect Out, Do Not Transfer to Preview Channel 
	Clear: Remove Graphic Using a Cut 
	Clear Graphic Overview 
	Clear a Graphic via the Scenes or Messages Browser 
	  
	Clear a Graphic Using the Keypad 

	Delete Graphics ID from the Recall Box 
	The Graphic Plays, but Does Not Display in Switcher Program or Preview  
	The Graphic Plays, but Does Not Display in Switcher Program or Preview 

	Graphics Playback via PRIME Playlist and PRIME Commander 

	Chapter 17: PRIME Playlist Graphics and​Clip Playback within PRIME Switcher 
	Overview 
	Display Playlist Player 
	Playout Modes 
	Playlist Player in Detail 
	Edit Playlist Appearance 
	Create New Playlist 
	Load Existing Playlist 
	Reposition a Playlist Item 
	Add Comment to Playlist 
	Override Scene/Message Replaceables and Play Transitions 
	Disable/Enable Playlist Item 
	Delete Item from the Playlist 
	Play the Playlist 
	Sequence Mode 
	Set Pause before Play for an Item 
	Take List Mode 
	Playlist Playout State 

	Set Duration 
	Stop a Playlist (Sequence Mode Only) 
	Loop the Playlist (Sequence Mode Only) 
	Change Playout Channel 
	Change Playout Layer 
	Change Clip/Image Transition Effect 
	Clear Playlist 
	Close Playlist Player 

	Chapter 18: Create a PRIME DVE Scene 
	Chapter 19: Work with Audio 
	Overview 
	Audio Controls 
	Overview 
	Change Audio Level 
	Display Audio Bus and Set Level(s) 
	Set Mute 
	Set Delay 
	Set Follow Video (MAIN Audio Bus Only) 
	Follow Video vs. Follow Audio 
	Set Follow Video 

	Remove a Follow Video Source 
	Disable Follow Video 


	Chapter 20: Keyboard Shortcut Manager 
	Overview 
	Set a Keyboard Shortcut to an Existing Function 
	Save a Set of Keyboard Shortcuts 
	Load Set of Keyboard Shortcuts 
	Add a New Keyboard Shortcut File 
	Clear Selected Keyboard Shortcut(s) 
	Reset Keyboard Shortcuts to Default 
	Keyboard Shortcut Troubleshooting 

	Troubleshooting 
	PRIME Switcher Interface 
	Video Inputs, Clips and Graphics Are Frozen 
	Components Are Missing from the Switcher Interface 
	A Component Tab Had Displayed, but Is Now Missing 
	The Interface Displays Multiple Tabs with the Same Name 
	I Need to Reset the Layout 

	PRIME Switcher Application Message 
	Exception - Not Enough Space on the Disk 

	Search 
	I Performed a Search, but There were No Results 

	Transitions 
	Preview Video Does Not Transition to Program 
	Preview Video Transitions to Program, When It Should Not 
	Key Video Does Not Transition to Program​In the Transition Area, the desired KEY is not active (unlit). 
	Key Video Transitions to Program, When It Should Not​In the Transition Area, the desired KEY is active (lit). 
	Graphics 1 and Graphics 2 Both Display in Program, or​Both Display in Preview, When They Should Alternate 
	ME1 (Mix Effect) Output Does Not Display in Program or Preview 

	Graphics 
	The Graphic(s) Plays, but Does Not Transition to Switcher Program or Preview 

	Clips 
	The Clip Plays at the Incorrect Speed and/or Aspect Ratio 
	The Clip Plays, but Does Not Display in Switcher Program or Preview 

	DVE 
	The DVE Graphic Displays, but the Video Input(s) Is​Missing or Incorrect 

	Keyboard Shortcuts 
	Note about Keyboard Shortcuts 
	Keyboard Shortcut Does Not Work 
	Keyboard Shortcut Performs an Unexpected Action 


	Glossary 
	Overview 
	Active Transition 
	Air 
	Atlas (Specific to PRIME) 
	Background (BKGD) 
	Bank - Main Bank 
	Bank - Mix Effect Bank (ME1) 
	Black (BLK) 
	Box, 2-Box, 3-Box, 4-Box, Etc. 
	Bug 
	Bus 
	Chroma Key 
	Clean Feed 
	Clip 
	Clip Player 
	Crosspoint 
	Digital Video Effect (DVE) - PRIME Scene 
	Digital Video Effect - PRIME Switcher 
	Downstream Keyer (DSK) 
	Graphic, Scene 
	Graphics Player 
	Key 
	Keypad 
	Keyer 
	Linear Key 
	Lower Third, Lower 3rd 
	Mix Effect (ME) 
	Over-the-Shoulder (OTS) 
	Message 
	Multiviewer 
	Physical Keypad 
	Playlist 
	Preview 
	Program 
	Project 
	Scene, Graphic 
	Sub Channel 
	Swap 
	Switcher/Video Mixer/Vision Mixer 
	Switcher/Technical Director (TD) 
	Take 
	Transition 
	Transition Type, Transition Effect, Transition 

	PRIME Switcher File Formats 
	Overview 
	*.config Configuration File 
	*.mep Mix Effect Preset 
	*.gtc PRIME Clip File 
	*.pbm PRIME Message File 
	*.pbx PRIME Scene File 
	*.pct Clip Transition File 
	*.ppc PRIME Power Clip File 
	*.psk PRIME Keyboard Shortcut File 
	*.ppl PRIME Playlist File 
	*.pst PRIME Switcher Transition File 
	*.swxpl PRIME Switcher Layout 


